Trying to connect OS TW to my Windows 2016 AD


[/b]LaptopDistributor ID: openSUSE
Description: openSUSE Tumbleweed
Release: 20191231

Windows 2016 Std
Fully patched

LANBoth Device on same lan
/etc/resolv.conf using
domain paedave.local
search lan
nameserver <ip of Windows 2016 Server>

What Am I trying to do?

I am trying to set my laptop up so I can use my domain login, to login to the laptop both when connected to the LAN and when offline (away from the lan) I have been trying to do this using Yast

Process Followed

[li]Open yast2 and navigate to Network Services -> User Logon Management [/li][/ol]

[li]Open “Change Settings” [/li][li]Now, enable “Allow Domain User Logon”, Enable domain data source -> “Users”; “Groups” [/li][li]Open Join Domain[/li][LIST=1]
[li]Insert Domain Name “like” [/li][li]ID-Provider is Active Directory [/li][li]Auth-Provider is Active Directory [/li][li]Enable Domain [/li][/ol]

[li]In the next panel, activate “Read all entities from backend database” [/li][li]Then, type in your Active Directory Domain controller like “”. [/li][li]On the next panel, authenticate with a superuser like “Administrator” who is able to execute a domain join. [/li][li]Finish the domain join [/li][/LIST]


[/b]When I get to the last auth-client screen there is no Workgroup listed

So after clicking on OK, I a message telling me that the domain join failed because the Workgroup name is blank and should be PAEDAVE


[/b]On the auth client screen how do I get the WORKGROUP set, as when i load up the SAMBA screen on the Laptop it does say PAEDAVE.

[b]Troubleshooting Attempted

[/b]When I run from the command linedavid@linux-7u1e:~> sudo net ads join -U Administrator
Enter Administrator’s password:
Using short domain name – PAEDAVE
Joined ‘LINUX-7U1E’ to dns domain ‘paedave.local’

This works as when i run

sudo wbinfo -g

I see my domain groups


How do I do this using yast?
Am I better doing this from the command line? (If so could someone point me to some instructions)