Results 1 to 3 of 3

Thread: cuda on leap 15

  1. #1
    Join Date
    Jul 2014
    Location
    Iran
    Posts
    19

    Default cuda on leap 15

    Hi Friends,

    HP EliteBook
    Core i7 2.7
    GPU: Quadro FX 2700
    8GB RAM

    I was using cuda which was installed with the following run files on leap 42.3.
    Code:
    cuda: "cuda_6.5.14_linux_64.run" 
    driver: "NVIDIA-Linux-x86_64-340.32.run". 

    Due to my unreliable internet connection I prefer using run files rather than using yast!

    Today I updated to leap 15 but none of the above files was useful. So I downloaded following
    files which was the only options for my configuration.
    Code:
    NVIDIA-Linux-x86_64-340.106.run
    cuda_9.2.88_396.26_linux.run
    

    But The problem is cuda-9.2 requires at least driver version 388 which is not available for my gpu.
    Also cuda-6.5 does not work with gcc 7 and other files in leap 15.

    Would you please give me a solution?

  2. #2
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: cuda on leap 15

    What miracles do you expect? Your options (in no particular order) are

    - convince or pay nVidia to support your card with newer software
    - do not upgrade to Leap 15 (what was the reason in the first place?)
    - manually build needed GCC version and use it
    - find other distribution that supports required combination of nVidia driver/CUDA/gcc

    But all that should have been obvious ...

  3. #3
    Join Date
    Apr 2011
    Location
    planet earth
    Posts
    13

    Default Re: cuda on leap 15

    The Nvidia developer site gives information of working combinations.
    https://developer.nvidia.com/cuda-toolkit

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •