Results 1 to 7 of 7

Thread: No sound in Supertuxkart

  1. #1

    Default No sound in Supertuxkart

    Hello, I have KDe4.11, opensuse 13.1 64bit, installed supertuxkart and no sound.

    In command line I can see:

    Code:
    AL lib: (EE) oss_open_playback: Could not open /dev/dsp: No such file or directory
    WARNING: Could not open the default sound device.
    Any idea what could solve it?

    Thank you,

    Martin

  2. #2

    Default Re: No sound in Supertuxkart

    Quote Originally Posted by atilius View Post
    Code:
    AL lib: (EE) oss_open_playback: Could not open /dev/dsp: No such file or directory
    WARNING: Could not open the default sound device.
    How did you install supertuxkart?

    Aparently it wants to use Oss, but you don't have the alsa oss emulation enabled.

    But normally supertuxkart should just use Alsa or Pulseaudio.
    Maybe you have set openal to use oss?
    Could you post /etc/openal/alsoft.conf and ~/.alsoftrc (if it exists)?

  3. #3

    Default Re: No sound in Supertuxkart

    I have installed via one click

    alsoft.conf

    Code:
    drivers=oss,pulseaudio
    The second file I cant see...

  4. #4

    Default Re: No sound in Supertuxkart

    Quote Originally Posted by atilius View Post
    I have installed via one click

    alsoft.conf

    Code:
    drivers=oss,pulseaudio
    Change that to:
    Code:
    drivers=alsa,pulseaudio
    or
    Code:
    drivers=pulseaudio,alsa
    and it should work.
    Or maybe remove it completely. OpenAL should try all drivers automatically then.

  5. #5

    Default Re: No sound in Supertuxkart

    With the "drivers=alsa,pulseaudio" it makes nois. Empty file works! Thank you!

  6. #6

    Default Re: No sound in Supertuxkart

    Quote Originally Posted by atilius View Post
    With the "drivers=alsa,pulseaudio" it makes nois. Empty file works! Thank you!
    If pulseaudio is enabled (which it is by default on openSUSE) "drivers=pulseaudio,alsa" might be better (I added that to my previous post, I guess you missed it...).

    But an empty file (or none at all) is even better anyway, as openAL then just tries all drivers it knows and uses the first one that works.

  7. #7

    Default Re: No sound in Supertuxkart

    yes, I have overlooked that there are two options and different order Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •