No sound in Supertuxkart

Hello, I have KDe4.11, opensuse 13.1 64bit, installed supertuxkart and no sound.

In command line I can see:

AL lib: (EE) oss_open_playback: Could not open /dev/dsp: No such file or directory
WARNING: Could not open the default sound device.

Any idea what could solve it?

Thank you,


How did you install supertuxkart?

Aparently it wants to use Oss, but you don’t have the alsa oss emulation enabled.

But normally supertuxkart should just use Alsa or Pulseaudio.
Maybe you have set openal to use oss?
Could you post /etc/openal/alsoft.conf and ~/.alsoftrc (if it exists)?

I have installed via one click



The second file I cant see…

Change that to:




and it should work.
Or maybe remove it completely. OpenAL should try all drivers automatically then.

With the “drivers=alsa,pulseaudio” it makes nois. Empty file works! Thank you!

If pulseaudio is enabled (which it is by default on openSUSE) “drivers=pulseaudio,alsa” might be better (I added that to my previous post, I guess you missed it…).

But an empty file (or none at all) is even better anyway, as openAL then just tries all drivers it knows and uses the first one that works.

yes, I have overlooked that there are two options and different order :slight_smile: Thank you.