Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Epson Perfection 1670

  1. #1

    Default Epson Perfection 1670

    Using opensuse 11.1 kooka didn't detect the scanner 1670 if I login as normal user. If I am root kooka finds the scanner and works fine.

    Where is the problem?

    herhin

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Epson Perfection 1670

    Quote Originally Posted by herhin View Post
    Using opensuse 11.1 kooka didn't detect the scanner 1670 if I login as normal user. If I am root kooka finds the scanner and works fine.

    Where is the problem?
    I encountered a permissions issue on the scanner functionality in my mothers all-in-one-PC under openSUSE-11.1. The thread was here:
    HP all-in-one Deskjet F4280 - openSUSE Forums

    My specific post here:
    openSUSE Forums - View Single Post - HP all-in-one Deskjet F4280

    By adding the regular users to group "lp" I was able to scan successfully with kooka under KDE-3.5.10 on openSUSE-11.1.

    Note if you add your regular user to group "lp", you probably should restart (or completely log out of your desktop and log out of Linux - probably quicker to restart).

  3. #3
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,295
    Blog Entries
    1

    Default Re: Epson Perfection 1670

    Is it only for multifunction machines, or primarily Epson machines?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  4. #4

    Default Re: Epson Perfection 1670

    As you suggested I added the group ls and even root to the user but with no effect.

    This is what sane-find-scanner reports if I am normal user:

    found USB scanner (vendor=0x0ccd, product=0x0038) at libusb:004:005
    found USB scanner (vendor=0x04b8, product=0x011f) at libusb:004:002
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    and this if I am root:

    found USB scanner (vendor=0x0ccd [TerraTec GmbH], product=0x0038 [Cinergy T2]) at libusb:004:005
    found USB scanner (vendor=0x04b8 [EPSON], product=0x011f [EPSON Scanner]) at libusb:004:002
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    KDE is 4.1.3

    herhin

  5. #5
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,295
    Blog Entries
    1

    Default Re: Epson Perfection 1670

    Is there a way to determine the /dev/ location of the device?

    For example, whenever I first go to do DV editing on my system I have to plug in the camcorder and then chmod the /dev/raw1394 in order to access it.
    Code:
    chmod 777 /dev/raw1394
    After that, then the camcorder is fully accessible.
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Epson Perfection 1670

    Quote Originally Posted by herhin View Post
    As you suggested I added the group ls and even root to the user but with no effect.
    You did restart afterward, to ensure the new user permissions were fully applied?

    This could be a KDE-4.1.3 bug. It may be worth your while to spend some time surfing on this anomalous behaviour to see if it is KDE specific.

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: Epson Perfection 1670

    Quote Originally Posted by herhin View Post
    As you suggested I added the group ls and even root to the user but with no effect.

    herhin
    Group lp, not ls

  8. #8

    Default Re: Epson Perfection 1670

    My investigations about this topic give the following results:

    1. Using lshal I found the device name as /dev/bus/usb/004/002. Changing the permission with root by chmod 666 002, running kooka as user starts the scanner.
    2. After Restart and login as user: The scanner didn't start. Checking the permission of /dev/bus/usb/004/002 showed 644.
    Searching for the device name by lshal shows another link within /dev/bus/usb/xxx/xxx, so it would be necessary to make the changes after each start of the system, which would be very bad.

    So what to do???

    I didn't have this problem with 11.0.

    herhin

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Epson Perfection 1670

    Have a look at /etc/udev/rules.d for the scanner rules. I'm running openSUSE 11.0, so there may be differences, but I have 55-libsane.rules containing a list of supported scanners. The scanner attributes are listed along with 'lp' group assigned and permission settings. I also have a rule specifically for my Epson CX5500 called 70-libsane.rules:

    SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="083f", MODE="664", GROUP="users"
    You can see, that this rule has 'users' group assigned, but I could easily change this, and the permissions if I desired. You could create a custom rule for your device incorporating the desired permissions, and group. Name it something like 95-myscanner.rules to make sure it gets processed last.

  10. #10

    Default Re: Epson Perfection 1670

    Hi deano_ferrari,

    your reply gives the solution!! Thank you!
    I checked the file 55-libsane.rules and compared it with the 11.0-version. Curious enough, in 11.1 the rule for the 1670 is commented out. Why??? The GROUP is lp, which I added to the user before. Removing the #, trying kooka as user, heureka it works!

    herhin

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •