Epson Perfection 1670

Using opensuse 11.1 kooka didn’t detect the scanner 1670 if I login as normal user. If I am root kooka finds the scanner and works fine.

Where is the problem?


I encountered a permissions issue on the scanner functionality in my mothers all-in-one-PC under openSUSE-11.1. The thread was here:
HP all-in-one Deskjet F4280 - openSUSE Forums

My specific post here:
openSUSE Forums - View Single Post - HP all-in-one Deskjet F4280

By adding the regular users to group “lp” I was able to scan successfully with kooka under KDE-3.5.10 on openSUSE-11.1.

Note if you add your regular user to group “lp”, you probably should restart (or completely log out of your desktop and log out of Linux - probably quicker to restart).

Is it only for multifunction machines, or primarily Epson machines?

As you suggested I added the group ls and even root to the user but with no effect.

This is what sane-find-scanner reports if I am normal user:

found USB scanner (vendor=0x0ccd, product=0x0038) at libusb:004:005
found USB scanner (vendor=0x04b8, product=0x011f) at libusb:004:002

Your USB scanner was (probably) detected. It may or may not be supported by

SANE. Try scanimage -L and read the backend’s manpage.

and this if I am root:

found USB scanner (vendor=0x0ccd [TerraTec GmbH], product=0x0038 [Cinergy T2]) at libusb:004:005
found USB scanner (vendor=0x04b8 [EPSON], product=0x011f [EPSON Scanner]) at libusb:004:002

Your USB scanner was (probably) detected. It may or may not be supported by

SANE. Try scanimage -L and read the backend’s manpage.

KDE is 4.1.3


Is there a way to determine the /dev/ location of the device?

For example, whenever I first go to do DV editing on my system I have to plug in the camcorder and then chmod the /dev/raw1394 in order to access it.

chmod 777 /dev/raw1394

After that, then the camcorder is fully accessible.

You did restart afterward, to ensure the new user permissions were fully applied?

This could be a KDE-4.1.3 bug. It may be worth your while to spend some time surfing on this anomalous behaviour to see if it is KDE specific.

Group lp, not ls

My investigations about this topic give the following results:

  1. Using lshal I found the device name as /dev/bus/usb/004/002. Changing the permission with root by chmod 666 002, running kooka as user starts the scanner.
  2. After Restart and login as user: The scanner didn’t start. Checking the permission of /dev/bus/usb/004/002 showed 644.
    Searching for the device name by lshal shows another link within /dev/bus/usb/xxx/xxx, so it would be necessary to make the changes after each start of the system, which would be very bad.

So what to do???

I didn’t have this problem with 11.0.


Have a look at /etc/udev/rules.d for the scanner rules. I’m running openSUSE 11.0, so there may be differences, but I have 55-libsane.rules containing a list of supported scanners. The scanner attributes are listed along with ‘lp’ group assigned and permission settings. I also have a rule specifically for my Epson CX5500 called 70-libsane.rules:

SYSFS{idVendor}==“04b8”, SYSFS{idProduct}==“083f”, MODE=“664”, GROUP=“users”

You can see, that this rule has ‘users’ group assigned, but I could easily change this, and the permissions if I desired. You could create a custom rule for your device incorporating the desired permissions, and group. Name it something like 95-myscanner.rules to make sure it gets processed last.

Hi deano_ferrari,

your reply gives the solution!! Thank you!
I checked the file 55-libsane.rules and compared it with the 11.0-version. Curious enough, in 11.1 the rule for the 1670 is commented out. Why??? The GROUP is lp, which I added to the user before. Removing the #, trying kooka as user, heureka it works!


herhin, congratulations on sticking with this to solve it. deano_ferrari well done on proposing an approach to find the solution.

My worry is this glitch could make it thru to 11.2. … herhin if you get the chance/time, you could write a bug report on 11.1 on this, noting there is a fix/work around (describe your fix in the bug report). That way the developers hopefully known enough to address this in 11.2.

Info on raising bug reports here: Submitting Bug Reports - openSUSE

Good work herhin! As oldcpu suggested, please file a bug report, so that the udev rules can be checked for errors.

I installed open a 32-bit openSUSE-11.1 with KDE-4.3.1 on my wife’s PC , where she has an Epson perfection 1260 connected. I could not initially get the scanner to scanwith either kooka or iscan. Her PC has the proprietary iscan apps:


Her scanner:

Bus 005 Device 002: ID 04b8:011d Seiko Epson Corp. Perfection 1260 Photo

I next added her login to group “lp” and I also added the application

I logged in/out of Linux and noted she could now scan with xsane but still neither kooka nor iscan would work. kooka recognized the device, but would simply sit at 0% when generating a preview. I waited an excessive time for the warmup (assuming that was taking place) but it did not make a difference from what I observed.

I noted iscan was giving the error “could not send command to scanner”. I checked the /etc/udev/rules.d for the scanner rules under 55-libsane.rules and noted her scanner was listed, and it was not commented out. So in her case that was not the problem with iscan.

But further surfing on the web gave me a link to a Russian Epson support web site with this URL ( … musing why do the Russians have the good support sites ? … ):
I downloaded that , was pleased to note it was in the English language, and found a trouble shooting section in that document that noted for the “could not send command to scanner” error , one could go to the /etc/sane.dll/dll.conf file, and add the word ‘epkowa’ in that file. I checked the file on my wife’s PC and I noted that both ‘epson’ and ‘epkowa’ were already in the file on my wife’s pc, but both were commented out. So I removed the comment symbol from in front of ‘epkowa’ (i left epson commented out), and iscan now worked. Strange. Possibly a packaging problem with one of the iscan apps I installed ?

I’m still not clear why kooka does not work. Likely I have something else misconfigured. Not a worry, as I now have 2 scanning apps that work, and my wife rarely boots to Linux (she is a big winXP fan).

Possibly a packaging problem with one of the iscan apps I installed ?

Likely. I have an Epson CX5500 MFP with epkowa driver (and associated entry in etc/sane.d/dll.conf), so must just be some packages. It works fine with kooka and iscan.