Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: 5.1 sounds on OpenSUSE 11.0 RC

  1. #1
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default 5.1 sounds on OpenSUSE 11.0 RC

    Hello there,

    First of all: I know there is lots of support requests concerning this matter, but I have read most of them and almost tried anything. I'm not yet that good at linux, but I wan't to get my sound system right. I'm really greatful if somebody can help and read this call!

    So, I have Opensuse 11 and I have installed alsa couple of times with no success. In some point I lost all audio and I didn't get it back. I have 5.1-speakers and in first I only got 2.1-sounds in linux. I wanted to listen music and watch movies using every speaker but I found setting 5.1-mode hard. In this point I have tried different variations of .asounrc -file, setting alsaconf over and over again and setting audio from YAST.

    I don't have a soundcard, but my motherboard is Asus P5LD2 SE. I tried Audio Troubleshooting with not much of a success though alsa-info.sh -script pasted my information here (hope that helps): general pastebin - rolle - post number 1048683 and other script printed: tsalsa.txt - nopaste.com (beta)

    Can you help me? Please.

  2. #2

    Talking Re: 5.1 sounds on OpenSUSE 11.0 RC

    Hi, welcome to OpenSUSE.

    The RC of OS 11.0 has some issues with sound regarding pulseaudio. I think your best bet is to read the following post:

    Upgrade 11.0 RC1 --> 11.0 GA - Page 2 - openSUSE Forums

    It explains how to update your RC installation to the final SUSE 11.0.

    I had problems with my Audigy 2 card not working, running a zypper dup command fixed everything.

    If you have any problems let me know.

    Regards,

    James
    www.worm.me.uk | james at worm dot me dot uk

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by rollex2 View Post
    I have 5.1-speakers and in first I only got 2.1-sounds in linux. I wanted to listen music and watch movies using every speaker but I found setting 5.1-mode hard. In this point I have tried different variations of .asounrc -file
    A number of users have noted sound problems, which were fixed by removing pulse audio (as it is an extra layer) but its by no means certain to me that this is your problem. IMHO its quite possible pulseaudio has nothing to do with your problem, ... or maybe its only part of the problem.

    I believe you will need a custom .asoundrc file under /home/your-username/.asoundrc
    .asoundrc file examples
    I also assume you know after every .asoundrc file change, you need to restart alsa with something like rcalsasound restart before you can test it. As you no doubt discovered, there are many different .asoundrc file possibilites, but unless you paste somewhere exactly what you tested, its really not possible to give you good help. Again, many of these .asoundrc files need edits, and unless we see what you tried, its very difficult to help.

    For example, I can see from the alsa-info-sh post script output you attempted a .asoundrc file, but I have no idea as to why you chose that particular file content.

    How about pasting on general pastebin - simplified internet collaboration the different .asoundrc files you tried (maybe with a reference link to where you got them from) so we can try help you.

    I notice you have an AD1986A. Did you try specify any model options in your /etc/modprobe.d/sound file, in conjunction with the custom .asoundrc file?

    Model Options you can try with the AD1986A are 6stack, 3stack, laptop, laptop-eapd, laptop-automute, and ultra.
    Code:
    	AD1986A
    	  6stack	6-jack, separate surrounds (default)
    	  3stack	3-stack, shared surrounds
    	  laptop	2-channel only (FSC V2060, Samsung M50)
    	  laptop-eapd	2-channel with EAPD (Samsung R65, ASUS A6J)
    	  laptop-automute 2-channel with EAPD and HP-automute (Lenovo N100)
    	  ultra		2-channel with EAPD (Samsung Ultra tablet PC)
    Again, you need to restart alsa after each and every "mode= ... " attempt. And your syntax MUST be exact.

    If you need help with the /etc/modprobe.d/sound file syntax, in trying these options, please post.

  4. #4

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Were so close to having linux do everything I want, yet it struggles in like 5-6 areas. Sound being one of them. If we could start getting these areas fixed (and most are in roadmaps for the next 1-2 years) Linux would take off.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by quickshade View Post
    Were so close to having linux do everything I want, yet it struggles in like 5-6 areas. Sound being one of them. If we could start getting these areas fixed (and most are in roadmaps for the next 1-2 years) Linux would take off.
    I think the key thing here is user participation on the positive side. Most users pay nothing for their OS, and they also contribute nothing in return. Linux is not based on that sort of foundation, but rather its based on the open source free software movement, where we are referring to "free" not as in "free beer" but free as in:
    * "free to copy",
    * one has "free access to the source code",
    * one is "free to modify the code",
    * one is "free to give away original version", and
    * one is "free to give away their modified versions".
    Free Software Philosophy - openSUSE

    The corner stone behind this Linux free software movement working, is that users MUST contribute.

    In my part, I have tried to help users in their sound by starting these openSUSE wiki pages:
    Sound-concepts - openSUSE
    SDB:AudioTroubleshooting - openSUSE
    Alsa-update - openSUSE

    I've also provided factoids on #suse (SUSEhelp) to try and help with sound, and actively participate in this forum to help users with their sound, and also actively participate in #suse, and occasionally in #alsa, to help users with their sound.

    Now I don't have the advanced hardware that many have, so I can't go the extra step to create 5.1 suroundsound how-to's, nor other such advanced guides.

    What is sad is those users who have succeeded in that setup, have not taken the time to make such a "5.1 surround sound" guide to make it easier. Its also sad that the vast majority of openSUSE users simply will not take the time to check the openSUSE hardware compatibility guide, and update it for their sound hardware. HCL/Sound Cards - openSUSE

    In truth, IMHO most openSUSE users simply fail to understand the philosophical basis on which their OS was built, and on which it succeeds.

    So in summary, I agree with your point that Linux struggles with sound, and IMHO the fault lies within ourselves, as Linux users, and not within the relatively small handful of people who produce the distributions.

  6. #6

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Yea I don't blame anyone for why it sucks and how it sucks. Point is the know it and they are trying to fix it. Which is something mega-corps never did. I think that Linux is great and it will be amazing to see what happens in the next year.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by quickshade View Post
    Yea I don't blame anyone for why it sucks and how it sucks.
    Sucks is a rather strong word. I don't think it sucks. I do see a problem.

    To quote Shakespeare:
    "The fault, dear Brutus, is not in our stars, But in ourselves"

  8. #8
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by oldcpu View Post
    there are many different .asoundrc file possibilites, but unless you paste somewhere exactly what you tested, its really not possible to give you good help.
    I tried this:
    Code:
    cm.dmixs51 {
      type dmix
      ipc_key 1024
      slave {
        pcm "hw:0,1"
        rate 48000
        channels 6
        period_time 0
        period_size 1024
        buffer_time 0
        buffer_size 4096
      }
    }
    
    pcm.mono {
      type plug #EDIT: korjattu puuttuva rivi
      slave{ 
    	pcm dmixs51
      	channels 6
      }
    	ttable.0.0 1 #vasenetu 0->2,3,4
      	ttable.1.1 1 #oikeaetu 1->2,3,5
      	ttable.0.2 1 #keski 2
      	ttable.1.2 1 #keski 2
      	ttable.0.3 1 #lfe 3
      	ttable.1.3 1 #lfe 3
      	ttable.0.4 1 #vasen taka 4
      	ttable.1.5 1 #oikea taka 5
    }
    
    pcm.stereo {
     type plug
      slave{
      	pcm dmixs51
      	channels 6
      }
      	ttable.0.0 1 #vasenetu 0<-2,3,4
      	ttable.1.1 1 #oikeaetu 1<-2,3,5
      	ttable.0.2 1 #keski 2
      	ttable.1.2 1 #keski 2
      	ttable.0.3 1 #lfe 3
      	ttable.1.3 1 #lfe 3
      	ttable.0.4 1 #vasen taka 4
      	ttable.1.5 1 #oikea taka 5
    }
    
    pcm.!surround51 {
        type plug
        slave{
            pcm "dmixs51"
            channels 6
        }
        	ttable.0.0 1 #vasen etu 0<-0
        	ttable.1.1 1 #oikea etu 1<-1
        	ttable.4.2 1 #keski 2<-4
        	ttable.5.3 1 #lfe 3<-5
        	ttable.2.4 1 #vasen taka 4<-2
        	ttable.3.5 1 #oikea taka 5<-3
    }
    (from here: Surround 5.1 ja DMixaus HOWTO)

    And this:
    Code:
    ----------- Stereo to 5.1 Upmixing, dmixing .asoundrc ---------------
    pcm.snd_card {
         type hw
         card 0 # change to your cards number or name
    }
    
    # 6 channel dmix:
    pcm.dmix6 {
         type dmix
            ipc_key 1024
            ipc_key_add_uid false # let multiple users share
            ipc_perm 0660 # IPC permissions (octal, default 0600)
            slave {
                    pcm snd_card # see below
                    rate 48000
                    channels 6
                    period_time 0
                    period_size 1024 # try 2048 against skipping
                    buffer_time 0
                    buffer_size 5120 # in case of problems reduce this
                                     # in case of skipping, try increasing
            }
         }
    
    # upmixing: 
    pcm.ch51dup {
            type route
            slave.pcm dmix6
            slave.channels 6
            ttable.0.0 1
            ttable.1.1 1
            ttable.0.2 1
            ttable.1.3 1
            ttable.0.4 0.5
            ttable.1.4 0.5
            ttable.0.5 0.5
            ttable.1.5 0.5
       }
    
    pcm.duplex {
         type asym
         playback.pcm "ch51dup" # upmix first
    #     playback.pcm "dmix6"  # just pass to 6 channel dmix
    #     capture.pcm "dsnoop:0" # doesn't work for me
         capture.pcm "snd_card"
    }
    
    # change default device:
    pcm.!default {
         type plug
         slave.pcm "duplex"
    }
    
    # for aoss
    pcm.dsp "duplex"
    
    pcm.dsp1 "duplex"
    (from here: Dmix - ALSA wiki)

    ...which seemed to work when submitting speaker-test -Dsurround51 -c 6.

    Quote Originally Posted by oldcpu View Post
    For example, I can see from the alsa-info-sh post script output you attempted a .asoundrc file, but I have no idea as to why you chose that particular file content.
    You are right, I didn't have idea. I suppose I already said i'm not so good at linux, I had about 3 years break and I don't remember much / don't know much at all. But I learn fast and try best as I can.

    I don't understand much about .asoundrc -parametres. The code is not familiar with me.

    Quote Originally Posted by oldcpu View Post
    I notice you have an AD1986A. Did you try specify any model options in your /etc/modprobe.d/sound file, in conjunction with the custom .asoundrc file?
    No, I try it next.

    Quote Originally Posted by oldcpu View Post
    If you need help with the /etc/modprobe.d/sound file syntax, in trying these options, please post.
    I will. I'll be in touch. Many thanks for helping me!! I appreciate.

  9. #9
    Join Date
    Jun 2008
    Location
    Jyväskylä, Finland
    Posts
    133

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by jameswalmsley View Post
    Upgrade 11.0 RC1 --> 11.0 GA - Page 2 - openSUSE Forums

    It explains how to update your RC installation to the final SUSE 11.0.
    In fact I just upgraded my RC. One question: what is "Final openSUSE 11.0"? I heard stable version comes out in day after tomorrow?
    Chameleon in my heart since 2006.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 5.1 sounds on OpenSUSE 11.0 RC

    Quote Originally Posted by rollex2 View Post
    In fact I just upgraded my RC. One question: what is "Final openSUSE 11.0"? I heard stable version comes out in day after tomorrow?
    RC stands for "release candidate". On Thursday, 19-June, the final "stable" GM (Gold Master) release will be made available to the public.
    Roadmap/11.0 - openSUSE
    Typically, a GM has a number of bugs fixed, that had not yet been fixed in the RC.

    Quote Originally Posted by rollex2 View Post
    I tried this: ... snipped .... And this:.... (from here: Dmix - ALSA wiki)

    ...which seemed to work when submitting speaker-test -Dsurround51 -c 6.
    Does that mean you have 5.1 surround sound working?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •