5.1 sounds on OpenSUSE 11.0 RC

Hello there,

First of all: I know there is lots of support requests concerning this matter, but I have read most of them and almost tried anything. I’m not yet that good at linux, but I wan’t to get my sound system right. I’m really greatful if somebody can help and read this call!

So, I have Opensuse 11 and I have installed alsa couple of times with no success. In some point I lost all audio and I didn’t get it back. I have 5.1-speakers and in first I only got 2.1-sounds in linux. I wanted to listen music and watch movies using every speaker but I found setting 5.1-mode hard. In this point I have tried different variations of .asounrc -file, setting alsaconf over and over again and setting audio from YAST.

I don’t have a soundcard, but my motherboard is Asus P5LD2 SE. I tried Audio Troubleshooting with not much of a success though alsa-info.sh -script pasted my information here (hope that helps): general pastebin - rolle - post number 1048683 and other script printed: tsalsa.txt - nopaste.com (beta)

Can you help me? Please.

Hi, welcome to OpenSUSE.

The RC of OS 11.0 has some issues with sound regarding pulseaudio. I think your best bet is to read the following post:

Upgrade 11.0 RC1 → 11.0 GA - Page 2 - openSUSE Forums

It explains how to update your RC installation to the final SUSE 11.0.

I had problems with my Audigy 2 card not working, running a zypper dup command fixed everything.

If you have any problems let me know.



A number of users have noted sound problems, which were fixed by removing pulse audio (as it is an extra layer) but its by no means certain to me that this is your problem. IMHO its quite possible pulseaudio has nothing to do with your problem, … or maybe its only part of the problem.

I believe you will need a custom .asoundrc file under /home/your-username/.asoundrc
.asoundrc file examples](http://home.cfl.rr.com/infofiles/asoundrc.examples.html#surround51.as.default)
I also assume you know after every .asoundrc file change, you need to restart alsa with something like rcalsasound restart before you can test it. As you no doubt discovered, there are many different .asoundrc file possibilites, but unless you paste somewhere exactly what you tested, its really not possible to give you good help. Again, many of these .asoundrc files need edits, and unless we see what you tried, its very difficult to help.

For example, I can see from the alsa-info-sh post script output you attempted a .asoundrc file, but I have no idea as to why you chose that particular file content.

How about pasting on general pastebin - simplified internet collaboration the different .asoundrc files you tried (maybe with a reference link to where you got them from) so we can try help you.

I notice you have an AD1986A. Did you try specify any model options in your /etc/modprobe.d/sound file, in conjunction with the custom .asoundrc file?

Model Options you can try with the AD1986A are 6stack, 3stack, laptop, laptop-eapd, laptop-automute, and ultra.

	  6stack	6-jack, separate surrounds (default)
	  3stack	3-stack, shared surrounds
	  laptop	2-channel only (FSC V2060, Samsung M50)
	  laptop-eapd	2-channel with EAPD (Samsung R65, ASUS A6J)
	  laptop-automute 2-channel with EAPD and HP-automute (Lenovo N100)
	  ultra		2-channel with EAPD (Samsung Ultra tablet PC)

Again, you need to restart alsa after each and every "mode= … " attempt. And your syntax MUST be exact.

If you need help with the /etc/modprobe.d/sound file syntax, in trying these options, please post.

Were so close to having linux do everything I want, yet it struggles in like 5-6 areas. Sound being one of them. If we could start getting these areas fixed (and most are in roadmaps for the next 1-2 years) Linux would take off.

I think the key thing here is user participation on the positive side. Most users pay nothing for their OS, and they also contribute nothing in return. Linux is not based on that sort of foundation, but rather its based on the open source free software movement, where we are referring to “free” not as in “free beer” but free as in:
* “free to copy”,
* one has “free access to the source code”,
* one is “free to modify the code”,
* one is “free to give away original version”, and
* one is “free to give away their modified versions”.
Free Software Philosophy - openSUSE

The corner stone behind this Linux free software movement working, is that users MUST contribute.

In my part, I have tried to help users in their sound by starting these openSUSE wiki pages:
Sound-concepts - openSUSE
SDB:AudioTroubleshooting - openSUSE
Alsa-update - openSUSE

I’ve also provided factoids on #suse (SUSEhelp) to try and help with sound, and actively participate in this forum to help users with their sound, and also actively participate in #suse, and occasionally in #alsa, to help users with their sound.

Now I don’t have the advanced hardware that many have, so I can’t go the extra step to create 5.1 suroundsound how-to’s, nor other such advanced guides.

What is sad is those users who have succeeded in that setup, have not taken the time to make such a “5.1 surround sound” guide to make it easier. Its also sad that the vast majority of openSUSE users simply will not take the time to check the openSUSE hardware compatibility guide, and update it for their sound hardware. HCL/Sound Cards - openSUSE

In truth, IMHO most openSUSE users simply fail to understand the philosophical basis on which their OS was built, and on which it succeeds.

So in summary, I agree with your point that Linux struggles with sound, and IMHO the fault lies within ourselves, as Linux users, and not within the relatively small handful of people who produce the distributions.

Yea I don’t blame anyone for why it sucks and how it sucks. Point is the know it and they are trying to fix it. Which is something mega-corps never did. I think that Linux is great and it will be amazing to see what happens in the next year.

Sucks is a rather strong word. I don’t think it sucks. I do see a problem.

To quote Shakespeare:
The fault, dear Brutus, is not in our stars, But in ourselves

I tried this:

cm.dmixs51 {
  type dmix
  ipc_key 1024
  slave {
    pcm "hw:0,1"
    rate 48000
    channels 6
    period_time 0
    period_size 1024
    buffer_time 0
    buffer_size 4096

pcm.mono {
  type plug #EDIT: korjattu puuttuva rivi
	pcm dmixs51
  	channels 6
	ttable.0.0 1 #vasenetu 0->2,3,4
  	ttable.1.1 1 #oikeaetu 1->2,3,5
  	ttable.0.2 1 #keski 2
  	ttable.1.2 1 #keski 2
  	ttable.0.3 1 #lfe 3
  	ttable.1.3 1 #lfe 3
  	ttable.0.4 1 #vasen taka 4
  	ttable.1.5 1 #oikea taka 5

pcm.stereo {
 type plug
  	pcm dmixs51
  	channels 6
  	ttable.0.0 1 #vasenetu 0<-2,3,4
  	ttable.1.1 1 #oikeaetu 1<-2,3,5
  	ttable.0.2 1 #keski 2
  	ttable.1.2 1 #keski 2
  	ttable.0.3 1 #lfe 3
  	ttable.1.3 1 #lfe 3
  	ttable.0.4 1 #vasen taka 4
  	ttable.1.5 1 #oikea taka 5

pcm.!surround51 {
    type plug
        pcm "dmixs51"
        channels 6
    	ttable.0.0 1 #vasen etu 0<-0
    	ttable.1.1 1 #oikea etu 1<-1
    	ttable.4.2 1 #keski 2<-4
    	ttable.5.3 1 #lfe 3<-5
    	ttable.2.4 1 #vasen taka 4<-2
    	ttable.3.5 1 #oikea taka 5<-3

(from here: Surround 5.1 ja DMixaus HOWTO)

And this:

----------- Stereo to 5.1 Upmixing, dmixing .asoundrc ---------------
pcm.snd_card {
     type hw
     card 0 # change to your cards number or name

# 6 channel dmix:
pcm.dmix6 {
     type dmix
        ipc_key 1024
        ipc_key_add_uid false # let multiple users share
        ipc_perm 0660 # IPC permissions (octal, default 0600)
        slave {
                pcm snd_card # see below
                rate 48000
                channels 6
                period_time 0
                period_size 1024 # try 2048 against skipping
                buffer_time 0
                buffer_size 5120 # in case of problems reduce this
                                 # in case of skipping, try increasing

# upmixing: 
pcm.ch51dup {
        type route
        slave.pcm dmix6
        slave.channels 6
        ttable.0.0 1
        ttable.1.1 1
        ttable.0.2 1
        ttable.1.3 1
        ttable.0.4 0.5
        ttable.1.4 0.5
        ttable.0.5 0.5
        ttable.1.5 0.5

pcm.duplex {
     type asym
     playback.pcm "ch51dup" # upmix first
#     playback.pcm "dmix6"  # just pass to 6 channel dmix
#     capture.pcm "dsnoop:0" # doesn't work for me
     capture.pcm "snd_card"

# change default device:
pcm.!default {
     type plug
     slave.pcm "duplex"

# for aoss
pcm.dsp "duplex"

pcm.dsp1 "duplex"

(from here: Dmix - ALSA wiki)

…which seemed to work when submitting speaker-test -Dsurround51 -c 6.

You are right, I didn’t have idea. I suppose I already said i’m not so good at linux, I had about 3 years break and I don’t remember much / don’t know much at all. But I learn fast and try best as I can.

I don’t understand much about .asoundrc -parametres. The code is not familiar with me.

No, I try it next.

I will. I’ll be in touch. Many thanks for helping me!! I appreciate.:slight_smile:

In fact I just upgraded my RC. One question: what is “Final openSUSE 11.0”? I heard stable version comes out in day after tomorrow?

RC stands for “release candidate”. On Thursday, 19-June, the final “stable” GM (Gold Master) release will be made available to the public.
Roadmap/11.0 - openSUSE
Typically, a GM has a number of bugs fixed, that had not yet been fixed in the RC.

Does that mean you have 5.1 surround sound working?

Only when doing speaker-test -Dsurround51 -c 6 on command line (noise in every speaker one by one).

I succeeded to change xine > alsa to amarok (previously alsa said “couldn’t initialize audio device” etc., so did mplayer alsa-configuration), but no 5.1 sound there, neither mplayer, apps or games, only 2.1. Alsamixer said previously something about failing function-something but now it works too. I guess I installed right packages… or something. Didn’t do command-line stuff.


Only when doing speaker-test -Dsurround51 -c 6 on command line (noise in every speaker one by one).[/QUOTE]My understanding is that you now have 5.1 sound working. But not every audio track will have 5.1 surround sound.

If you wish to take 2.0 sound, and upmix it to 5.1, then I think thats another matter. Just surf for that functionality. … some pretty bizzare .asoundrc files can be found. …

for example the post 2008-05-08 08:01 AM PDT in this thread:
FedoraForum.org - Yet another 5.1 Surround Sound Thread!!
gives this .asoundrc file:
note they make reference to the application “ladspa” being needed (not an issue, as it comes with openSUSE). …

I suspect there MUST be other solutions…

… and note, the above is posted only on what I have read … I have absolutely NO EXPERIENCE with this.

Good luck.

Okay, sounds work now pretty well, at least all applications and suse make 2.1 sound. Mplayer does 5.1 but rear speaker volumes are really low. Amarok still produces 2.1 sound even if 5.1 settings are set. Some avis won’t work (no sound at all, “couldn’t initialize sounds”) on mplayer but vlc player sounds okay.

Still trying to set all 5.1.

In a case like this, it is very useful if you provide what codecs are used by the avi files in question. Its important to eliminate the possibility that this could be an mplayer code problem. Without such a check, such statements about mplayer not working, but vlc working, in a 5.1 surround sound thread, only cloud the issue.

Humm. I wonder what happened:

rolle@peikko:~> rcalsasound restart
bash: rcalsasound: command not found
rolle@peikko:~> alsaconf
bash: alsaconf: command not found

Alsamixer works fine.

Amarok still recognizes alsa but produces only 2.1 sounds. Mplayer don’t play sounds at all (couldn’t initialize …), VLC Player works with 2.1 sounds automaticly. And suse produces sounds normally 2.1. Test (speaker-test -Dsurround51 -c 6) still says every speaker works, so what’s the matter here? I don’t understand. How to get apps and suse with 5.1 even if it’s “working”, right?

Updated 11.0 stable btw.

You need to run “rcalsasound restart” and “alsaconf” with root permissions. So type “su” (no quotes - enter root password when prompted) first, and then try again.

This should be fixable. Launch mplayer in a terminal and post here any error messages you get.

Nothing is the matter. … Most audio tracks do not have different audio for each of the channels/speakers, …

Now if you wish to take audio designed for two channels, and spread it out to all speakers, then that is something different. I was trying to explain that above, but I don’t think you understood my post. … and yes, there are .asoundrc files that can help you there.

I wish someone with 5.1 experience would chime in here. I’ve learned the above from chatting with users on IRC channel #alsa who have 5.1 sound running, and also from reading. … But I don’t have the hardware to setup 5.1 sound on my own PCs.

Oh, sorry, forgot the thing.

“Could not open/initialize audio device -> no sound.” Mplayer works with arts-output though. And previously when alsa worked, no 5.1, never, only 2.1.

I have nothing but mp3s. I also have windows partition and windows xp professional sp3 installed and every single mp3 works just fine.

Guess I didn’t understand then. Or just a bit lazy to try yet, but I am trying to try all the time.

Yeh, I irc a lot. Could you tell me which server is #alsa on?

Go to “freenode” , IRC #alsa

Got it to work there :slight_smile:
The solving process is right here: http://rolle.tux.fi/%23alsa.log

Thank very much you for helping me to solve this :slight_smile:

Glad to read the gurus in #alsa managed to help you. I see both “wishie” and “gnubien” were logged on at that time. They can really “rock and roll” when it comes to solving user’s sound problems.