Zypper won't refresh repositories

Hi all,

When I run zypper ref I get the next output:

Download (curl) error for ‘http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/content’:
Error code: Curl error 52
Error message: Empty reply from server

Abort, retry, ignore? [a/r/i/…? shows all options] (a):

To be sure, I checked the same command line by hand and it worked with no error:
curl -v ‘http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/content

  • Hostname was NOT found in DNS cache
  • Trying…
  • Trying 2001:67c:2178:8::13…
  • Immediate connect fail for 2001:67c:2178:8::13: Network is unreachable
  • Connected to download.opensuse.org ( port 80 (#0)
    > GET /distribution/leap/42.2/repo/non-oss/content HTTP/1.1
    > User-Agent: curl/7.37.0
    > Host: download.opensuse.org
    > Accept: /
    < HTTP/1.1 200 OK
    < Date: Sun, 13 Aug 2017 19:08:15 GMT
  • Server Apache/2.2.34 (Linux/SUSE) is not blacklisted
    < Server: Apache/2.2.34 (Linux/SUSE)
    < X-Prefix:
    < X-AS: 28521
    < Last-Modified: Wed, 09 Nov 2016 09:43:10 GMT
    < ETag: “a1b-540db15b8c780”
    < Accept-Ranges: bytes
    < Content-Length: 2587
    < Content-Type: text/plain
    DATADIR suse
    DESCRDIR suse/setup/descr
    DISTRO cpe:/o:opensuse:opensuse-addon-nonoss:42.2,openSUSE NonOSS Addon
    LINGUAS af ar be_BY bg br ca cy el et ga gl gu_IN he hi_IN hr ka km ko lt mk nn pa_IN rw sk sl sr_CS ss st tg th tr uk ve vi xh zu
    REPOID obsproduct://build.opensuse.org/openSUSE:Leap:42.2/openSUSE-Addon-NonOss/42.2/ftp/x86_64
    META SHA256 57c4467ce18bb3b842c7c638392ea1a26c534c6ce00eeb97b222c9b92e73b3d1 appdata.xml.gz
    META SHA256 8f5c1f11a2f8455ba37a4cfa7b6e1f8defbab798f029ca6ae68be61258479610 packages.DU.gz
    META SHA256 f10f1e0b998c5d6087320a9baaa5d805693349ea158a7fb8aff16b9b311d1139 packages.FL.gz
    META SHA256 356d0dad54f25745e1d6d038053f0b55912c21eb3783055ba5ac483e3f464f3e packages.cs.gz
    META SHA256 5eeb9fb88e749714bc0135d3783a7e001b790005299d5a99f6f7f074bec20577 packages.de.gz
    META SHA256 a7b988c607ae831b6cd57bfb6c93ed6794f09ea6dcbeb3ad5d9c680cf4185935 packages.en.gz
    META SHA256 9f7b5e7312646134de5317dbe93237328bb1ad83ebde54fee33afa79af08a8a4 packages.es.gz
    META SHA256 14c296b22115a0e22cf04c1849732e777fb14eafd4e760fe22ae8595f2c5d45e packages.fr.gz
    META SHA256 9dba74f9e6ac6f8a2519a054a546a46e9e43c8a7e323ce4b1ee08f0707f3f933 packages.gz
    META SHA256 4c29202cb41902995e56b4c95d7a3f082a1b6306d22692aa80fff8e9834e6c09 packages.hu.gz
    META SHA256 010d3035db64d2e518450501a3a2a433fa8d9d233eb4db5d635ca72231a7deec packages.it.gz
    META SHA256 55ff03a7cf5f575253b60106d98ec6a6fdc2733e5d1f1c397e0a5889729eee6a packages.ja.gz
    META SHA256 2e5e07b8e0c396d882991ec4944ec84125593f2375fba16c3909a64b5abc3858 packages.lt.gz
    META SHA256 965cf4e571114a828a22a399cd8b7c4cae6e91318a0cdc2d6c6dbf3e9a953c66 packages.nl.gz
    META SHA256 835a1b50e71900c2850accc56bd0c80ae0e518901471e32e0954909a729d9ca2 packages.nn.gz
    META SHA256 cb707a81f177bdd847f09059d080d8d76536c7698bad26d506279dbdc4870a38 packages.pl.gz
    META SHA256 bb5435454e8a61d7e3aa0ca379221f70d54ec68932f5af03b74f5527c5907240 packages.pt.gz
    META SHA256 aa5832876072267dcd3ec48864068f5d9931f142e2fb0b0a2caa64ce2c49ff77 packages.pt_BR.gz
    META SHA256 f5b0f7dfc32259d839edfa7ba5df007d4e378f7c8a4c2e8e0dc674f4503aec42 packages.ru.gz
    META SHA256 f985422c7b145ff3ffea8bc36142ad8197ba2e97ff970bee66a9a57861cd4f18 packages.uk.gz
    META SHA256 13b0943e46aa0639383c792c8949c6e59561df1cab24413a0b788c3f30f7876d packages.zh_CN.gz
    KEY SHA256 d9f574c69457dc5ee30d8d143484677379d2e9229fa9fb7986462dd716d08ad6 gpg-pubkey-307e3d54-4be01a65.asc
    KEY SHA256 971c0b268e632409ad7ccd26d43a04fe13dba82267f9b3cfab937a0d44789765 gpg-pubkey-3dbdc284-53674dd4.asc
  • Connection #0 to host download.opensuse.org left intact

So this is an inconsistent behavior. I tried then to cleanup all repos and this time I got the same results trying to download every single repomd.xml.

I’m not sure what to do next, and the reason for this inconsistence between zypper and manually run curl.


Benjamin Diaz
PSE@Novell de Mexico

IMHO there are several possibilities for the openSUSE repository behaviour described here:

  1. There was an outage related to the server(s): the “network unreachable” warning is possibly indicating this.
  2. The zypp / rpm caches were corrupt: “# zypper clean --all” and “# rpm --rebuilddb” may help to repair this issue.
  3. A “# zypper refresh --services --force” may also be needed.

Unless I’ve overlooked this since forever,
I’ve never created or seen a repo error with “/content” appended.

The correct URL should be just what precedes that.
Recommend you doublecheck your URLs…

One way to display the necessary info is to run the following

zypper lr -d

Or, you can dig through the YaST repo management module.