Zypper weirdness

I followed the directions for installing the latest Plasma-KDE (given @ https://en.opensuse.org/SDB:KDE_repositories), and all went well. I installed Plasma 15.4.90. After the install, when I ran sudo zypper ps -s, I got:

The following running processes use deleted files:
PID  | PPID | UID  | User  | Command     | Service
8752 | 8735 | 1000 | steve | kwin_x11    |        
8756 | 1    | 1000 | steve | krunner     |        
8758 | 1    | 1000 | steve | plasmashell |        
You may wish to restart these processes.
See 'man zypper' for information about the meaning of values in the above table.

I then logged out and back in. I then ran said zypper ps -s again, and got the same thing again (with different PIDs). This morning 15.4.90 was upgraded to 15.5. And logging out then back in, running sudo zypper ps -s yields the same result. I’ve run zypper clean, but I don’t seem to be able to get rid of this zypper ps -s output. Anyone have an idea what is happening? I’ve encountered no problems with the new Plasma.


Is it safe assume you have not tried rebooting to resolve the issue?
Maybe change to a target without a GUI and bring it back up to see if KDE
is caching something?

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.

Yeah, I rebooted and ran zypper ps -s, same result. I ran init 3 and logged in, then ran kstart plasmashell, and that didn’t bring up plasma. Perhaps I had the wrong command?

Simply startx runs startkde and a normal plasma session here. If it starts something else for you, try instead:

WINDOWMANAGER=/usr/bin/startkde startx

OK. I’ll give that a try.


Well, startx worked. But I still have that zypper ps -s output. There doesn’t seem to be anything wrong with my plasma desktop. I mean everything works ok (in fact, they seemed to have fixed the flakiness in the device notifier. But maybe I shouldn’t have said that…).


I think you don’t have to worry about that.

Some programs open a temporary file, then remove that file while it is still open. That way they don’t have to remove it on shutdown. But it leaves an open file that is not in any directory.

Eventually, the “zypper” maintainers will make a special case for that. But they have not yet done so for Plasma. So just ignore it.

OK. I shall ignore it.

Thanks to all for the help.

Weirdness of zypper got fixed with openSUSE Tumbleweed 20190209.