zypper update error help

Can someone elaborate on this error for me??

I’ve tried to find a good explanation or how to fix this, but kinda lost.

Download (curl) error for 'http://www.opensuse-education.org/download/repo/1.0/11.1/content':
Error code: Unrecognized error
Error message: Maximum (3) redirects followed

I’m not clear on what you have there. Is it this what you wanted?
Index of /repositories/Education/openSUSE_11.1

Try removing the old one and add the one above.

They are different repos. The one from openSUSE Education - News is an stable repo, is like an stable version of openSUSE where programs aren’t updated (only security fixes and major problems). The one from the OBS is the development repo, where packages are constantly updated (and so is less tested).

About the problem…

$ curl "http://www.opensuse-education.org/download/repo/1.0/11.1/content"
<title>302 Found</title>
<p>The document has moved <a href="http://www.opensuse-education.org/download/repo/1.0/11.1/content">here</a>.</p>

It’s an error on the server side, a recurrent redirection. Report it to openSUSE Education, but problably they already know and will be fixed shortly.

Sorry, my fault: I tried to setup mirrorbrain on Sunday, but it looks like I’ve made a mistake in the config.

Should be fixed right now.