zypper up: Permission to access denied!

I have never ever seen this before!!

All of a sudden i am getting this response when i attempt to update my system.

There have been no changes at this end … since when did one need permission to access the repo??

Any ideas??

Thanks.

(07:50 root@fssd-OS422 griadooss) > zypper up
Permission to access 'http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/content' denied.

From your prompt I read that you’re attempting to use zypper without root permissions …

Its not a root Permission error. It appears that download.opensuse.org has gone off line or has permission issues. You cannot access any of the directory structures associated to it any more. Try hitting the url via web and you will get permission denied error.

On Tue, 02 Oct 2018 22:06:03 +0000, Knurpht wrote:

> From your prompt I read that you’re attempting to use zypper without
> root permissions …

Doesn’t look that way to me - root@hostname would imply running as
root…


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

no … definitely logged on under su. :wink:

Here is what i am now getting via “Software Updates” from the GUI.

http://files.zimpics.org/forum/suse/RepoUpdateIssue.png

Yes, something is up with the repos currently. Similar issue reported here.

Odd … I came to the very same conclusion as you.lol!

Please be patient, there are issues with the mirror redirector. It’s being worked on.

Thanks for the update Gertjan!

There are mirror problems: https://progress.opensuse.org/issues/41933

Try it now. It appears to be working this morning.

Tony

This morning (10/10/2019) the same happened again: I’m getting “Permission to access …” errors on all my repositories. (Yes, I am running “zypper up” as root).
Suppose i simply have to wait until someone from opensuse fixes it again …

If you switch your repos to point directly to one of the mirrors that keep discontinued releases instead of using download.opensuse.org this probably won’t happen.

I just tried again and now it worked OK. Apparently this is a transient error that goes comes and goes.

One more advice. Better start a new thread then hanging at the end of a long forgotten one.

More people will look when you have a fresh thread with a good title.