Zypper Up does Zypper Dup on Leap 42.2?

Three times now, I’ve done a zypper UP on my Leap 42.2 installation and it seemed to work, but then when rebooting, the boot list has changed from Leap 42.2 to Tumbleweed, and things like wireless (broadcom 4352) no longer work.

My expectation is that zypper up on a Leap 42.2 build should upgrade to all the most recent packages for that build, but should not change the build to Tumbleweed. It’s a repeatable experiment - 3 times so far - that seems to happen on a second or later zypper up. Only option is to re-install LEAP on the partition that got overwritten by Tumbleweed.

Is my expectation correct, or will repeated Leap upgrades always move on to Tumbleweed? If so, how do I make sure that I can stay on Leap?

Thanks in advance.

Paul

Machine is a Lenovo Y70 Touch, 16G RAM, 1T SSD, although I don’t think that matters.

Show us the result of

zypper lr

Thanks, Pete. I just did a reinstall from scratch, haven’t done an update yet, and zypper lr shows…

~> zypper lr

| Alias | Name | Enabled | GPG Check | Refresh

—±------------------------------------±----------------------------------------±--------±----------±-------
1 | Packman | Packman | Yes | (r ) Yes | Yes
2 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | (r ) Yes | Yes
3 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes
4 | download.opensuse.org-oss | Main Repository (OSS) | Yes | (r ) Yes | Yes
5 | download.opensuse.org-oss_1 | Main Repository (Sources) | Yes | (r ) Yes | Yes
6 | download.opensuse.org-oss_2 | Main Update Repository | Yes | (r ) Yes | Yes
7 | google-chrome | google-chrome | Yes | ( p) Yes | Yes
8 | http-download.opensuse.org-3ce64b47 | multimedia:libs | Yes | (r ) Yes | Yes
9 | http-download.opensuse.org-531dbe8b | home:fmherschel | Yes | (r ) Yes | Yes
10 | http-download.opensuse.org-64d85f9c | home:adra | Yes | (r ) Yes | Yes
11 | http-download.opensuse.org-720c8607 | hardware | Yes | (r ) Yes | Yes
12 | http-download.opensuse.org-7a8e7004 | home:wolfi323 | Yes | (r ) Yes | Yes
13 | http-download.opensuse.org-83e66f02 | KDE:KDE3 | Yes | (r ) Yes | Yes
14 | http-download.opensuse.org-baa0c51a | multimedia:apps | Yes | (r ) Yes | Yes
15 | http-download.opensuse.org-d9a956a7 | home:Sauerland | Yes | (r ) Yes | Yes
16 | openSUSE-42.2-0 | openSUSE-42.2-0 | No | ---- | Yes
17 | repo-debug | openSUSE-Leap-42.2-Debug | No | ---- | Yes
18 | repo-debug-non-oss | openSUSE-Leap-42.2-Debug-Non-Oss | No | ---- | Yes
19 | repo-debug-update | openSUSE-Leap-42.2-Update-Debug | No | ---- | Yes
20 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No | ---- | Yes
21 | repo-source-non-oss | openSUSE-Leap-42.2-Source-Non-Oss | No | ---- | Yes

Once I do an upgrade, I’ll post the same result, to see if it varies.

Paul

Hi, zypper (at least in theory) should not be changing vendors (which repository a package comes from) without you explicitly telling it to.

Could you please use http://paste.opensuse.org to provide:

  • The output of: ls -al /etc/zypp/vendors.d/
  • The contents of the file /etc/zypp/zypp.conf

Also, what software do you need from the following repositories that you have added?

  • hardware
  • multimedia:libs
  • multimedia:apps
  • KDE:KDE3
  • home:fmherschel
  • home:adra
  • home:wolfi323
  • home:Sauerland

I suspect some of these are development repositories that contain software for Tumbleweed.

Finally, could you describe how you added these repositories and updated the system? Thank you!

Show zypper lr -d

with -d option that shows the URL

Also please use the code tag option here in the editor it is the # in the tool bar

All or most of the above should probably be summarized as…

Zypper up - which is an <update> not an upgrade
Using your configured repositories (which is a critical issue, do not mix repos from different releases unless you really know what you are doing), packages are replaced with newer versions of the same or similar. The OS name should not change if you do this correctly.

Zypper dup - which is a <distribution upgrade>, not a simple update
Used to make major changes which happens when you change from one major release to another, and which typically involves disabling or removing repos for a release and replacing with repos from a different release.

HTH,
TSU

Active openSUSE-Leap-42.2 repos cannot be seen. Why?

Well, as long as we see no output of

zypper lr -d

We will not know which repos he has. The URLs (the -d option) are crucial. The names and aliases (and of course the numbers) are only internal to his system and can be made more or less at random.

sounds to me like you’ve accidentally installed a tw package with the 1-click installer and added a tw repo, still with out your repo list this is just guesswork
generaly speacking zypper does not chage repo’s but if you tried to install a tw package yast would tell you that x packages will switch repositories and you probobly clicked next and endedup with an active tw repo, during the next update zypper thinks the tw repo is the main repo and switches the rest of the packages to it as tw always has newer packages
the fix would be for us to see your full repo list including the URL so we can see which is a tw repo and tell you do remove it then do a dup with the LEAP repos (you’d need to re-switch to packman too)