Zypper slowdown

Until yesterday, the new Zypper in openSUSE 11.0 worked fast as a lightning when refreshing my repositories.

Since yesterday, there is a dramatic slowdown: Zypper takes ages (1-2min) for each repository to refresh - even when it’s up to date!

Is it just me or is somebody else experiencing this issue? Any idea how to fix this?:confused:

wen I install OpenSUSE 11 zypper was fast as the light, but suddenly star to become slower with the time I do no why.

hope some one can help us.

It is normal that Zypper slows down a little due to the growing number of repositories one is using after a some time. Nevertheless, such slowdown as the last days was most probably not normal.

Anyhow, the slowdown seems to have vanished today. :slight_smile: Maybe the openSUSE servers were exceptionally slow yesterday.

if you watch and see a certain repository is taking a long time you can disable that one for a while.

Sometimes a repository can be off for a bit and you have to wait till you can access it again.

Note that the data you’re fetching (in case of an update) comes from a mirror - not the openSuSE servers themselves which can cause issues if that particular mirror is slow.

Also cleaning up the zypper database occasionally might be a good idea - I don’t know if Duncan and the boys have included any type of internal defragmentation for the db structure. It might fragment over time and slow things down a bit but re-building it should fix those issues (if it ever gets thatbad)

I am aware of this, thanks. :slight_smile: But it looked to me as if all repositories were slow. On the other hand, most repositories reside on download.opensuse.org :slight_smile:

i had serious issues before as well, especially at release time the opensuse.org mirrors were all hammered. I have since switched all my repos from the general opensuse.org to a specific one (http://ftp5.gwdg.de/) which for me is blazing fast and solved all my problems there. They also have the community repos there.