zypper segfaulting

I’m on OpenSuse 10.3 and somehow I’ve ended up with my zypper segfaulting. I recently used KDE/Upgrade - openSUSE to upgrade to the latest 10.3 kde. I don’t know if that is what caused the issue. It was not present until I more recently did a restart of my computer.

zypper -V tells me I have zypper 0.8.26

Some sample outputs:

zypper refresh

Repository ‘openSUSE BuildService - OpenOffice.org’ is up to date.
Segmentation fault

zypper up

Segmentation fault

zypper repos work fine

If I do zypper rr repo, I get a segfault, but then if I do zypper repos, that repo has indeed been removed.

An strace leading up to a segfault running zypper refresh can be found at http://cowsandmilk.net/pub/zypper.strace

Try rebuilding the database:

rpmdb --rebuilddb

zypper ref

zypper up

Unfortunately, that did not solve the problem.


maybe you ran out of memory. In general YaST and zypper from 10.3 needs a lot of memory. You can check this with top for example.

The Segmentation fault is probably coming from zyppers own database.

See this post, mainly comment #3 : OpenSuse 10.3 zypper - Cannot write file - openSUSE Forums

If you still have this issue then you can also ‘flush’ the repo cache… but don’t think that is needed.


note: with 11.0 and up a ’ zypper ref -f ’ should be enough to fix issues with the zypper db.

I’ve tried deleting that database and it doesn’t solve the problem.

Anything specific happen before zypper when belly up?

I don’t have a 10.3 install handy… there are other folders that can be cleared in /var/cache/zypp/ (the repo cache for each listing).

Before touching that:

  1. Have you tried first removing all the listed repositories, applying the empty list and then re-adding the needed repositories?
  2. What does ’ zypper up ’ report? Are there any zypper updates presented?
  3. With segfaults, it sometimes it helps to reinstall - what might have to be manually done using the rpm’s in this case?