Zypper ref && zypper up has killed my KDE!!!

Hi guys, recently did my periodic zypper ref and zypper up. On reboot… DEAD! KDE opens to a splash screen, I have mouse but no icons kicker/launcher etc, so no way that I know of to open a terminal or indeed any application, (I can open a console with ctrl-alt-fx)
alt-f2 does not bring up klauncher or whatever it is called
When it first happened, I had various apps open and they would try to open on reboot, return to last state as it were, it seemed that the keyboard was not responding, so that for instance I could not type into konversation, also I usually have apps on different desktops, and there is seemingly now only one.

Is there a way to open say; konversation from a console?

I have mv renamed .kde folder, still the same.
I have reinstalled nvidia driver 290.10
I am currently booting to XFCE.
My repos are/were a bit messy but…

SUSE Paste

Where do I go now? If I have to trash the whole thing I might go to MINT (eek!)
I have 11.4 with KDE 4.7.3

ps nepo/strigi/virtuoso/akonadi etc has never worked for me, since it was introduced (11.2?) but I don’t think that is the cause. I have been happily zypper upping all this time without problems, I just get a warning after about 5 minutes telling me that nepo etc is not working, and I ignore it, and do without.
If it is the cause, I am definitely migrating to another distro which DOES NOT have it!

You have KDF enabled
It’s build is for 12.2’s kde !

Boot to level 3 yast and disable it
Then do zypper dup

Once again Mr Caf, I am sure you will be my saviour! I did not entirely understand your reply, and I have to go out now for an urgent appointment (Wales vs Australia!!), I will look in to it later (probably slightly less than optimal, as will have beer brain on but hey it never stopped me before!) At first look at your reply I guess I have an entirely wrong repo? Which one is it? Will not zypper dup try to install 12.1?
Anyhow as I say I will have a look later, until then many, many thanks!

Boot to level 3 and login as user
Then become su

Now do this:

zypper rr 8

This is a duplicate of packman we can remove
then

zypper rr 3

that is the offending repo

Now do:

zypper dup

That should get you back in business.
Once back you should switch on Packman again
http://www.su2root.ukfsn.org/files/Switcher Pics/11.4_packman_switch.png

My HERO!!

I had to mv/rename .kde4 again, the first reboot after the zypper dup gave me the OpenSuse green splash with the gecko progress bar and then went to a white screen, after the mv I am now back in KDE business…
Thanks Caf you are the dog’s biscuits!!!

:shake: :shake: :good: :good:

Thanks Caf you are the dog’s biscuits!!!

My Son uses a saying like that, but it’s Bollocks ! not Biscuits :smiley:

YW