Zypper lag?

Whenever I run zypper from a command line (as root) it sits there with no output showing up. After about 2-3 minutes it confirms whether I want to install whatever program I requested, but it takes a long time. Does anyone else have this problem?
I have disabled IPv6 because it causes a lag due to my DNS servers (I have read that Ubuntu Lucid has a fix to this on Launchpad https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/417757?comments=all, I don’t know how successful it is) and I am not experiencing a delay on any other program that uses the network.

No I don’t get this.
Is the same true in Yast Software Management?

When I start YaST I have to wait while it does an autorefresh and there is a delay when it starts to download files that I don’t experience right before I download in zypper, only during program startup. I also don’t experience a delay when using cnf

zypper will have lag on auto refresh too - But it just depends when the last refresh was. But you will notice it as it displays in the terminal.
The DNS issues affecting a few users should have been bug fixed and patched via updates.

Nothing at all displays on the terminal when the lag occurs. However, when an autorefresh recently occurred the lag doesn’t happen.

I haven’t experienced a fix regarding that. I temporarily enabled IPv6 to test whether a fix came or not and I still experience a delay. I click on the updater applet and it tells me no updates available. I click on check and it still tells me that.

Just in case lets see your repos

zypper lr -d
# | Alias              | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                            | Service
1 | MingW              | MingW                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/mingw/openSUSE_11.2/ |        
2 | Packman Repository | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://packman.mirrors.skynet.be/pub/packman/suse/11.2                         |        
3 | ati                | ati                   | Yes     | No      |   99     | rpm-md | http://www2.ati.com/suse/11.1/                                                 |        
4 | google-chrome      | google-chrome         | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386                                     |        
5 | repo-debug         | openSUSE-11.2-Debug   | No      | No      |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                 |        
6 | repo-non-oss       | openSUSE-11.2-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                   |        
7 | repo-oss           | openSUSE-11.2-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                       |        
8 | repo-source        | openSUSE-11.2-Source  | No      | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.2/repo/oss/                |        
9 | repo-update        | openSUSE-11.2-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                      |        

That looks good.
Not sure where you go from here


I have the same experience here zypper on official repository (and build service) lags but works flawless with VLC repository.

First problem was that IPv6 could not be disabled via yast https://bugzilla.novell.com/show_bug.cgi?id=539869 after solving this issue all other network connections were working as expected but only yast and zypper does still have theses lags on build service and update repositories.

I’ve searched around and found out that the aria2c backend causes this problem when ara2c is disabled yast and zypper are working without any lags. I’ve reproduced this behavior on 3 completely different PCs with the same result. Because others don’t have this problem it must be related to my router hardware or it is a problem with my ISP and p2p torrent downloads.

Happy new year

This is interesting. I just thought the servers were slow. I also use a high speed satellite connection with lots of lag time. I used

export ZYPP_ARIA2C=0

and ran

zypper -vvv ref

and it took half the time to finish. I then read up on zypper and found out it uses aria2 to do it’s job. I’m going to do some more testing. What is it about aria2 makes zypper so slow?


I also know some persons who have cable connection and they don’t have this lag problem.

aria2c uses the metalinks for all official and build service repositories for downloading the packages. Maybe this has something to do with it. It is possile that aria2c then downloads the packages via bittorrent (depending on the metalink informations). Hence it also could be some p2p preventions or slowdowns by the ISP which are causing these lags.

If your ISP is throttling all p2p it’s time to move. This is just another variety of vendor lockin.
I have no such lag here in the UK, but my ISP does not throttle p2p or employ any form of traffic shaping.

Bullseye! My ISP (Wildblue) is not as forgiving with p2p. I really don’t fully understand their p2p policy, but sometimes it is cut back. I assume this is the reason I get a lag from time to time when running zypper ref. With aria2c
disabled, it is the same fast speed every time. My only alternative out here in the sticks of Kentucky is dial up.:’(

That sounds like some real ‘Backwoods’ ISP.

Go drown your sorrows with some ‘Sour Mash’ and hope the New Year brings something betterrotfl!

I keep waiting for AT&T high speed, but there aren’t enough hicks around here to make it financially viable for them to run the fiber optics. It stops at the city limits. One of these days…

I want to thank the people that solved this issue with the aria2c change. It was really torquing me off the slowness. I do not have Wildblue (though I did for 2.5years, my sympathies to 67GTA) since I got ADSL phone service at my place in the sticks this month. They must throttle p2p to keep service accessible for everyone.

Thanks again for providing this solution.



it looks like the latest online update to a newer version of aria2c fiexed this issue for me. For more informations look at /dev/loki: Call for testing openSUSE 11.2 with newer aria2

Have a lot of fun

I just ran across this thread again while googling aria2. I still have the same crappy satellite connection, but the aria2 version in 12.1 doesn’t have this problem. I enabled it for zypper just this morning and everything is zippy! I hope to get a good 3G connection after the first of the year!