Zypper finds "Problem with Pipewire" . . . decision on solution required???


Been away from my multi-boot machine for ten days and today in TW a mere “376 packages to upgrade” were mentioned in the GUI updater. I ran a zypper ref/dup in the console and got . . . a decision that requires a choice for one of two solutions . . . . In the recent past I would just pick one, but lately that has caused some further issues, so I’m posting here on it . . . I don’t know what “pipewire” is or does for me . . . ???

Problem: problem with the installed pipewire-media-session-0.3.38-3.3.x86_64
 Solution 1: install pipewire-media-session-0.4.0-1.1.x86_64 from vendor openSUSE
  replacing pipewire-media-session-0.3.38-3.3.x86_64 from vendor http://packman.links2linux.de
 Solution 2: keep obsolete pipewire-media-session-0.3.38-3.3.x86_64

pipewire has replaced pulseaudio.
Solution 1 should work, solution 2 will most likely break your audio.

As far as i know you have two options:

  1. You choose Solution 1
    but then you have to do the vendor change from Packman to openSUSE for all installed pipewire-packages. 1. Uninstall pipewire
    and install pulseaudio instead.

You can search the forum as well. There have been threads on this already.



Thanks for the replies . . . .

Interesting that zypper would offer #2 as a “solution” . . . considering most people wouldn’t think of that broken audio as a solution?

Thanks for the insights, I did scroll through a couple pages of the recent threads and didn’t see anything relating to “pipewire” . . . been out of town taking care of family issues and didn’t think of “searching” the forum, I just scanned it . . . saw nothing relevant.

But, your #2 suggestion seems like the “adult” thing to do, rather than switching out of Packman for just one package . . . . I guess I’ll be doing this in all 4 or 5 of my OpenSUSE installs over the next few days, getting all the installs back up to current . . . .

Post action report:

Well, as usual it isn’t just as simple as it appears . . . I “removed” pipewire and it showed 3 packages that were being removed, ran that . . . ran “install pulseaudio” and it said, “already installed, nothing to do.” But, when I ran zypper dup -l again the “pipewire question remained” . . . . I tried to lock “pipewire” . . . .

Went into Yast, “pipewire” was marked with “taboo” but a bunch of other “pipewire” packages remained as listed and installed. Three were checked to “install” . . . I tried to delete them, but then I got a “Your chromium browser app needs pipewire xxxxx” . . . so I voted to keep that one and deleted the others . . . .

Ran the zypper dup again and it loaded the 376 packages . . . just checked chromium youtube music and it had sound … . so I guess we are “good to hear sound”???

Usually I cancel zypper dup in case of conflicts, somebody fixes it in a few days. This case in particular the package is gone from packman, and it’s probably not a good idea keeping a package that’s gone from the repo. For context, this package was split in the oss repo and packman didn’t pick it up. It will eventually be replaced by wireplumber.

So I went with solution #1 and pulseaudio still works. Yes, because it’s not accurate to say that everybody is on pipewire yet. I do have some pipewire packages installed but that’s different from actually using it. I’m certainly not:

$ pactl info | grep '^Server Name'
Server Name: pulseaudio

Here is the post where i described what i did when i ran into the problem that Packman no longer provided pipewire-media-session.

I use pulseaudio

> pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 11
Tile Size: 65472
User Name: b1
Host Name: MACH01
Server Name: pulseaudio
Server Version: 15.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: f26b:0416

but there is still one pipewire-related package installed on my system

# zypper se -si *pipewire*

Loading repository data...
Reading installed packages...

S | Name              | Type    | Version    | Arch   | Repository
i | libpipewire-0_3-0 | package | 0.3.39-2.3 | x86_64 | Packman openSUSE Tumbleweed AC

It seems to be required by

# rpm -q --whatrequires "libpipewire-0.3.so.0()(64bit)"


and by chromium (which is not installed on my machine)

# zypper info --requires chromium | grep pipewire


Probably libpipewire-0_3-0-0.3.39-2.3.x86_64 is the only pipewire-related package you need (and the pulseaudio-packages to have your sound working).




Thanks for your post, appreciate that.


Thanks kindly for that thorough post . . . I’ll check into it when I rotate back into TW . . . .

I noticed that one of my Gecko installs had a similar or larger number of packages to update, but no pipewire decisions had to be made before running the “dup” process . . . . It did seem to take quite a bit longer to run through the zypper process than TW???

So, cycled back to TW and I ran through the various provided commands . . . seems like all is in realignment, except @susejunky appears to have a newer version of the remaining pipewire package??? What’s up with that??

@linux-f6nl:~> pactl info | grep '^Server Name'
Server Name: pulseaudio
@linux-f6nl:~> su
linux-f6nl:/home/ # zypper se -si *pipewire*
Loading repository data...
Reading installed packages...

S  | Name              | Type    | Version    | Arch   | Repository
i+ | libpipewire-0_3-0 | package | 0.3.39-1.1 | x86_64 | Main Repository (OSS)

linux-f6nl:/home/ # rpm -q --whatrequires "libpipewire-0.3.so.0()(64bit)"

Your libpipewire-0_3-0 comes from the openSUSE Tumbleweed OSS repository while mine comes from the Packman repository.




OK, yes, I did see that difference . . . so Packman is using the newest stuff???


I have to admit i’m not expert enough to tell what the difference between a version 0.3.39-1.1 and a version 0.3.39-2.3 might be.



If you want to use pulseaudio just remove the pipewire-pulseaudio package.
No need to remove pipewire and some of the pipewire packages installed in your machine.


Thanks for the hint . . . don’t recall seeing “pipewire-pulseaudio” in Yast, but when I get back there I’ll check it. My TW system is now using pulseaudio, some pipewire packages removed, others not . . . audio is/was working . . . . Sometimes “rough trade” gets it done, just not elegantly . . . . :\

In this situation I switched all the pipewire packages from Packman to the openSUSE standard repository and everything works just fine.