zypper dup wants me to change vendor on one package

This notice from zypper came up several days ago and I was hoping it was just a repository error, but it hasn’t gone away. It’s actually preventing me from performing the distribution upgrade.

linux-q5o0:~ # zypper dup -l --no-allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Problem: problem with installed package libtxc_dxtn-1.0.1-4.14.x86_64
 Solution 1: install libtxc_dxtn-1.0.1-1.1.x86_64 (with vendor change)
  http://packman.links2linux.de  -->  openSUSE

Choose the above solution using '1' or cancel using 'c' [1/c] (c): c
linux-q5o0:~ # 

Do I need to remove that package and then reinstall again from Packman? As I understand it, I don’t want to change vendors Packman → openSUSE, correct?

By the look in this case you do want it to move back and use the openSUSE one. Both the same packages, no need for it to be on Packman as nothing untoward in it, if it is needed it should be a link to OBS as this is where it’s maintained.

Edit: Delete request pushed - https://pmbs.links2linux.de/request/show/4018

Thanks for your reply. I did as you suggested and switched to the one from openSUSE. I was very, very behind in getting package updates because once I told it to switch, zypper then reported it was going to update 987 packages! Holy moly.

I assume it was your decision to use Tumbleweed. And that is a rolling release that refreshes much software every time. Thus not updating for some time lets things accumulate of course.

Oh yes, definitely. I specifically went with TW because it’s a rolling release. It was just surprising there were so many updates. The most I had ever seen before was around 200.

You should have seen it when TW move to a new GCC version; (almost ) all packages got rebuilt …

I used to update with “zypper dup”.

These days, I am using “zypper dup --allow-vendor-change”. That way, I don’t get prompted for those vendor changes.

I only have standard repos and packman. And I have set priorities so that packman is always preferred. So if there is a vendor change away from packman, there must be a good reason for it.

And, yes, I know there’s a setting that I can use for allowing vendor change. In practice, most of the time “zypper dup” by itself works. And if a vendor change is really needed, it will give a conflict resolution dialog. At that stage, I bail out, then use “zypper dup --allow-vendor-change”.