ZYPPER DUP updated to Plasma5 today--some minor issues

So, I am now upgraded to Plasma 5.3. I think it looks good, but there are some minor nits to pick, and I hope someone can point me in the right direction:

  1. Krunner does not automatically start when I begin typing (assuming a window is not selected). I got spoiled by this feature and I miss it. :slight_smile: I looked in the settings to no avail.
  2. Desktop effects do not work. I think I read this is expected at this time though.
  3. There is no trackpad app that I can find

All in all, minor difficulties.

There never was a setting for this AFAICR.
But yes, this feature seems to be missing in Plasma5. I have no idea whether it is planned to be added or not though.

Open krunner with Alt+F2 or Alt+Space. You can of course also change the shortcut combination in systemsettings5.

  1. Desktop effects do not work. I think I read this is expected at this time though.

No, this is not expected. They should work fine, if your graphics card/driver is up to the task. (OpenGL 1 support has been removed)
They even worked in the 5.0 pre-release versions…

Verify in systemsettings5->Display and Monitor->Compositor that the “Rendering Backend” is set to OpenGL, not all effects work with XRender, exactly like it already was the case in KDE4.
If the Backend reverts back to XRender automatically, your graphics driver doesn’t support the necessary features or your graphics driver installation is broken. Or you encountered a bug.

  1. There is no trackpad app that I can find

I have no experience with that as I don’t use a touchpad, but kcm-touchpad should be included in Plasma5. Have a look in systemsettings5->Input Devices…

If that’s not what you are after, then you probably should explain what exactly you are looking for.

Interestingly, if I unlock widgets, it works! I wonder if it is a bug.

No, this is not expected. They should work fine, if your graphics card/driver is up to the task. (OpenGL 1 support has been removed)
They even worked in the 5.0 pre-release versions…

Verify in systemsettings5->Display and Monitor->Compositor that the “Rendering Backend” is set to OpenGL, not all effects work with XRender, exactly like it already was the case in KDE4.
If the Backend reverts back to XRender automatically, your graphics driver doesn’t support the necessary features or your graphics driver installation is broken. Or you encountered a bug.

Interesting–systemsettings5 is not what is opened when I click on “Configure Desktop” under the KMenu. It looks like the KDE4 system settings, because when I specifically run systemsettings5, “Compositor” is available under “Display and Monitor” whereas this is not the case under system settings under the KMmenu. There seem to be two different applications: Configure Desktop and System Settings in Kicker. I removed the former, but alas, my effects are still not working.

I have no experience with that as I don’t use a touchpad, but kcm-touchpad should be included in Plasma5. Have a look in systemsettings5->Input Devices…

If that’s not what you are after, then you probably should explain what exactly you are looking for.

When I try to install kcm-touchpad, I get the following error:

Loading repository data... Reading installed packages...
Resolving package dependencies...

Problem: installed plasma5-desktop-5.3.0-1.1.x86_64 obsoletes kcm-touchpad < 5.3.0 provided by kcm-touchpad-1.1-4.6.x86_64
 Solution 1: Following actions will be done:
  deinstallation of plasma5-desktop-5.3.0-1.1.x86_64
  deinstallation of plasma5-session-5.3.0-1.1.noarch
  deinstallation of patterns-openSUSE-kde_plasma-20150505-1.1.x86_64
  deinstallation of patterns-openSUSE-kde-20150505-1.1.x86_64
  deinstallation of patterns-openSUSE-kde_imaging-20150505-1.1.x86_64
  deinstallation of kdebase4-workspace-branding-openSUSE-13.2-6.63.x86_64
 Solution 2: do not install kcm-touchpad-1.1-4.6.x86_64

**Choose from above solutions by number or cancel [1/2/c] (c): c**

So apparently, Tumbleweed does not have an updated kcm-touchpad.

Is there a “kcm_touchpad5”?

Yes, but when I use systemsettings5, I am able to manage the touchpad. kcm-touchpad5 causes the same error.

You mean Alt+F2? That works fine here with locked widgets as well.

Btw, there’s a new experimental interaction mode in Plasma 5.3: Widgets don’t show their handle bar when you move the mouse over them and you can’t move them either by default, but rather only when you press and hold the left mouse button on them.
This should actually make locking the widgets unnecessary, especially in combination with Plasma5’s undo feature for widget deletion.
You can enable this mode by right-clicking on the desktop (or clicking on the toolbox icon) and choosing “Desktop Settings”->Tweaks.
You can also hide the toolbox icon/“cashew” in there, probably one of the most requested features in KDE4 that never got added… :wink:

Interesting–systemsettings5 is not what is opened when I click on “Configure Desktop” under the KMenu. It looks like the KDE4 system settings, because when I specifically run systemsettings5, “Compositor” is available under “Display and Monitor” whereas this is not the case under system settings under the KMmenu. There seem to be two different applications: Configure Desktop and System Settings in Kicker. I removed the former, but alas, my effects are still not working.

Yes, “Configure Desktop” is KDE4’s systemsettings (which has been renamed by openSUSE years ago, because YaST is meant for changing the system settings), whereas Systemsettings is Plasma5’s settings and should be in the favorites.

Can you please elaborate what exactly you mean with “my effects are still not working”?
Are they actually enabled in systemsettings5? (Workspace Behavior->Desktop Effects)
Is OpenGL enabled in the Compositor settings?
What effects exactly are not working?

Note that Plasma5 does not take over the KDE4 settings, so if you enabled additional desktop effects, you have to do so again.

When I try to install kcm-touchpad, I get the following error:

So apparently, Tumbleweed does not have an updated kcm-touchpad.

No!

kcm_touchpad has been integrated into Plasma5 in 5.3, i.e. it’s in the package plasma5-desktop now.
You don’t have to (and cannot actually) install it separately.

Again, it should be there in systemsettings5->Input Devices:
http://susepaste.org/images/66497045.png

Yeah, that is really cool!

But I am one of those freaks who like the cashew/toolbox. However, effectively having a “locked” widget until I want to actually do something with it is pretty awesome.

Note that Plasma5 does not take over the KDE4 settings, so if you enabled additional desktop effects, you have to do so again.

Yes, I just realized that, and now they are working. Thanks!

No!

kcm_touchpad has been integrated into Plasma5 in 5.3, i.e. it’s in the package plasma5-desktop now.
You don’t have to (and cannot actually) install it separately.

As per my earlier note, this seems to be the case.

Thanks for your help!

Oddly enough, I can only test audio (Front Left, Front Right) from “Configure Desktop” under Multi Media>>Audio and Video Settings>>Audio Hardware Setup. Under System Settings it does not work.

Indeed. I can confirm this here on 13.2.
The test sound on the “Device Priority” tab does work fine though.

Interesting that the OP states there are only ‘minor’ issues. After updating to 5.3 (and that update yesterday was over 300 packages) I am unable to log in to anything other than IceWM. I can’t log in to either plasma5 or KDEWorkspace as user or root. Or maybe I should say that after I log in, I’m returned to the log in screen.
Anyone know a fix for this?

With the amount of information you give, no.

Try to run “startkde” inside IceWM. Does Plasma start? Do you get an error message?

Have you tried to boot to recovery mode?
What does “glxinfo|grep render” say? (you might have to install Mesa-demo-x to get any output)

Btw, I’m using Plasma5 (not as main desktop, but still) since over a year when 5.0 wasn’t even released yet, and never had a major issue…

For those with touchpad issues in Plasma5: install synaptiks, open a terminal and do

synaptiks

You’ll see a new item in the systray items. Double-click it and the synaptiks configuration will show up, allowing you to set tapping etc.

I got a lot of output but here is the last of it:
kdeinit5: Got KWRAPPER ‘ksmserver’ from wrapper.
kdeinit5: preparing to launch ‘libkdeinit5_ksmserver’
Could not open ksmserver using a library: Cannot load library /usr/lib64/libkdeinit5_ksmserver: (/usr/lib64/libkworkspace5.so.5: file too short)
ksmserver: error while loading shared libraries: /usr/lib64/libkworkspace5.so.5: file too short
kdeinit5: PID 10000 terminated.
kf5.kinit.klauncher: new app “:1.29”
startkde: Shutting down…
kdeinit5: terminate KDE.
klauncher: Exiting on signal 1
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
QThread: Destroyed while thread is still running
startkde: Running shutdown scripts…
startkde: Done.

There is also a error about Qt: Qt: Session management error: networkIdsList argument is NULL

I’ll try that next.

Among other things, it says: direct rendering: Yes

I’ve been using it since it first became available from the Frameworks5 and Qt5 repos with 13.2 but now I’m using Tumbleweed.

I have the same problem in recovery mode.

Well, you have your error message there:

So something apparently went wrong when installing the package plasma5-workspace-libs (disk full, maybe?).
Try to reinstall it, that should fix your problem, unless something else is broken too:

sudo zypper in -f plasma5-workspace-libs

Thank you. My sanity is restored.

I did not think of that, because when I went from KDE to Plasma 5 for the previous snapshot, it insisted on uninstalling “synaptiks” due to some conflict.

The general problems that I am seeing are:

  1. The menu system is terrible. With KDE4 we had nice multi-level structured menus. Now I just get a huge screen dump with no structure, so that it hard to find what I am looking for. I may have to go back to using the command line to start applications.
  2. Windows resume all in desktop 1. Position is not remembered.
  3. Konsole crashes on startup. I’ve gone back to “xterm”.
  4. “sddm” cannot start Gnome. It just hangs there waiting for Gnome to start. I have to use CTRL-ALT-BACKSPACE to abort. I have now switched to “lightdm”.
  5. The input devices menu say “No touchpad found”. Thankfully, installing “synaptiks” helped there.
  6. I cannot turn off the screen lock. I can set it to 99 minutes. But I cannot set it to “never”.

I fully agree.
But that’s not really a Plasma5 problem per se.

(open)SUSE always used its own menu structure, that’s provided by the package desktop-data-openSUSE, which provides this multi-level setup.
KDE3, KDE4, and other desktops use this.

But the openSUSE KDE team decided in their (public) meeting on April 1st that openSUSE’s Plasma5 should not care about SUSE’s menu structure any more, but rather use the upstream one.

openSUSE’s packages are actually patched to read /etc/xdg/menus/kf5-applications.menu instead of the standard applications.menu. Copying the latter over the former will bring you back the “old” SUSE structure.

Actually I do hope that this decision will be revisited, and I also have ideas (to some degree) on how to make that configurable even (e.g. via installing on of two branding packages or setting an environment variable).

Windows resume all in desktop 1. Position is not remembered.

That’s a known problem. A patch exists and was part of the packages in KDE:Frameworks5. But as a side-effect this patch disabled session management completely for KF5-based applications (although it shouldn’t), therefore it has been disabled again.
The issue is still under investigation.

Konsole crashes on startup. I’ve gone back to “xterm”.

Another known problem, caused by some additional patches in openSUSE’s Qt5 and KF5 packages:
http://bugzilla.opensuse.org/show_bug.cgi?id=931167
https://bugs.kde.org/show_bug.cgi?id=344183

A"sddm" cannot start Gnome. It just hangs there waiting for Gnome to start. I have to use CTRL-ALT-BACKSPACE to abort. I have now switched to “lightdm”.

Hm. Haven’t noticed that one yet.
But kdm is still available as well, and actually won’t even be replaced by sddm automatically AFAIK.

And a year ago, GDM failed to start KDE (both 4 and 5)… :-/

I cannot turn off the screen lock. I can set it to 99 minutes. But I cannot set it to “never”.

That was the case until 5.2.2.
In 5.3 there is a checkbox to enable/disable it.

Before, you had to set it to 0 minutes to disable it.

I reinstalled that package and it got rid of the ‘file too short’ error but I still can’t log in to Plasma5.

Also when I use zypper, I get a list of about a hundred files that ldconfig says are “empty, not checked”. All of the files are in directory /usr/lib64 starting with libKF5Parts.so.5, libKF5NotifyConfig.so.5, libKF5NewStuff.so.5, libKF5Declarative.so.5.

Then install those packages again too.

sudo zypper in -f libKF5Parts5 libKF5NotifyConfig5 libKF5NewStuff5 libKF5Declarative5

And maybe run “rpm -Va” afterwards to find what packages are still broken too.