Zypper dup tryign to remove steam

Just ran into this issue - “Problem: 1: the installed steam-1.0.0.79-1.4.x86_64 requires ‘glibc-locale-base-32bit’, but this requirement cannot be provided
deleted providers: glibc-locale-base-32bit-2.39-7.1.x86_64”

Any ideas?

Please always post the complete output incl. the complete commandline so that we see, what you are seeing.

I ran into this a couple days ago when I did my zypper dup - I added --allow-vendor-change to the command and that seemed to work OK without causing Steam to uninstall.

Which repo does provide these removed packages?
Atm you can only keep obsolete glibc-locale-base-32bit and glibc-32bit until next snapshot with these packages enabled again…

https://bugzilla.suse.com/show_bug.cgi?id=1225809

Looks like the issue I ran into was a different issue. Disregard. :slight_smile:

According to openQA: opensuse-Tumbleweed-DVD-x86_64-Build20240604-extra_tests_gnome@64bit test results steam should be fixed in the next snapshot, whenever that is. (You can keep your expectations low by assuming it will release next Monday.)

Just for future reference…when something like this happens(especially with Steam), usually it’s just a matter of waiting for a next snapshot as sometimes packages fall out of sync. This has been an issue with Steam related packages for the last week and a half, as there were far more problems over the last week, most of which were resolved with the last snapshot.

2 Likes