zypper dup to Packman - bad idea?

I’ve often wondered (but never had the guts) if it is a good idea to switch the OSS packages to Packman, for those that are listed on Packman?

In most posts I see, the “fourth” repo mentioned is always Packman…(next to OSS/non-OSS/Update)

In other words, in YAST - Software Mngt, if I pick the Packman repository and then click the “Switch system packages…” link - is that wise or unwise?

Not a bad idea.
(Actually recommended in my multi-media guide)

But in some cases, particularly gnome installs, it can be difficult, or at least not easy for some to answer the conflict questions, often related to Cario and Transmission.

This depends on what OBS repo do you use. If a home repo of a user, little can be said. But I do not recommend changing packages of Standard and Contrib to Packman. Standard packages have the highest quality, and Contrib’s quality is lesser. I even do not recommend changing Education packages to Packman ones, because OBS has more checks on package quality.

This all has one exception: some patent-protected technologies which cannot be included in OBS. These include font rendering, codecs etc. In order to use those features you should install packages from Packman.

Probably most Packman packagers don’t agree with you. But true, it all depends on which repo you trust more… and each one of us will have its own oppinion.

thats how I did it and worked okay for me, nothing will happen till you press accept. Or simply do it package by package, takes a bit longer but wont be such a big step at once

What action do you folks recommend for the following conflicts when I try to switch to Packman:

#### YaST2 conflicts list - generated 2010-04-18 12:43:07 ####

problem with installed package dialog-1.1-28.2.x86_64

     ] keep obsolete dialog-1.1-28.2.x86_64

     ] Following actions will be done:
deinstallation of dialog-1.1-28.2.x86_64
deinstallation of alsa-utils-1.0.21-3.1.x86_64
deinstallation of alsa-1.0.21-3.2.x86_64
deinstallation of yast2-sound-2.18.4-
deinstallation of yast2-tv-2.18.4-2.8.noarch

ktoblzcheck-devel-1.23-2.2.x86_64 requires ktoblzcheck = 1.23, but this requirement cannot be provided

     ] deinstallation of ktoblzcheck-devel-1.23-2.2.x86_64

     ] keep obsolete ktoblzcheck-1.23-2.2.x86_64

     ] break ktoblzcheck-devel by ignoring some of its dependencies

libgwenhywfar3-47-3.11.3-1.pm.1.1.x86_64 requires gwenhywfar3 = 3.11.3, but this requirement cannot be provided
uninstallable providers: gwenhywfar3-3.11.3-1.pm.1.1.i586[Packman Repository]
                   gwenhywfar3-3.11.3-1.pm.1.1.x86_64[Packman Repository]
     ] Following actions will be done:
deinstallation of gwenhywfar-3.8.3-4.5.x86_64
deinstallation of gwenhywfar47-3.8.3-4.5.x86_64
deinstallation of libgwenhywfar47-3.8.3-4.5.x86_64
     ] keep obsolete aqbanking-devel-4.0.0-3.5.x86_64

     ] break libgwenhywfar3-47 by ignoring some of its dependencies

     ] deinstallation of aqbanking-devel-4.0.0-3.5.x86_64

#### YaST2 conflicts list END ###

In each case try keeping the obsolete packages.