Zypper Dup to 20180615 snapshot again kills Cinnamon desktop

Symptoms are identical to those described in the https://forums.opensuse.org/showthread.php/531075-Zypper-Dup-kills-Cinnamon-desktop thread. I was on snapshot 20180613, ran zypper dup to get to 20180615. After lightDM, I got only the IceWM desktop, and a message indicating that Cinnamon had crashed.

The auto-generated email accompanying the 20180615 snapshot indicates no Cinnamon related files (that I recognize!). However, I have now added the X11:Cinnamon:Current repository at https://download.opensuse.org/repositories/X11:/Cinnamon:/Current/openSUSE_Tumbleweed, as this was necessary to fix the issue in the above-linked thread. (As also described at https://bugzilla.opensuse.org/show_bug.cgi?id=1091701 )

With this X11:Cinnamon repository enabled, zypper dup wanted to add the following packages:


I ran zypper to lock down everything that I know of related to Cinnamon:

#  | Name                                       | Type    | Repository
1  | cinnamon                                   | package | (any)     
2  | cinnamon-control-center                    | package | (any)     
3  | cinnamon-control-center-common             | package | (any)     
4  | cinnamon-control-center-lang               | package | (any)     
5  | cinnamon-gschemas                          | package | (any)     
6  | cinnamon-gschemas-branding-openSUSE        | package | (any)     
7  | cinnamon-lang                              | package | (any)     
8  | cinnamon-metatheme-numix                   | package | (any)     
9  | cinnamon-screensaver                       | package | (any)     
10 | cinnamon-screensaver-lang                  | package | (any)     
11 | cinnamon-session                           | package | (any)     
12 | cinnamon-session-lang                      | package | (any)     
13 | cinnamon-settings-daemon                   | package | (any)     
14 | cinnamon-settings-daemon-lang              | package | (any)     
15 | cinnamon-theme-adapta                      | package | (any)     
16 | cjs                                        | package | (any)     
17 | gtk2-metatheme-adapta                      | package | (any)     
18 | gtk3-metatheme-adapta                      | package | (any)     
19 | libcinnamon-control-center1                | package | (any)     
20 | libcinnamon-desktop-data                   | package | (any)     
21 | libcinnamon-desktop-data-branding-openSUSE | package | (any)     
22 | libcinnamon-desktop-lang                   | package | (any)     
23 | libcinnamon-desktop4                       | package | (any)     
24 | libcinnamon-menu-3-0                       | package | (any)     
25 | libcjs0                                    | package | (any)     
26 | libmuffin0                                 | package | (any)     
27 | libnemo-extension1                         | package | (any)     
28 | metatheme-adapta-common                    | package | (any)     
29 | mint-y-icon-theme                          | package | (any)     
30 | muffin                                     | package | (any)     
31 | muffin-lang                                | package | (any)     
32 | nemo                                       | package | (any)     
33 | typelib-1_0-CMenu-3_0                      | package | (any)     
34 | typelib-1_0-CinnamonDesktop-3_0            | package | (any)     
35 | typelib-1_0-CjsPrivate-1_0                 | package | (any)     
36 | typelib-1_0-MetaMuffin-0_0                 | package | (any)    

and re-ran zypper dup. That fixed the problem; I’m up and running again with the 4.17.1 kernel.

https://bugzilla.opensuse.org/show_bug.cgi?id=1091701 is still open, so I gather that it’s still necessary for Cinnamon desktop users to include the X11 repository. Is this an experimental/testing repo, that gets incomplete additions of new Cinnamon packages? (I’m unclear on how Tumbleweed repositories differ.) If so, should I keep all Cinnamon files locked down until the security issue at https://bugzilla.suse.com/show_bug.cgi?id=1090371 is addressed, and it’s safe to remove the X11 repository?

I haven’t personally followed what’s happening with Cinnamon,
I only know that that the few times I’ve installed Cinnamon, for whatever reason it’s a procedure that isn’t similar to installing any other Desktop… Until possibly now.

When I looked at your posted link, I noticed those .ymp files which aren’t typical.
When I took a look at the contents of those “one click install” files, to my surprise they both look like pattern definitions for installing Cinnamon, similar to what you’d see when installing any other Desktop. Why someone placed those files there and as .ymp files, and not make them the same as any other Desktop install pattern file, I have no idea.

Those files present interesting possibilities…
One or both might provide a way to install, or even re-install Cinnamon without the effort you put into locking your files.
This needs testing to determine whether they work and how (unless the person who created those files steps forward and explains all to us).


Thanks for the response, tsu2. I hadn’t noticed the ymp files, but see that wikipedia has an entry to explain them: https://en.wikipedia.org/wiki/YMP_File

I know that the still-open https://bugzilla.opensuse.org/show_bug.cgi?id=1091701 suggested the https://download.opensuse.org/repositories/X11:/Cinnamon:/Current/openSUSE_Tumbleweed repository as a temporary work-around, but remain confused by the different repository categories for Tumbleweed. If the X11:Cinnamon repository is experimental or receives incomplete package additions, it sounds like my system could repeatedly get hosed if I zypper dup while it is enabled.

I still have copies of the Tumbleweed partition made before this problem arose, and now wonder if I should restore one, lock everything related to Cinnamon, zypper dup without the X11 repository, and wait until bug 1091701 is finally addressed. That might be the easiest solution. The partition is small, and Clonezilla is fast. I don’t need to use the latest version of Cinnamon.

I also understand that I’m out on my own branch if other Cinnamon users aren’t having this issue.

.YMP files are what makes “One Click Install” happen when you visit https://software.opensuse.org/search/ with a web browser installed from your distro’s OSS repository.

This means that if you double-click on these two YMP files with your openSUSE web browser, it looks like your web browser should be able to lauch the YaST installer fully configured to install (and maybe re-install?) Cinnamon. if there is an order to installing using these two YMP files, I’d recommend installing the “basis” first.


If you use such repos, make sure that all the packages concerned come from that repo. Find the digit that represents that repo, than do

sudo zypper dup --from #digit --allow-vendor-change

Use the --allow-vendor-change option with ‘zypper dup’ if it wants to change vendor for Cinnamon packages.

Thanks again for your efforts to help, tsu2, and Knurpht, thank you for the tip re the zypper dup options. That may come in handy for the future.

I wound up going with the hunch described in post #3, above: restoring a partition saved before adding the X11 repository, locking all Cinnamon-related packages and then running zypper dup to get back up to speed. Ironically, this puts me back to the solution I’d stumbled on when this 1091701-bug-related problem started, described in post #2 at https://forums.opensuse.org/showthread.php/531075-Zypper-Dup-kills-Cinnamon-desktop .

I’ll keep Cinnamon packages locked until this bug is addressed, and I can safely update Cinnamon with zypper dup without having to use special repos.

I have that repo enabled on my v.15 install and Cinnamon DE crashed yesterday after a Zdup.

But I don’t have said repo on my Tumbleweed install and had no issue with the v.20180615 upgrade.

From my Tumbleweed install running Cinnamon 3.8.3

─> cinnamon --version
Cinnamon 3.8.3
─> sudo zypper info cinnamon

Information for package cinnamon:
Repository     : Tumbleweed_OSS                                  
Name           : cinnamon                                        
Version        : 3.8.3-1.2                                       
Arch           : x86_64                                          
Vendor         : openSUSE                                        
Installed Size : 9.0 MiB                                         
Installed      : Yes (automatically)                             
Status         : up-to-date                                      
Source package : cinnamon-3.8.3-1.2.src                          
Summary        : GNU/Linux Desktop featuring a traditional layout
─> cat /usr/lib/os-release
NAME="openSUSE Tumbleweed"
# VERSION="20180615"
ID_LIKE="opensuse suse"
PRETTY_NAME="openSUSE Tumbleweed"
─> sudo zypper lr


# | Alias                               | Name                   | Enabled | GPG Check | Refresh
1 | Google-chrome                       | Google-chrome          | Yes     | (r ) Yes  | Yes    
2 | Google-talkplugin                   | Google-talkplugin      | Yes     | (r ) Yes  | Yes    
3 | Nvidia                              | Nvidia                 | Yes     | (r ) Yes  | Yes    
4 | Packman_Tumbleweed                  | Packman_Tumbleweed     | Yes     | (r ) Yes  | Yes    
5 | Tumbleweed_OSS                      | Tumbleweed_OSS         | Yes     | (r ) Yes  | Yes    
6 | Tumbleweed_OSS-updates              | Tumbleweed_OSS-updates | Yes     | (r ) Yes  | Yes    
7 | Tumbleweed_non-OSS                  | Tumbleweed_non-OSS     | Yes     | (r ) Yes  | Yes    
8 | http-download.opensuse.org-c012d5b8 | loisronhab             | Yes     | (r ) Yes  | Yes    
9 | skype-stable                        | Skype                  | Yes     | (r ) Yes  | Yes 

The loisronhab provides only Neofetch package.

Tonight I tried another zypper dup in my v.15 install with the X11:Cinnamon repo enabled.

Again it crashed …

Not yet safe to tread in that repo yet with the bump to 3.8.4.

The purgatory of 3.8.4 has come to an gleeful finale.

Cinnamon 3.8.6 packages from X11:Cinnamon repo are showing none of the previously mentioned issues.

You’re braver than I am, McQueen! I’m going to steer clear of the X11:Cinnamon repository after the issues cited above.

FWIW: I installed two test openSUSE Cinnamon VMs using the procedure described at https://forums.opensuse.org/showthread.php/527435-How-to-install-openSUSE-Tumbleweed-with-the-Cinnamon-desktop-and-lightDM , one with Leap 15 and the other with Tumbleweed. No special repos, no locked packages.

The Leap 15 VM works. Cinnamon on the Tumbleweed VM crashes repeatedly, defaults to IceWM. I’ll wait until I can successfully zypper dup the Tumbleweed VM before pulling the package locks on bare metal Tumbleweed.

Problem solved! (I think, I hope) I saw today’s notice of a new snapshot at https://lists.opensuse.org/opensuse-factory/2018-06/msg00340.html , noted:

==== polkit-default-privs ====

- polkit-default-privs: add cinnamon-control-center datetime action 
- polkit-default-privs: add lightdm rules (bnc#1089436)

in the message, and decided to update Cinnamon Tumbleweed in the above-mentioned VM. Success! No IceWM, no Cinnamon crash.

I removed all locks in the bare metal Tumbleweed Cinnamon installation, ran zypper dup. Success again! Problem fixed, no more package locks, no special repositories used.