Zypper dup speeds terrible

Terrible speeds doing updates, how do I reset mirrorlist to Canada and US only?

If you are in Canada or USA, those are the mirrors that you should be getting.

At one time, geolocation for IPv6 was bad, and I was getting mirrors from Bangladesh. So I added an IPv4 entry to download.opensuse.org to “/etc/hosts”. That way I got good mirrors, and the mirrors still used IPv6. I think that was fixed, but I am unable to check because my current ISP does not provide IPv6.

Hmm, if you are hiding behind a “tor” proxy, you would probably get bad mirror redirection.

You can change the url for your repo to the preferred mirror. Just use Yast Software Repositories and edit the url – but keep the same name. For a list of available mirrors, visit with a web browser and click on the link for “details”.

Ok I’ll check that out and thx for the help and info :good:

Just a follow up, I disabled ipv6 or set it to ignore in Network connections applet since my ip only uses ipv4, disabled Packagekit and deleted this line [NOTFOUND=return] in /etc/nssswitch.conf at “hosts”. I did a zypper refresh to check speed and it was fast, I’ll see what’s its like at next update

I should perhaps mention that updating Tumbleweed is sometimes slow. That’s because there are many packages to download and many Tumbleweed users are downloading them at the same time. It has gotten better, with improvements in getting some mirrors up before the update is announced. But I do often see slower speeds for Tumbleweed updates than I see for Leap 15.1 updates.

Ok thx that makes sense never thought of that, thx for the help

And also seeding to the mirrors, so may be getting a file from a different mirror, that can be an issue if you do define a mirror and it hasn’t yet synced and can’t find a file…

Great help here, thx for the info