Zypper dup reporting several checksum errors with ghc modules

I ran zypper dup this morning and had several checksum errors reported on the download. These were all ghc- modules such as ghc-pretty, ghc-binary, ghc-directory. discarded the offending files. I assumed these issues would be fixed as has happened in the past and decided to try again later.

I ran zypper dup again this evening and the same errors are being reported. I am reluctant to accept the downloads with checksum errors until I am advised because I have no idea where the problem has arisen. Grateful for advice please.

@Budgie2 mirrors are syncing for a new snapshot, try again…

Hi and thanks. Not here yet. I shall try in the morning.

I have reported zypper ghc problems in Applications for leap on thread below:

Patch problem with ghc, ongoing for a few days

I reported to buzilla about 3 weeks ago and no changes.

tom kosvic

“This morning … this evening …” ah, yes, probably much different time zone, since it’s only 2:10pm Central in the US :slight_smile:

So, that (ghc…) suggests you’re using Haskell for something … what would that dependency be for ? (mostly curious, as I’ve not had to use Haskell).
Maybe Haskell has a dependency on the (kde5 → kde6) libraries (?)

Hi aggie,
I had never seem ghc before. I think your “maybe” point could be the reason as I have never knowingly used the ghc.

My problem is that the issue is still there, 24 hours later, so the mirror syncing may not be the problem. This brings me to the next question-
Should I override the checksum pause for the five problem modules?

If you don‘t know if you need it, why not uninstalling it?
If you later see that you need it, you can install it again…

Hui, as you know I know very little of the inner workings of TW. I have only ever installed the apps I need and rely on zypper dup to do the heavy lifting. I have a good bit of trouble with the update of Plasma 6 and it is quite possible that ghc has been brought in as part of the upgrade process.
I shall leave this a bit longer before doing anything as radical as you suggest but will keep in mind. I rather hoped somebody else who recognises this issue might have come across the problem with an explanation.

I checked my system for any ghc* packages. They are listed, but zero are installed. But of course, everyone’s software needs are different.

If you’re a software developer and need Haskell stuff, then keep it (or maybe you’re using some arcane app that requires Haskell) … if it were me, I’d delete all the ghc* packages.

You could run Yast2 Software Management (GUI) module, and in the Search text box, type “ghc” (no quotes) and tap the Search button. Then, in the software list pane, select to uninstall the packages .

You will probably see a pop-up recommending removal of other dependent packages. That might clue you in as to the “why” some package requires Haskell.

Anyway - up to you … personally, i’d remove the ghc* packages - why have software installed (and causing update issues) that you’ll never use.

Hi aggie,
I am looking at this again. I now have 10 packages to be re-installed:-

ghc-array ghc-binary ghc-directory ghc-exceptions ghc-filepath ghc-mtl ghc-pretty ghc-time ghc-transformers ghc-unix

but there are many others to remove. I have no idea why these packages were installed initially and as nobody else has reported this I have removed the lot and after a reboot it is a case of ‘so far so good.’

One of TW’s mysteries! Thanks for the encouragement.

1 Like

Hi aggie,
A post script to this thread; I had to use my laptop to do some work on our wifi APs, for which requires a walkabout. Since the laptop had not been used for a while I ran sudo zypper dup. I had the same issue with the ghc* packages.

I find this strange because the laptop is a very simple installation with few apps. I might have unknowingly required GHC on the workstation I had been using when installing an app, but I do not understand why my GHC stuff is on my laptop. Why has nobody else had this problem I wonder?

I have removed all the ghc* packages from the laptop and it seems fine.

1 Like

I have seen that ghc is used in the build/compilation process of stellarium – an astronomy program. That must be where I needed it in the past. I think stellarium is a reasonably well used product.

tom kosvic

I’m the occasional Stellarium user, but I only use the web version (if I were more heavily involved in star-gazing, I’d probably prefer the dedicated app).

I see also that haskell (ghc) is used in build of rstudio. That is ide for running R processes.
Think it is worth fixing the ghc update

tom kosvic

@tckosvic and @myswtest … (no GHC for this):

# zypper in stellarium
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 9 NEW packages are going to be installed:
  libQt6Charts6 libQt6MultimediaWidgets6 libQt6SerialPort6 libgstphotography-1_0-0 libindiclient2 libnlopt0
  libnova-0_15-0 qt6-multimedia stellarium

9 new packages to install.
Overall download size: 252.3 MiB. Already cached: 0 B. After the operation, additional 392.8 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): n
# 

.
And yes, rstudio would pull in a bunch of GHC stuff, PLUS many others!!

# zypper in rstudio
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 7 recommended packages were automatically selected:
  gcc gcc-c++ git git-email libclang13 mathjax pandoc-cli

The following 2 packages are suggested, but will not be installed:
  rstudio-desktop rstudio-server

The following 272 NEW packages are going to be installed:
[ ...  a bunch of packages listed here ...]

272 new packages to install.
Overall download size: 255.2 MiB.
#

Easy to avoid:

> LANG=C sudo zypper in --no-recommends rstudio
Refreshing service 'NVIDIA'.
Refreshing service 'openSUSE'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 49 NEW packages are going to be installed:
  R-KernSmooth R-MASS R-Matrix R-base R-base-devel R-boot R-class R-cluster R-codetools R-compiler R-core R-core-devel R-core-doc R-core-libs R-core-packages R-datasets R-foreign R-grDevices R-graphics R-grid R-lattice R-methods R-mgcv R-nlme R-nnet R-parallel
  R-recommended-packages R-rpart R-spatial R-splines R-stats R-stats4 R-survival R-tcltk R-tools R-utils libboost_chrono1_84_0 libboost_filesystem1_84_0 libboost_iostreams1_84_0 libboost_program_options1_84_0 libfmt10 libgfortran5 libpq5 libquadmath0 libsoci_core4_0
  libsoci_postgresql4_0 libsoci_sqlite3-4_0 rstudio tk

49 new packages to install.
Overall download size: 78.5 MiB. Already cached: 0 B. After the operation, additional 172.0 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): 

Not a single GHC package gets installed…

1 Like

Yes, I was going to say that for some reason, it was pulled in or is being pulled in as a recommended.

Once it is pulled in, it is going to want to update. If not needed, remove them. And, if in another

zypper dup

it wants to be installed again, add the --no-recommends switch. Or, if there appears to be no use on your system, you can always remove, then taboo them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.