Zypper dup not working, nothing provides..

Hi,

For the last week or so when I have tried to do a distribution upgrade (which I used to do regularly) I get the following message:

Problem: nothing provides libqt4-x11 >= 4.4.3 needed by kdelibs4-4.1.2-44.2.i586
Solution 1: do not install kdepimlibs4-4.1.2-1.2.i586

I am unable to upgrade because of the problems it would cause.
Here are my repos:-

| Alias | Name | Enabled | Refresh

—±-------------------------------------------------------------------------------------±---------------------------------------------±--------±-------
1 | Index of /distribution/11.0/repo/oss | Main Repository (OSS) | Yes | Yes
2 | KDE_4_Extra_Applications_STABLE | KDE 4 Extra Applications STABLE | No | Yes
3 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes
4 | KDE:Qt | KDE:Qt | No | No
5 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
6 | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0 | openSUSE BuildService - KDE4:Factory:Desktop | Yes | Yes
7 | VideoLan Repository | VideoLan Repository | No | Yes
8 | Index of /distribution/11.0/repo/non-oss | Main Repository (NON-OSS) | No | Yes
9 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | No
10 | KDE_4_STABLE | KDE 4 STABLE | Yes | Yes
11 | Main Repository (OSS) | Main Repository (OSS) | No | Yes
12 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
13 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
14 | Packman Repository | Packman Repository | No | Yes
15 | Index of /repositories/KDE:/Community/openSUSE_11.0 | openSUSE BuildService - KDE:Community | Yes | Yes
16 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
17 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | No | Yes
18 | Kde_4_Unstable | Kde 4 Unstable | No | Yes
19 | X11:XGL | X11:XGL | Yes | Yes
20 | KDE:Qt44 | KDE:Qt44 | Yes | No

Any ideas?

Thanks.

Hi,

Make sure that you have the correct qt repository enabled: KDE 4 Update Problem - openSUSE Forums

hope this helps

Hi,

I added that repo and now I get this message:-

Reading installed packages…
5 Problems:
Problem: PolicyKit-kde-0.0.svn810197-4.78.i586 requires kdebase4-runtime >= 4.1.2, but this requirement cannot be provided
Problem: kdepimlibs4-4.1.2-1.2.i586 requires kdelibs4 >= 4.1.2, but this requirement cannot be provided
Problem: kdelibs4-4.1.1-49.1.i586 requires kdelibs4-core = 4.1.1, but this requirement cannot be provided
Problem: liboil-0_3-0-0.3.15-0.pm.2.i586 obsoletes liboil <= 0.3.14 provided by liboil-0.3.14-18.1.i586
Problem: libkdeedu4-4.1.2-25.2.i586 requires kdebase4-runtime >= 4.1.2, but this requirement cannot be provided

Problem: PolicyKit-kde-0.0.svn810197-4.78.i586 requires kdebase4-runtime >= 4.1.2, but this requirement cannot be provided
uninstallable providers: kdebase4-runtime-4.1.2-44.2.i586[Factory]
kdebase4-runtime-4.1.2-44.2.i586[http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0/]
Solution 1: Following actions will be done:
do not install PolicyKit-kde-0.0.svn810197-4.78.i586
do not install kdenetwork4-filesharing-4.1.2-28.2.i586
do not install kdegames4-4.1.2-18.2.i586
do not install kdemultimedia4-4.1.2-24.2.i586
do not install kde4-webkitpart-4.1.1.svn856106-14.10.i586
do not install kde4-plasma-addons-4.1.2-20.6.i586
do not install kde4-okular-4.1.2-40.2.i586
do not install kde4-kwrite-4.1.2-35.2.i586
do not install kde4-kweather-4.1.2-14.2.i586
do not install kde4-kwalletmanager-4.1.2-25.2.i586
do not install kde4-lskat-4.1.2-18.2.i586
do not install kdeartwork4-screensaver-4.1.2-15.2.i586
do not install kde4-kopete-4.1.2-28.2.i586
do not install kde4-khangman-4.1.2-25.2.i586
do not install kde4-ksudoku-4.1.2-18.2.i586
do not install kde4-ksnapshot-4.1.2-40.2.i586
do not install kde4-knotes-4.1.2-50.2.i586
do not install kde4-kscd-4.1.2-24.2.i586
do not install kde4-kshisen-4.1.2-18.2.i586
do not install kde4-ksame-4.1.2-18.2.i586
do not install kdeedu4-4.1.2-25.2.i586
do not install kde4-konsole-4.1.2-35.2.i586
do not install kde4-kreversi-4.1.2-18.2.i586
do not install kdebase4-4.1.2-35.2.i586
do not install kde4-konqueror-4.1.2-35.2.i586
do not install kde4-kmix-4.1.2-24.2.i586
do not install kde4-kpat-4.1.2-18.2.i586
do not install kde4-konquest-4.1.2-18.2.i586
do not install kde4-konqueror-plugins-4.1.1-14.6.i586
do not install kde4-krfb-4.1.2-28.2.i586
do not install kde4-kolf-4.1.2-18.2.i586
do not install kde4-krdc-4.1.2-28.2.i586
do not install kde4-knetwalk-4.1.2-18.2.i586
do not install kde4-kio_audiocd-4.1.2-24.2.i586
do not install kde4-kgamma-4.1.2-40.2.i586
do not install kde4-kmines-4.1.2-18.2.i586
do not install kde4-kmahjongg-4.1.2-18.2.i586
do not install kde4-kwin-4.1.2-96.1.i586
do not install kde4-klines-4.1.2-18.2.i586
do not install kde4-kpercentage-4.1.2-25.2.i586
do not install kde4-kjumpingcube-4.1.2-18.2.i586
do not install kde4-korganizer-4.1.2-50.2.i586
do not install kde4-kiriki-4.1.2-18.2.i586
do not install kde4-kio_sysinfo-11.0-81.16.i586
do not install kde4-kontact-4.1.2-50.2.i586
do not install kde4-kio_kamera-4.1.2-40.2.i586
do not install kde4-keditbookmarks-4.1.2-35.2.i586
do not install kde4-kgoldrunner-4.1.2-18.2.i586
do not install kde4-kfourinline-4.1.2-18.2.i586
do not install kde4-kdm-4.1.2-96.1.i586
do not install kde4-kgpg-4.1.2-25.2.i586
do not install kde4-kdnssd-4.1.2-28.2.i586
do not install kde4-kcolorchooser-4.1.2-40.2.i586
do not install kde4-kcalc-4.1.2-25.2.i586
do not install kde4-dolphin-4.1.2-35.2.i586
do not install kde4-blinken-4.1.2-25.2.i586
do not install kde4-kbounce-4.1.2-18.2.i586
do not install kde4-kblackbox-4.1.2-18.2.i586
do not install kde4-kbattleship-4.1.2-18.2.i586
do not install kde4-katomic-4.1.2-18.2.i586
do not install kde4-kanagram-4.1.2-25.2.i586
do not install kde4-gwenview-4.1.2-40.2.i586
do not install kde4-ark-4.1.2-25.2.i586
do not install kde4-akregator-4.1.2-50.2.i586
do not install kde4-kfind-4.1.2-35.2.i586
do not install kde4-bovo-4.1.2-18.2.i586
do not install kde4-kget-4.1.2-28.2.i586
do not install kdebase4-session-4.1.2-18.1.i586
do not install kdebase4-nsplugin-4.1.2-35.2.i586
Solution 2: do not forbid installation of kdebase4-runtime-4.1.2-44.2.i586
Solution 3: do not forbid installation of kdebase4-runtime-4.1.2-44.2.i586
Solution 4: Ignore some dependencies of PolicyKit-kde

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/C]:

Any ideas?

Thanks.

Hi,

it looks like you have forbidden the installation of kdebase4-runtime run zypper ll to get a list of locked RPMs. If it is listed there run zypper rl kdebas4-runtime to remove the lock.

hope this helps