Zypper dup not upgrading linux kernel

I’ve only recently migrated to the Tumbleweed repositories after installing 12.1 earlier this year.

Before KDE 4.8 was put into Tumbleweed I had run off the Opensuse 12.1 KDE48 repos jointly with Tumbleweed (thanks to Greg K for his effort in bringing us the update!).

For a while i noticed that my kernel wasn’t updating when i ran “zypper dup --from Tumbleweed”, but i assumed it was a dependency issue, however now that i have removed the KDE48 repos and am run entirely off Tumbleweed i still don’t get a kernel upgrade on “zypper dup”.

“uname -r” outputs: 3.1.9-1.4-desktop

I would like to upgrade to 3.2.5, which i understand resolves the ASPM power management issue.

Any help appreciated.

I might suggest you run YaST / Software / Software Management and search on kernel. Then select kernel-desktop and switch to the versions tab. If kernel 3.2.5 is in a repository you have, it should be there and selectable. I don’t use Tumbleweed, but often the problem you have is due to you having a kernel not from the present repository and the fact that the Software Management / Options / Allow Vendor Change is not selected.

Thank You,

I suggest you just run

zypper dup

That’s what I do

You probably should post your repo list. Perhaps you have a mistake there?

Info: http://forums.opensuse.org/content/55-how-upgrade-opensuse-12-x-tumbleweed.html

Thinking about it, I had a similar issue on this PC after I switched from an updated 12.1 install to Tumbleweed. I ended up manually updating the Kernel like jdmcdaniel3 suggested above, hoping I’d remember to update the kernel next time. However it didn’t matter as there was an update today and it did it automatically when I did zypper dup so I guess the one time manual update fixed whatever the issue was…

try this, substitute “Tumbleweed” by the name you gave the Tumbleweed repo

zypper dup --from Tumbleweed

Wow thanks for all the great replies.

I followed jdmcdaniel3 recommendations at looked at the available versions of kernel-desktop in Yast Software Management tool.

This shows there is indeed a more up-to-date version of the kernel from the Tumbleweed repository, but that the current version is:
“3.1.9-1.4.1-x86_64 from vendor openSUSE”

The Tumbleweed version states:
“3.3.0-17.1-x86_64 from Tumbleweed with priority 99 and vendor obs://build.opensuse.org/openSUSE:Tumbleweed”

I checked the option allowing vendor control (although i don’t think this is the problem) and then ran zypper dup from a terminal. This still didn’t upgrade the kernel, so i did “–from Tumbleweed” with result below:

zypper dup --from Tumbleweed

Loading repository data…
Reading installed packages…
Computing distribution upgrade…

Problem: vmware-guest-kmp-desktop-8.8.0_k3.1.0_1.1-2.1.2.x86_64 requires ksym(desktop:__init_waitqueue_head) = e174aa7, but this requirement cannot be provided
uninstallable providers: kernel-desktop-3.1.0-1.2.1.i586[openSUSE Current OSS]
kernel-desktop-base-3.1.0-1.2.1.i586[openSUSE Current OSS]
kernel-desktop-devel-3.1.0-1.2.1.i586[openSUSE Current OSS]
kernel-desktop-3.1.0-1.2.1.x86_64[openSUSE Current OSS]
kernel-desktop-base-3.1.0-1.2.1.x86_64[openSUSE Current OSS]
kernel-desktop-devel-3.1.0-1.2.1.x86_64[openSUSE Current OSS]
kernel-desktop-base-3.1.9-1.4.1.i586[openSUSE Current updates]
kernel-desktop-base-3.1.9-1.4.1.x86_64[openSUSE Current updates]
Solution 1: Following actions will be done:
install kernel-desktop-devel-3.1.0-1.2.1.x86_64 from excluded repository
deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
Solution 2: Following actions will be done:
install kernel-desktop-base-3.1.9-1.4.1.x86_64 from excluded repository
deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
Solution 3: Following actions will be done:
deinstallation of vmware-guest-kmp-desktop-8.8.0_k3.1.0_1.1-2.1.2.x86_64
deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
deinstallation of ndiswrapper-kmp-desktop-1.56_k3.1.0_1.1-19.1.2.x86_64
Solution 4: deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
Solution 5: deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
Solution 6: keep obsolete kernel-desktop-3.1.9-1.4.1.x86_64
Solution 7: break vmware-guest-kmp-desktop by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/4/5/6/7/c] (c):

When i choose to break these packages to move on, i get a stream of other packages with dependency errors. So it looks like i have some serious dependency issues. I suspect this was introduced while i was mucking around with KDE48 repos.

Here is my repo list:

zypper lr

| Alias | Name | Enabled | Refresh

1 | PackmanTumbleweed | PackmanTumbleweed | Yes | Yes
2 | Tumbleweed | Tumbleweed | Yes | Yes
3 | dvd | dvd | Yes | Yes
4 | google-earth | google-earth | Yes | Yes
5 | openSUSE Current OSS | openSUSE Current OSS | Yes | Yes
6 | openSUSE Current non-OSS | openSUSE Current non-OSS | Yes | Yes
7 | openSUSE Current updates | openSUSE Current updates | Yes | Yes


Solution 3: Following actions will be done:
deinstallation of vmware-guest-kmp-desktop-8.8.0_k3.1.0_1.1-2.1.2.x86_64
deinstallation of virtualbox-guest-kmp-desktop-4.1.4_k3.1.0_1.1-3.2.3.x86_64
deinstallation of ndiswrapper-kmp-desktop-1.56_k3.1.0_1.1-19.1.2.x86_64

I always uninstall all that garbage anyway and let me tell you what a game that is! It tries to install all the different kernel flavours and it needs brute force.
See what zypper does for you

When I migrated to the Tumbleweed from 12.1, I removed these packages:

zypper rm hdjmod-kmp-desktop ndiswrapper ndiswrapper-kmp-desktop open-vm-tools open-vm-tools-gui virtualbox-guest-kmp-desktop virtualbox-guest-tools virtualbox-guest-x11 vmware-guest-kmp-desktop

Linux 3.3.0-17-desktop x86_64
KDE: 4.8.1 (4.8.1) “release 2”

Later I installed Oracle VBox from this repo:
Index of /virtualbox/rpm/opensuse/11.4/

The problem is likely because you only have three of the four Tumbleweed repositories. There’s OpenSUSE Current OSS, Currrent non-OSS, Current Updates but also a simple Tumbleweed one. I had the exact same problem until I realized that.

Hi everyone,

Thanks for all your helpful replies and support. Sorry that i haven’t responded for a while - i was on holiday over easter and busy at work since then.

I followed caf4926’s instruction and just removed the packages with conflicting dependencies. There where a few more than those listed in the “solution 3” above - which align with what afshine says.

This was only possible by using the command “zypper dup --from Tumbleweed”. But after installing the upgrade, i ran just “zypper dup” and a few packages changed vendor and a few upgraded/downgraded. Now i simply run zypper dup and it performs the necessary upgrade (as i am doing currently with KDE 4.8.2 update!).

I wonder if the wiki page explaining how to move to Tumbleweed ought to be updated to introduce this step? Or maybe i just missed it.

Thanks again everyone for your help, i’ve spent a couple of years trying to find the best distro for me and i always keep coming back to Suse, so i’ve decided to stick with it properly for now. Tumbleweed gives me all that i love about openSUSE whilst being as cutting edge as the other distros i enjoyed - Linux Mint Debian, Chakra.

Hi trenthawkins, that is what i did as well. For anyone else trying to upgrade to Tumbleweed, this is how I did it. I removed those 9 packages listed above, and ran “zypper dup --from Tumbleweed”. After a reboot I added Packman repo, and ran “zypper dup --from Packman”. Since then, I’ve only used “zypper dup” to update the system.