zypper dup from 11.2RC1 wants to update EVERYTHING

Well this may be normal, but I don’t really understand the logic behind this.
I installed a fresh 11.2 RC1 from the kde live CD.
As you can see, the RC is using the official ‘11.2’ repo :

shaminou@linux-l4ae:~> zypper lr
# | Alias        | Name                  | Enabled | Refresh
1 | repo-debug   | openSUSE-11.2-Debug   | No      | Yes
2 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes     | Yes
3 | repo-oss     | openSUSE-11.2-Oss     | Yes     | Yes
4 | repo-source  | openSUSE-11.2-Source  | No      | Yes
5 | repo-update  | openSUSE-11.2-Update  | Yes     | Yes

but when I want to get updates, here is what I get :

shaminou@linux-l4ae:~> sudo zypper dup                           
root's password:                                                 
Loading repository data...                                       
Reading installed packages...                                    
Computing distribution upgrade...                                

The following NEW packages are going to be installed:
  AdobeICCProfiles apparmor-docs at bash-doc binutils bootcycle desktop-translations DeviceKit-disks dos2unix ed efont-unicode finger ft2demos fuse geoclue-gpsd 
  ghostscript-fonts-other gimp-help gimp-help-browser gimp-plugins-python gutenprint gvfs gvfs-backends gvfs-fuse hplip hplip-hpijs ImageMagick intlfnts         
  java-1_6_0-openjdk java-1_6_0-openjdk-plugin joe kdeartwork4-weatherwallpapers kdegames4-carddecks-other ksh ksymoops libatasmart4 libcdio10 libcdio_cdda0     
  libcdio_paranoia0 libdv4 libebl1 libfuse2 libgdu0 libgeoclue0 libglade2 libgvfscommon0 libiniparser0 libproxy0 libproxy0-config-gnome libproxy0-config-kde4    

  a little elipsis to avoid exceedind the post length limit]

  lsb-release lsof lsscsi lukemftp lvm2 mailx man manufacturer-PPDs marble marble-data master-boot-code mc mdadm meanwhile memtest86+ Mesa mhash microcode_ctl
  mingetty ModemManager module-init-tools MozillaFirefox MozillaFirefox-branding-openSUSE MozillaFirefox-theme-oxygen MozillaFirefox-translations-common mozilla-nspr
  mozilla-nss mozilla-xulrunner191 mozilla-xulrunner191-gnomevfs mozilla-xulrunner191-kde4 mozilla-xulrunner191-translations-common mpt-firmware mtools
  multipath-tools myspell-american nano ncurses-utils ndiswrapper ndiswrapper-kmp-desktop neon netcat netcfg netpbm net-tools NetworkManager NetworkManager-glib
  NetworkManager-kde4 NetworkManager-kde4-libs NetworkManager-openvpn NetworkManager-openvpn-kde4 NetworkManager-pptp NetworkManager-pptp-kde4 NetworkManager-vpnc
  NetworkManager-vpnc-kde4 nfs-client nfsidmap nss_ldap nss-mdns ntfs-3g ntfsprogs ntp numactl numlockx obex-data-server okteta okular OpenEXR openldap2-client
  openobex OpenOffice_org OpenOffice_org-branding-openSUSE OpenOffice_org-calc OpenOffice_org-components OpenOffice_org-draw OpenOffice_org-filters
  OpenOffice_org-help-en-US OpenOffice_org-icon-theme-oxygen OpenOffice_org-impress OpenOffice_org-kde4 OpenOffice_org-l10n-de OpenOffice_org-l10n-es
  OpenOffice_org-l10n-extras OpenOffice_org-l10n-fr OpenOffice_org-l10n-it OpenOffice_org-l10n-pl OpenOffice_org-l10n-ru OpenOffice_org-libs-core
  OpenOffice_org-libs-extern OpenOffice_org-libs-gui OpenOffice_org-templates-labels-a4 OpenOffice_org-templates-labels-letter OpenOffice_org-ure
  OpenOffice_org-writer openslp openssh openssh-askpass openssl openssl-certs openSUSE-build-key opensuse-codecs-installer openvpn orbit2 oxygen-icon-theme ozerocdoff
  PackageKit pam pam_apparmor pam-config pam_fp pam_krb5 pam_ldap pam-modules pam_mount pango parted patch patterns-openSUSE-apparmor patterns-openSUSE-base
  patterns-openSUSE-enhanced_base patterns-openSUSE-fonts patterns-openSUSE-games patterns-openSUSE-imaging patterns-openSUSE-kde4 patterns-openSUSE-kde4_basis
  patterns-openSUSE-kde4_games patterns-openSUSE-kde4_imaging patterns-openSUSE-kde4_internet patterns-openSUSE-kde4_multimedia patterns-openSUSE-kde4_office
  patterns-openSUSE-kde4_pure patterns-openSUSE-kde4_utilities patterns-openSUSE-kde4_yast patterns-openSUSE-multimedia patterns-openSUSE-non_oss
  patterns-openSUSE-office patterns-openSUSE-sw_management patterns-openSUSE-sw_management_kde4 patterns-openSUSE-update_test patterns-openSUSE-x11
  patterns-openSUSE-yast2_basis patterns-openSUSE-yast2_install_wf pciutils pciutils-ids pcmciautils pcre perl perl-base perl-Bootloader perl-Business-ISBN
  perl-Business-ISBN-Data perl-Config-Crontab perl-Crypt-SmbHash perl-Crypt-SSLeay perl-DBD-SQLite perl-DBI perl-Digest-HMAC perl-Digest-MD4 perl-Digest-SHA1
  perl-File-Tail perl-GD perl-GD-Barcode perl-gettext perl-HTML-Parser perl-HTML-Tagset perl-libwww-perl perl-Net-Daemon perl-NetxAP perl-Parse-RecDescent perl-PlRPC
  perl-RPC-XML perl-TermReadKey perl-TimeDate perl-URI perl-WWW-Curl perl-X500-DN perl-XML-LibXML perl-XML-LibXML-Common perl-XML-NamespaceSupport perl-XML-Parser
  perl-XML-SAX perl-XML-Simple perl-XML-Writer perl-XML-XPath permissions phonon phonon-backend-xine pinentry pinentry-qt4 pkcs11-helper pkg-config plasma-addons
  plasma-addons-marble plasma-theme-aya plasmoid-quickaccess pm-profiler pm-utils PolicyKit PolicyKit-doc polkit polkit-default-privs polkit-gnome polkit-gnome-lang
  poppler-tools postfix ppp pptp preload preload-kmp-desktop procps psmisc pullin-flash-player pwdutils python python-base python-kde4 python-kdebase4 python-qt4
  python-satsolver python-simplejson python-sip python-urlgrabber python-xml qt4-qtscript qtcurve-gtk2 qtcurve-kde4 quota recode reiserfs release-notes-openSUSE
  rpcbind rpm rpm-python rsync rsyslog sane-backends sane-backends-autoconfig satsolver-tools sax2 sax2-gui sax2-ident sax2-libsax sax2-libsax-perl sax2-tools saxon8
  sbl scout scpm sed setserial sg3_utils shared-mime-info sil-charis sil-doulos skanlite slang smartmontools smolt smolt-gui smp_utils soprano soprano-backend-redland
  startup-notification strace strigi sudo SuSEfirewall2 susehelp susehelp_de susehelp_en susehelp_es susehelp_fr susehelp_it suseRegister suspend sweeper sysconfig
  sysfsutils systemtap-runtime sysvinit taglib taglib-extras tar tcpd terminfo-base terminus-font tightvnc timezone translation-update translation-update-de
  translation-update-es translation-update-fr translation-update-it translation-update-pl translation-update-ru udev ulimit unrar unscd unzip update-alternatives
  update-test-optional update-test-trival usb_modeswitch usbutils utempter util-linux vim vim-base virtualbox-ose-kmp-desktop vorbis-tools vpnc w3m wdiff wget
  wireless-regdb wireless-tools wodim wpa_supplicant wvdial wvstreams x11-input-fujitsu x11-input-wacom x11-tools xalan-j2 xdg-menu xdg-user-dirs xdg-utils xerces-j2
  xerces-j2-xml-apis xfsdump xfsprogs xinetd xkeyboard-config xorg-x11 xorg-x11-driver-input xorg-x11-driver-video xorg-x11-driver-video-radeonhd
  xorg-x11-driver-virtualbox-ose xorg-x11-fonts-core xorg-x11-libfontenc xorg-x11-libICE xorg-x11-libs xorg-x11-libSM xorg-x11-libX11 xorg-x11-libX11-ccache
  xorg-x11-libXau xorg-x11-libxcb xorg-x11-libXdmcp xorg-x11-libXext xorg-x11-libXfixes xorg-x11-libxkbfile xorg-x11-libXmu xorg-x11-libXp xorg-x11-libXpm
  xorg-x11-libXprintUtil xorg-x11-libXrender xorg-x11-libXt xorg-x11-libXv xorg-x11-server xorg-x11-xauth xorg-x11-Xvnc xstroke xterm xz yakuake yast2 yast2-add-on
  yast2-apparmor yast2-backup yast2-bootloader yast2-branding-openSUSE yast2-core yast2-country yast2-country-data yast2-dbus-client yast2-fingerprint-reader
  yast2-firewall yast2-hardware-detection yast2-inetd yast2-installation yast2-irda yast2-iscsi-client yast2-kerberos-client yast2-ldap yast2-ldap-client yast2-libyui
  yast2-mail yast2-metapackage-handler yast2-mouse yast2-ncurses yast2-ncurses-pkg yast2-network yast2-nfs-client yast2-nfs-common yast2-nis-client yast2-ntp-client
  yast2-online-update yast2-online-update-frontend yast2-pam yast2-perl-bindings yast2-pkg-bindings yast2-printer yast2-profile-manager yast2-qt yast2-qt-pkg
  yast2-registration yast2-registration-branding-openSUSE yast2-repair yast2-restore yast2-runlevel yast2-samba-client yast2-samba-server yast2-scanner yast2-security
  yast2-slp yast2-sudo yast2-sysconfig yast2-theme-openSUSE yast2-theme-openSUSE-Oxygen yast2-trans-de yast2-trans-en_US yast2-trans-es yast2-transfer yast2-trans-fr
  yast2-trans-it yast2-trans-pl yast2-trans-ru yast2-trans-stats yast2-tune yast2-tv yast2-update yast2-users yast2-vm yast2-x11 yast2-xml yast2-ycp-ui-bindings
  ypbind yp-tools zd1211-firmware zip zisofs-tools zlib zypper

The following packages are going to be downgraded:
  kdebase4-openSUSE kdebase4-runtime-branding-openSUSE kdebase4-workspace-branding-openSUSE kdelibs4-branding-openSUSE kdm-branding-openSUSE kio_sysinfo
  kio_sysinfo-branding-openSUSE openSUSE-release

The following product is going to be reinstalled:

975 packages to upgrade, 8 to downgrade, 158 new.
Overall download size: 957.8 MiB. After the operation, additional 870.7 MiB will be used.
Continue? [y/n/?] (y):

So… should I understand that packagers went on fury and updated every packages of the repo, or is this something else ?

Actually, I decided to install the rc because I thought it would be the same as the final release… with just some package to update in some time to get the final release.

It was like that for me. Worked fine.
Left it on overnight because when I did it they had only just released RC2 and it was slow, I think everyone was trying to get it.

I think I did

zypper ref
zypper in zypper libzypp
zypper dup

well… then I’ll wait for the final release.
I’just wanted to know if there was some kind of logic behind this ‘replace everything’ behaviour…

Tried it myself and it goes like this:
First it came out, zypper dup is finally there everybody seem to want it. So I tried it on M8 and it started like yours did. it downloads and installs every rpm and on my 1 megabit connection it was slow, so I stoped it and downloaded the dvd and went from there. I bet that some peopple have the need for this feature but I just cant wait that long :slight_smile: (stearing at the screen on my toes to get the update)

I upgraded on Monday morning using zypper dup from RC1 to RC2, and like you I was surprised at the number of changed packages. IIRC the download was over 1GB, but I have two kernels installed and also I prefer to upgrade with only oss and non-oss repos enabled, so some packman packages get removed and replaced with distro ones. If the upgrade checks out ok, I then enable packman’s repo and reinstall the multimedia stuff.

The download speed was about the slowest I can remember, even on 10Mb/sec BB. The upgrade worked extremely well. :slight_smile: