Zypper dup from 11.2 to 11.3 hosed System

After upgrading to 11.3 I no longer have a GUI system.

First the upgrade hosed grub and I had to fix the menu entries, as the upgrade set the wrong drive as the root partition. I tried downloading an install disk, but the Repair System option is gone, so I had to use rescue system to edit the grub menu.

So now at least I can boot again, however there is no X11 working. I tried using Sax2 to configure it, but there is no longer Sax2 to use. So how do I configure X then?

If you ask me, OpenSuse is going backwards, instead of forwards.


Tried everything on the link provided except 6 and 7 .

Each 'solution results in X starting to load, and then frozen system, with the log stopping abruptly. after the lines:

I2C device “DVI-0:ddc2” registered at address 0xA0.
I2C device “DVI-0:DDC control interface” registered at address 0x6E.

If there is an existing /etc/X11/xorg.conf
that is there from 11.2, consider trying a rename of it…Eg: as su: mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Mind you, if it were me, I would have done a fresh install. It’s a hell of a lot quicker than dealing with all this dog’s breakfast.

You are quite right when you say there is no Sax2 in 11.3.

# Xorg -configure

You did not provide us with any specs to help you. You have the
reference caf4926 gave you.

Yes I have the reference link as you suggested, however if you read my last post none of those solutions worked at all, they just resulted in a frozen X, and blank screen and no way to kill the x server as ctrl-alt-back did not work, and I had to restart the computer. I ended up trying step 7 which was install proprietary driver ( ati) however this says it can’t find any XFree86.

So I ended up downloading the install disk , and ran upgrade from the install and it upgraded more then 200 packages even though zypper dup said everything was up to date even after a zypper ref.

Anyway choosing upgrade from the install on the disk got me working GUI,no acceleration:(, andr now I can’t get vmware running, it says that kernel headers for version 2.6.34-12-desktop can’t be found. Even though according to yast they are installed, and checked usr/src/linux which seems to be the correct link. I did a make cloneconfig, make and everything compiled fine, so I assume the headers are installed properly, so why can’t vmware compile the necessary modules, any ideas?

Update - make modules works, but with a warning that modpost found 18 section mismatches, would this be relevant at all maybe?

What do you get with

zypper verify

zypper verify reports all dependencies satisfied.

And post result of

rpm -qa | grep kernel

Fixed vmware problem.

Tried manually compiling the vmware modules, didn’t work but found problem.

autoconf.h which should be in


has now been moved to


A simple symlink solved the problem and now the vm modules compile.

Good news…