Zypper does not continue downloading files

Some days ago, my internet connection became very unstable and interrupts every 2-10 minutes, so zypper cannot download packages to install.

  1. Is there a way to ask zypper to continue downloading file from the previous attempt? There are ocasions, when zypper downloaded 18/20 Mb, and the next attempt began downloading from the very beginning.

  2. Is there a wey to force zypper retry downloading packages in non-interactive mode? I cannot answer ‘r’ on zypper questions every 2 minutes.

It would be best for You to enable the aria2c backend. If i’m not wrong it you should put a line like this " EXPORT ZYPP_ARIA2C=0" in /etc/boot.local (some are claiming to put it in /etc/profile.local but i couldn’t find this file in 11.1)
If it is the right code you shouldn’t have any problems downloading packages even if your connection drops.

You mean, zypper doesn’t begin again after any interruption?

No only that, but when I used the -D flag which man zypper says means Dry Run, I observe that it ran a 180 MB download to completion. Downloaded everything and in true *nix fashion reported no error. So why does running the same #&%$ command again without the option result in re-downloading 180 MB again?

I have read arguments that zypper is so much better than apt-get, but suboptimal executions like this make me wonder.

Maybe I misread the man file? But it says in several places that -D is for Dry-run. It also uses -D in other places with other effects. Could it be that they haven’t decided what it does or when it does it? I surely expected a Dry Run to “simulate”. If downloading was carried out then why in the name of sanity, doesn’t it keep them and use them. I didn’t actualize anything again.

I hope there is an explanation and that the developers of zypper only put the -D in to fool old apt-get users into thinking that they could test and not have to redownload everything again. I hope there is a reasonable explanation. It just seems like an enormous waste of time and resources.


You need to enable caching if this is correct it should do it…

zypper mr -k -all

from here All 1 entries tagged Zypper, Mike’s blag

check with zypper help…

Thanks FM, and thanks to Mike, for a very useful blog. Read the man file and info on 11.1 zypper but the 11.0 info on Mike’s blog is much clearer:

zypper mr -k -all

worked fine, but

zypper -l -y update --dry-run

didn’t until I removed -l -y, then

zypper update --dry-run

continued with

Loading repository data…
Reading installed packages…
Nothing to do.

Great! Next time will have the cache on.

Internet connection has been rather intermittent last few days and I just hoped to update even if it died.

Apologies for the near rant. Started with SuSE 7.2 but never very successful 'cause I didn’t know about winmodems. Eventually a serial modem cured my problem. Then Mandrake8.1, Mepis2003, Kanotix and last few years sidux/sid.

One of my clients chose openSuse11.0 for their enterprise, so back learning again. I’m OOo support but have to stay ahead of the users. Learning to like openSuse. Seems a good choice for their company, especially go-oo. Currently waiting on our tech support to build a new image for 11.1 with OOo3.1 but I think Kde4.2 is causing some headaches. Kde4.1 has caused learning pains for me. :frowning:

I’ve had no success trying to build a USB pendrive image to install on my AA1. Tried all the tutorials but so far have not managed to install oSuse11.1 on the AA1. Not a problem just a curiosity.

I’m a confirmed Kde3.5.10 user. Kicking a bit while learning Kde4x.

Thanks for your help.
My apologies for wordiness and getting carried away.