Zypper broken after last update

Hi guys.

I updated my tumbleweed installation about 3-4 days ago. I tried ‘zypper ref’ again today, and got the following message:

zypper: relocation error: zypper: symbol _ZN4zypp5CpeId11NoThrowType13lastMalformedE, version ZYPP_plain not defined in file libzypp.so.1519 with link time reference

Any ideas how to get out of this?

I am not seeing that.

However: During a recent update, X was restarted. If you were running the update from within X, then it is possible that the update did not fully complete.

I ran my update with “zypper dup” running under “screen”. So “screen” continued to run and the update continued after the update.

This happened once before – I think it was in May 2014. And I had a broken zypper.

I booted the live rescue CD, and mounted the system at “/mnt”. I also did:


# mount --bind /dev /mnt/dev
# mount --bind /proc /mnt/proc
# mount --bind /sys /mnt/sys

I’m not sure whether those were really needed.

I then used:

# zypper -R /mnt dup

(I think that was the command, but best check man pages).

This used the working zypper on the rescue media to complete the update on the mounted system. If fixed the problem for me.

Since then, I always run updates from within “screen” or from a virtual terminal (CTRL-ALT-F1) so that restarting X won’t interrupt it.

My “zypper dup” did not complete ~ hung & system said zypper was busy when I tried to continue.

Closed the active terminal. Stopped the process as root (using “ctl+esc” and search for zypper); yes, it was still running.

In a new terminal, did “zypper ref” & “zypper dup” again and then it completed the update with no problems.