zypper broken after an interrupted update

Hi, I was doing “sudo zypper ref && sudo zypper up”, then I was test running an overclock program which gave me some “kernel errors” warnings due to my parameter mistake. I had forgotten about the update and don’t remember how it quit itself. All I know is that “sudo zypper” gave me error about “sudo”, so I reboot the computer afterward.

But now it is:

sudo zypper clean -a
[sudo] password for root:  
zypper: error while loading shared libraries: /usr/lib64/libzypp.so.1722: file too short

I can su into root but zypper gives the same error. I also notice that audio device is empty now.

I once had a similar problem. This was with factory (before “Tumbleweed” existed in its current form).

I booted the install media – in this case a USB drive with a copy of the DVD iso.

I then mounted the installed system at “/mnt” (all needed partitions).

Next I did something like:

mount --bind  /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

Then I used “zypper” from the install media, with:

zypper --root /mnt ...other-zypper-arguments

In your case you will need to update or install “libzypp”, perhaps “zypper” itself and perhaps “libsolv-tools”.

The idea is that you are using the working “zypper” on the install media to update the mounted system.

If you cannot get that to work, then the next option is a reinstall.

Is it possible to download the zypper package and use rpm to install/repair it?

Any reason the link does not work for me to download zypper from:

It directs me to page

No data for openSUSE:Leap:15.3 / zypper

after I click “expert download”

This is how I’ve done it more than once over the years. Fetch the zypper, libzypp and any dependent rpms needed from the mirrors, not from software search. When you try to install, rpm will report any missing deps you might need in addition to those you know about. You’ll need to get those and try again to do the whole bunch at once until the bunch is a complete dependency matchup. Before running rpm, you may need to run rpm --rebuilddb due to the interruption. If ultimately this doesn’t work, you’ll need to try as nrickert described.

If you’re up for adventure, you could download the libzypp rpm containing libzypp.so.1722, enter the rpm using mc, and copy the complete file over the short file present on the system. I’ve done this with other libs, but not with libzypp (that I can remember).

Hi, I did just that and it fixed zypper. Copied the file from another suse machine.

Now I have another serious problem and I don’t know if I should start a new thread.

After zypper started working, strangle I had to zypper up several times in half an hour. After each update/reboot, when I do ref&up there are new updates. I had to do it 3 times or so. Then my grub become this !!

Am I hacked???

Edit: Adding image link coz insert image doesn’t work for me:

Use http://paste.opensuse.org

https://paste.opensuse.org/61815855 (still not showing using image insert)
Not sure what happened to the grub. After I fixed the zypper, it looks alright except I’ve lost video driver after a few more repeated zypper updates in half an hour. I feel like being hacked because I ran the package corectrl installed from a home:repo named Dead_Mozay.

What’s more stupid is snapper can’t work probably because of my cpu replacement yesterday. BIOS said sth about TPM reset after I replaced a new CPU. Now when I try to use snapper to boot earlier image it gives some TPM error stuff.