Zypper and YaST corrupt [HELP!]

Guys I finally shifted to openSUSE from Ubuntu because the latter was becoming progressively buggy.

And yesterday, I was updating my SUSE when my internet connection died on me, and the updated failed, and you can guess what happened.

Nothing I am doing is helping, including using the .rpm archive installer to reinstall libzypp. I also tried the relinking suggestion I found off a search on this community. Nothing. works.

Please, please help.

Hi, welcome to the forums.

Sad thing, this happening during an update. Nothing lost yet. Is the installer the only thing that does not work? Meaning, you can login to the desktop and have a working internet connection ?

Writing this from my happily purring OpenSUSE. Everything else is good.

Does it not start at all ? If it does , does it throw messages ? If so, please post them here.

Also post output of


zypper lr -d

Read this thread, follow oldcpu’s instructions, that should fix it:
libzypp Not found after update - openSUSE Forums

Please let know how you got on.

I have narrowed down to the following files:

zypper_versionstuff.rpm
(I renamed it to something convenient).
See this:


linux-scvm:/home/angadude/Download # rpm -i zypper.rpm
error: Failed dependencies:
	libreadline.so.5()(64bit) is needed by zypper-1.0.2-1.5.x86_64
	libzypp.so.523()(64bit) is needed by zypper-1.0.2-1.5.x86_64


So I need those two files off the internets. Links would be disproportionately appreciated :smiley:

try: boot from the install DVD and do this: http://tinyurl.com/yajm2aq

then, if the disk checks ok select Repair Installed System…

if it doesn’t check ok, post again…

if that does not work then use the backup you made prior to the
trouble beginning to restore a working system…


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio


linux-scvm:/home/w4lrus/Download # zypper lr -d
If 'zypper' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf zypper
linux-scvm:/home/w4lrus/Download # 



Edit: Okay, I got me libzypp. One more to go.

Is this openSUSE-11.2 ? Do you still have the problem?
Can you update with zypper ? If you can update with zupper, then try in a terminal with root permissions:

zypper ve

… the reference for that command is here: Zypper/Usage/11.2 - openSUSE

… if zypper is de-installed (for some reason) then you need to install from the UPDATE repository: Index of /update/11.2/rpm
manually downloading to your hard drive: zypper (not the delta zypper) and libzypp and install them with root permissions:

rpm -Uvh zypper-1.3.4-0.1.3.x86_64.rpm libzypp-6.31.4-0.1.1.x86_64.rpm 

(you may need to change the name for a 32-bit openSUSE) and also you may also need to download and install at the same time additional rpms to solve dependency problems, where you may need to get the rpms off of the OSS repository if not in the UPDATE repository: Index of /distribution/11.2/repo/oss/suse

and install all needed apps all at a time, in one line, with a space between rpms. Hopefully it does not come to that.

Once zypper is functional, try:

zypper ve

OP installed OK, this happened during update. Network connection got lost on an update that included new zypper packages …:slight_smile:

This repo should have all the new zypper and yast packages you need:
Index of /update/11.2/rpm

Keep us posted (huhhuh, you are already)
Mind, you have to get the x86_64 packages, but I guess you know that.

I ran this:

linux-scvm:/home/angadude/Download # rpm -Uvh zypper-1.3.4-0.1.3.x86_64.rpm libzypp-6.31.4-0.1.1.x86_64.rpm
error: open of zypper-1.3.4-0.1.3.x86_64.rpm failed: No such file or directory
error: open of libzypp-6.31.4-0.1.1.x86_64.rpm failed: No such file or directory

Okay this is wierd:


linux-scvm:/home/angadude/Download # rpm -i --replacepkgs libzypp-6.31.4-0.1.1.x86_64.rpm
	file /usr/lib64/libzypp.so.631.0.4 from install of libzypp-6.31.4-0.1.1.x86_64 conflicts with file from package libzypp-6.31.4-0.1.1.x86_64


IT WORKS! :smiley:

Thanks guys, the openSUSE community is fantastic. The repo you linked me to was just what I needed. Now lets see if YaST runs.
Yep, YaST works great too.

EDIT:: What I did: Simply reinstalled the latest zypper. That repo has what you need.

Okay, YaST still is kind of handicapped. See this:


	libzypp.so.619 => not found
warning: the gtk frontend is installed but does not work
GTK GUI wanted but not found, falling back to Qt.
terminate called after throwing an instance of 'YUINoDialogException'
  what():  No dialog existing
YaST got signal 6 at YCP file /usr/share/YaST2/clients/sw_single.ycp:633
/sbin/yast2: line 454: 17836 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS


But zypper is working fine.

Edit: Now installing nmap. zypper > apt-get

You should install all yast related packages from the same repo. Please post output of ‘zypper lr -d’. Don’t start using apt-get or other package managers until this is fixed.
A simple ‘zypper ref && zypper up’ might very well pull in the missing yast updates (IMHO nothing else going on), i.e. finish updating. The errors look like the result of version mismatches.

But, you’ll get there, and got to know a new world :wink:

Further to Knurpht’s recommendations, if you have the correct repositories setup , you may be able to resolve any current problems with:

zypper ve

I recommended that above, but I can not tell exactly how far you went in following the recommendation.

The philosophy is to (1) sort zypper (which I think you have) and then (2) use the “zypper ve” to sort YaST.

OP’s problem was that zypper itself did not work anymore…I saw that in your post, used it once myself when something similar happened. But I did have the ‘zypper’ command available.

Its difficult to tell what they have done. I suggested downloading the rpms for zypper, and then gave the rpm command to run to install zypper AFTER the rpms were downloaded, and from what I can see they ran the rpm command BEFORE downoading the rpms !! >:(

Clearly they have not the knowledge to follow from my instructions. :frowning: And I am not able to make it more clear.

I think I will bow out of this thread, as the the knowledge gap is too big between myself and Angadude, and with different approaches to solve the problem coming from 2 different people, it must be very confusing.

AFAICS he’s got it sorted now. The wrong order of following your advice slipped my attention. DId not mean to confuse anyone ;).