Zypper and YaST are both SLOW

I’m seriously contemplating switching to OpenSUSE, but I haven’t used it since 13.2. I’m a bit of a bleeding edge freak and I always hear good things about Tumbleweed. I wanted to “try before I buy” so I got a Live-CD of Tumbleweed, but one big thing I want to do is jump straight on testing KWayland. To the point, I tried doing a zypper up, zypper clean --all && zypper refresh and updating from YaST, but they are both downloading at 15KiB/s!! WAT. So after some research I saw that IPv6 could cause problems, so I disabled it and made sure I was communicating over IPv4 only, got rid of my IPv6 address via sysctl and rebooted (cool thing suse has a persistent live image) and still no luck! Why is zypper downloading at such an appalling rate?

By default zypper uses a mirror assigned to your region could be it is busy or just not very good try a different one


have noticed first hour after snapshot released things are very slow. Sometimes on weekends too. most of the time its full speed.

Sorry for the late response, but I went to get back on later that day to respond and the forum would NOT let me log on after creating my new password, finally got it to work. I tried again and later that day it sped up. So after snapshots it slows (makes sense) and regions. I will try that next time. I think I will be jumping on tumbleweed later this week.

Be carefull, it is a rolling release.

It might move before you land.:slight_smile:

I think you’re really going to like Tumbleweed. I have it on two systems now and it’s superb!

just a note - discussion on factory mailing list hints at recent issues with tumbleweed mirrors so should be fixed very quickly.