ZSTD data corrupted

Hy all,
yesterday I found my desktop PC in blank screen.
I had left it switched on during the night to avoid a restart and I found it like that.
So… the PC was unresponsive to mouse and keyboard, and finally I reboot it.
At the restart, a message appeared during initial phase of boot that is

[ 0.808120][ T64] Initramfs unpacking failed: ZSTD-compressed data is corrupt

and system hanged up there.
After some retries, system rebooted.
Now, standard boot is that at the initial phase, you have a black screen with the message reported, and then after some seconds, text appearance changes (font change) and boot follows.
I’ve tried to understand what this ZSTD is, but all I know is a compressor like zip or rar.
So up to now, the PC works regularly but I do not understand if this thing could give me a problem in the next future.
Is there a way to “recover” this error?
If somebody needs a more specific information I can send the boot.msg file, here I don’t see a way to annex to the post.
My system is an old MB with a AMD8320e processor, and OpenSUSE 15.5 as the only OS.
File system is EXT4, so I don’t have BTRFS.

Did you do anything during that day that resulted in new kernel or updates to kernel, initrd or zstd? Zstd is Leap’s default initrd compression scheme.

If you choose to boot a prior kernel via the Grub menu’s “Advanced…” section, is the behavior the same?

If it was mine I would try reinstalling zstd and libzstd1 packages, then if nothing changed, I would rebuild the initrd for the current kernel.

Probably also good to check the health of your drive(s).

I am still wondering what is the best tool for the job, smartctl is not human friendly to my opinion, skdump (libatasmart-utils package) is better but still confusing to me.

Hi everybody, sorry for the late replay, my internet was off.
@mrmazda I’ve tried booting using the previous version of the kernel but no luck with that.
Now that I have the internet, I will try to reinstall the packages you mentioned.
For @marel, I’ve already checked the SMART infos and it says is healthy.
Obviously this doesn’t mean there are no errors at all, but I would exclude this, even because the disk is a brand new SSD.
Anyway I will take it in count and it will be part of my tests if other things will not be profitable.
In the meantime, thank you all.

1 Like

I don’t know if it is something related with this, but after an update where it is supposed to have installed two packages, one is a intel-ucode and the other is xrdb, everything is back to normality.
At the boot infact there is no any message and the startup time is much shorter.
So, finally anything solved automatically.
Thank you again, anyway, for your prompt answers.