ZSNES install error: tools/strutil.h:34:96: error: ‘strncasecmp’ was not declared in this scope

I am a brand new Linux user and, after a quick stint with Ubuntu/gnome, decided to go for openSUSE and the KDE desktop. Strugling with a few things here and would like to see if I can get some help.

1 - Decided to install a SNES emulator, my favorite is ZSNES. tried SNES9x. It works but it is buggy. ZSNES was solid on Ubuntu.
2 - Downloaded ZSNES_1_51 and followed the installation instructions. Found that I did not have NASM and other packages.Fixed those issues. (proud of myself)
3 - Finally was able to MAKE and everything looked pretty good there for 3/4 of a second until i got the following message:

*** tools/strutil.h:34:96: error: ‘strncasecmp’ was not declared in this scope
make: *** [tools/strutil.o] Error 1 >>>

Can anybody help me with this? Again, being the newb that I am I kindly request that you take it easy. I’ve been doing my homework but this takes time! :wink:

uname yields: Linux linux-05x1.site 3.1.9-1.4-default #1 SMP Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux (openSUSE 12.1

Why don’t You try this package ?

It’s from one of our users repository but it might just be working :slight_smile: If not it should be easy enough to uninstall using YaST or zypper. Definitely much easier than compiling from source.

Best regards,

It’s in the Emulators repository, maintained by Ulrich Hecht, from Suse.
If your computer is fast enough you may want to try bsnes.

Yes, the package worked perfectly! Thanks a lot!

Not very fast.ZNES is actually working now but I would like to try BSNES. How do I browse through these repositories? Is there a web interface?

Yes. Try this link.
software.opensuse.org: Download openSUSE 12.1

You have to click on the wrench icon (right to search) and then select show unsupported packages if You want to browse user build service directories.

There is also emulators repo :
Index of /repositories/Emulators/openSUSE_12.1

Simply add this and install bsnes with YaST or zypper.

Best regards,