Zoom USB external modem install failure


OpenSUSE 11.1; kernel

Tried to configure via:
Zoom CD driver: 1.06_k2.6.22.17_01_default-1suse.i586.rpm
linuxant driver: dgcmodem-1.13_k2.6.31.5_0.1_pae-1suse.i586.rpm

Used Yast2 & ,also, command line rpm i …, in su mode

Doesn’t create /dev/ttyACM0 nor any /dev/ttyx

Output of dgcconfig

SuSe:~ # dgcconfig
Conexant DGC USB modem driver, version 1.06

If you need assistance or more information, please go to:
Linuxant - Company information

When reporting a problem for the first time, please send
us the file generated by “dgcconfig --dumpdiag”.

No pre-built modules for: SuSE-11.2 linux- i686-SMP

Please obtain the appropriate variant of this package for your system
or try the generic RPM or tar version.

I did try generic with same result.

Lsusb output:

SuSe:~ # lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0803:3095 Zoom Telephonics, Inc.
Bus 001 Device 003: ID 046d:c045 Logitech, Inc. Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0ecd:a100 Lite-On IT Corp. LDW-411SX DVD/CD Rewritable Drive

dmesg output segments for tty; usb; ACM:

0.000106] console [tty0] enabled  
1.029960] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A        
1.030531] 00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A     

11.668226] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

2.848094] usb 1-1: new full speed USB device using ohci_hcd and address 2   
3.537194] usb 1-1: New USB device found, idVendor=0803, idProduct=3095 
3.537204] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3  
3.537208] usb 1-1: Product: USB Modem        
3.537211] usb 1-1: Manufacturer: Conexant    
3.537214] usb 1-1: SerialNumber: 24680246    
3.537452] usb 1-1: configuration #1 chosen from 2 choices        

11.676616] usbcore: registered new interface driver cdc_acm

11.676622] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters

What do I do to properly install modem.


My apologies
The OS is SuSE-11.2 linux- i686-SMP

Upgraded to SuSe 11.3

Didn’t load any USB modem driver

wvdial and Kinternet/KDE3 now dial and connect

Neither Firefox nor Konquerer connect to Internet

Same happens whether wireless router is on or off

Any ideas how to resolve browser connect issue?


Is Network Manager enabled concurrently? That can prevent a DNS being available when dialling out.

cat /etc/resolv.conf

We may as check the route table (for gateway) as well

/sbin/route -n/CODE

Hi deano_ferrari,

Below are the results from commands I ran from su, and from kInternet log. I connected with dialup with an DNS error message. Network manager process was killed. I connected via dialup with network manager running but with wlan0 disabled, but browser wouldn’t connect to Internet.

I will try loading a dgcmodem driver.

What do the ? mean in wvdial output?

Thanks for your help.

These commands are with networkmanager running.

stargazer@SuSe:~> su -
SuSe:~ # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:




or disable DNS configuration updates via netconfig by setting:


See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!


SuSe:~ # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 2 0 0 wlan0 U 0 0 0 lo UG 0 0 0 wlan0

SuSe:~ # wvdial
→ WvDial: Internet dialer version 1.60
→ Cannot get information for serial port.
→ Initializing modem.
→ Sending: ATZ
→ Sending: ATQ0 V1 E1 S0=0 &C1 &D2
ATQ0 V1 E1 S0=0 &C1 &D2
→ Modem initialized.
→ Idle Seconds = 300, disabling automatic reconnect.
→ Sending: ATDT14849407660
→ Waiting for carrier.
→ Carrier detected. Starting PPP immediately.
→ Starting pppd at Wed Jul 28 19:57:21 2010
→ Pid of pppd: 6820
→ Using interface ppp0
→ pppd: п��@�[06][08]��[06][08]
→ pppd: п��@�[06][08]��[06][08]
→ pppd: п��@�[06][08]��[06][08]
→ local IP address
→ pppd: п��@�[06][08]��[06][08]
→ remote IP address
→ pppd: п��@�[06][08]��[06][08]
→ primary DNS address
→ pppd: п��@�[06][08]��[06][08]
→ secondary DNS address
→ pppd: п��@�[06][08]��[06][08]
→ Script /etc/ppp/ip-up run successful
→ Default route Ok.
→ warning, no nameserver found /etc/resolv.conf
→ Nameserver (DNS) failure, the connection may not work.
→ Connected… Press Ctrl-C to disconnect
→ pppd: п��@�[06][08]��[06][08]

Networkmanager process killed.

SuSe:~ # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UH 0 0 0 ppp0 U 0 0 0 lo U 0 0 0 ppp0

I restarted networkmanager, and issued wvdial from su

pppd[0]: → WvDial: Internet dialer version 1.60
pppd[0]: → Initializing modem.
pppd[0]: → Sending: ATM1
pppd[0]: ATM1
pppd[0]: OK
pppd[0]: → Modem initialized.
pppd[0]: → Sending: ATDT4849407660
pppd[0]: → Waiting for carrier.
pppd[0]: ATDT4849407660
pppd[0]: CONNECT 57600
pppd[0]: → Carrier detected. Waiting for prompt.
pppd[0]: ** O1 Communications TermServ **
pppd[0]: Login:
pppd[0]: → Looks like a login prompt.
pppd[0]: → Sending: free
pppd[0]: free
pppd[0]: Password:
pppd[0]: → Looks like a password prompt.
pppd[0]: → Sending: (password)
pppd[0]: Entering PPP Session.
pppd[0]: IP address is
pppd[0]: MTU is 1524.
pppd[0]: → Looks like a welcome message.
pppd[0]: Script /usr/bin/wvdial --chat --no-syslog --config /var/run/smpppd/chat-modem0.conf smpppd finished (pid 9696), status = 0x0
pppd[0]: Serial connection established.
pppd[0]: Renamed interface ppp0 to modem0
pppd[0]: Using interface modem0
Status is: connecting
pppd[0]: Connect: modem0 <–> /dev/ttyACM0
pppd[0]: local IP address
pppd[0]: remote IP address
pppd[0]: primary DNS address
pppd[0]: secondary DNS address
pppd[0]: Script /etc/ppp/ip-up finished (pid 9698), status = 0x0
Status is: connected

I tried to get browser to connect to Internet - no go.

If I undertsnad your results correctly, wvdial works ok as root. Ok, maybe you need to add yourself to the ‘dialout’ group first via YaST > Security and Users…

Also, what does this return (when device plugged in)?

ls -l /dev/ttyACM*

You’re close…

BTW, when dialled out, then /etc/resolv.conf should have the namservers reported by wvdial

pppd[0]: primary DNS address
pppd[0]: secondary DNS address

If you don’t, that is definitely the problem. Network Manager should NOT be running (and should be disabled in YaST > Network Devices), otherwise the dialler won’t be able to add the nameservers to /etc/resolv.conf).

A similar issue here.

Hi deano_ferrari,

I am replying to your thread via dial up, thanks to your help.

Disabling network manager from YaST>Network Devices>Network Settings was the solution. What I did was to select ifup option from the General Tab. Previously, I only disable NM from the task bar NM icon.

Summary for others reading this thread:

SuSe 11.3 loads its own driver for USB modems. You do not need to install any dcgmodem rpm. I use Kinternet to make a connection after I use the ifup option as per above to stop Network Manager.

SuSE team should consider code to have SuSe to auto transfer browser to dialup if wired and wireless ethernet are not enable via NM at the task bar icon.

I am embarrassed that I didn’t think to stop NM through YaST.

I, only, need to use dial up when I am in upper Maine.

Thanks for your help.


Glad to read its sorted!