Zoom Conferencing - Blank GUI

I use the Zoom Video Conferencing client (zoom.us) for business and recently it stopped working. It happened after I wiped my system and did a fresh openSUSE Tumbleweed (64-bit) installation. Everything on my system is working great, but now Zoom is having problems. It installs normally, but when I launch the client, I get the following window:

It’s just a blank box with no visible options. I can click in the areas where the options would have been and things seem to work, but I can’t see anything. This persists with any subsequent windows that open within Zoom. Even if I click a direct link to a meeting, the client launches as it should, but I get the same blank windows.

I’ve been running openSUSE Tumbleweed with Gnome for a long time and Zoom has worked great. Something changed when I did this recent wipe/reinstall. I’ve been working with Zoom support to see if they can solve it, but when they try to reproduce the issue on an openSUSE VM, everything works fine for them. They sent me a screenshot of it running normally on a current Gnome desktop in Tumbleweed. I’ve followed all of their recommendations, but nothing fixes the problem. I think the Zoom client is fine. Something is wrong with my openSUSE system. My OS is fully upgraded, running the latest packages from the standard repositories. How can I track down this issue?

as it is a video conferencing app maybe it’s missing some patented codecs did you add and do a full vendor change to the packman repo, what’s your repo list

zypper lr -d

maybe it’s a video card issue, what card and driver do you have?

sudo lspci | grep VGA

does that app come packaged as an rpm file is it a web app or a precompiled linux binary if it was a properly packaged rpm then zypper would have installed all the needed dependencies if it’s a binary blob try running it in a terminal and see the messages that pop up.

Here’s my repo list:
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias .............. | Name  ....................... | Enabled | GPG Check | Refresh |  Priority | Type ....| URI
1 | openSUSE-20180222-0. | openSUSE-20180222-0 ......... | No .... | --------- | ------- | 99 ...... | yast2 .. | hd:///?device=/dev/disk/by-id/usb-Lexar_JumpDrive_3633097036-0:0-part2
2 | packman ............ | packman  .................... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
3 | repo-debug ......... | openSUSE-Tumbleweed-Debug ... | No  ... | --------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/debug/tumbleweed/repo/oss/
4 | repo-non-oss ....... | openSUSE-Tumbleweed-Non-Oss . | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/non-oss/
5 | repo-oss  .......... | openSUSE-Tumbleweed-Oss ..... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/oss/
6 | repo-source  ....... | openSUSE-Tumbleweed-Source .. | No .... |  -------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/source/tumbleweed/repo/oss/
7 | repo-update ........ | openSUSE-Tumbleweed-Update .. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://download.opensuse.org/update/tumbleweed/
8 | skype-stable  ...... | skype (stable) .............. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | https://repo.skype.com/rpm/stable/

Here’s my video card and driver:

00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 6100 (rev 09)

The software comes packaged as an openSUSE RPM from the Zoom website. It makes sense that perhaps some codecs were missing since my previous Tumbleweed installation was pretty mature. I hadn’t done a fresh wipe in a few years. However, if the default openSUSE installation doesn’t have the necessary codecs, then the Zoom support guy wouldn’t have been able to get it running in his test VM. Right? The app ran fine for him.

afaik most if not all video conferencing software use patented codecs you should do a full vendor change to packman

zypper dup --from 2

Ok, that won’t cause any major issues or anything? I’m always hesitant to move away from the manufacturer’s recommended settings. I figure the defaults are defaults for a reason.

In the linux world, defaults are simply a means for which anyone can start. In other words, they’re a starting point only. It’s why linux is renowned for its customization.

Hi Grassman20!

No, but somehow I don’t think it will solve your issue, otherwise those assisting you would have had the same issue (or would have told you about this necessary step).

Did you try to run the video conferencing app under a fresh new account?


assumption is the cause of most fails
if their app uses h264 for video encoding (as a lot if not most do) it would need the packman multimedia packages
as a doing a full vendor change to packman is a must for all opensuse users who want an unrestricted system the zoom devs might have also assumed the OP did a full vendor change as he does have the packman repo
if that doesn’t work I’d suggest checking the hardware in yast, that app might need v4l packages but the OP didn’t say how he installed the rpm if he used zypper and the devs did a propper jop packaging their app all dependencies should be met (zypper might install restricted multimedia packages if they weren’t already installed as both packman and OSS have the same priority)
after doing the full vendor change to packman the issue persists the OP should start that app in a terminal and tell up the output

Sure there is:
openSUSE cannot include proprietary/restricted codecs for legal reasons.
See also https://en.opensuse.org/Restricted_formats

Packman can (and does) offer them though.
If you want (or need) to use them, you need to switch (preferably all) packages to Packman’s versions.

I just installed zoom conferencing on leap 42.3 and it’s working fine for me
on their download page they say their opensuse build is for 13.2+
I’m speculating that TW is just too new for that build you should recontact the zoom developers and ask for a newer build
TW uses a much newer version of gcc depending how they linked their app it might need a recompile (a static build should work on TW also)

they said they used TW in an virtual machine but what version of TW did they use and what version of TW do you have

cat /etc/os-release

make sure you both have the same TW build before comparing

another thing I was reading their Linux FAQ
and came across this

  - openSUSE 64-bit 

those are old gstreamer packages (packman’s build are needed) but gstreamervideo-0.10 has been abandoned for quite some time now it was available for 13.x but it’s gone for LEAP and TW this is what I have

~> zypper se libgstvideo
Loading repository data...
Reading installed packages...

S | Name                    | Type    | Version    | Arch   | Repository     
i | libgstvideo-1_0-0       | package | 1.8.3-7.16 | x86_64 | openSUSE-42.3-0
i | libgstvideo-1_0-0-32bit | package | 1.8.3-7.16 | x86_64 | openSUSE-42.3-0

as I didn’t create an account or really test the audio/video encoding I can’t be really sure if it works, if they still use the old gstreamer-0.10 they need to migrate to gstreamer-1.0 afaik no modern Linux distro uses those old libraries

I did the full vendor change by running as root:

zypper dup --from packman

It only installed 16 packages and switched another 16 to Packman. I figured it would have been much more. Anyway, after a restart I installed Zoom again by running the openSUSE RPM I downloaded from their website. The problem persists. I don’t know what’s going on, but it seems like my issue is unique. It works fine when Zoom support runs it on a fresh Tumbleweed installation, it works fine when I_A runs it on Leap, and it worked fine when I ran it on Tumbleweed prior to my system refresh. I really don’t want to nuke my system and start over, but I’m guessing that would fix the issue. I just wish I could pinpoint the problem and fix it without resorting to the scorched-earth option.

As I_A already hinted at, that software apparently needs gstreamer-0_10, which has been dropped from the distribution and also Packman (though it is still available in/for Leap 42.3).

It probably worked on your Tumbleweed system previously because you still had gstreamer-0_10 installed from before it was dropped.
Dropped packages are not removed from the system (especially if other installed packages depend on them), but you cannot install them new of course.

And I_A never said it worked on his Leap system, he wrote this:

as I didn’t create an account or really test the audio/video encoding I can’t be really sure if it works

That said, I don’t know if it really needs gstreamer-0_10 (in which case it probably wouldn’t even start I suppose), maybe that FAQ is outdated and it has been ported to 1.x.
Try to install gstreamer-plugins-bad-orig-addon, gstreamer-plugins-ugly-orig-addon, and gstreamer-plugins-libav, that should give you support for all possible codecs in gstreamer 1.x.
Also try to delete the plugin cache, ~/.cache/gstreamer-1.0/ if that doesn’t help.

I installed gstreamer-plugins-bad-orig-addon, gstreamer-plugins-ugly-orig-addon, and gstreamer-plugins-libav as you suggested. I also deleted ~/.cache/gstreamer-1.0/, logged out and back in. Still, the problem persists.

I suppose it’s possible that gstreamer-0_10 is the culprit. I assumed that the Tumbleweed instance that tech support spun up was a fresh install, but that’s not necessarily true. I don’t have time today, but tomorrow I’ll download the latest tumbleweed and fire it up in a VM to see if I can get Zoom working. It’ll be a fresh, out-of-the-box instance of Tumbleweed so if it works there, then I know something is up with my system.

This also happens on my laptop with openSUSE Tumbleweed if I start zoom as a non-privileged user. If I start the zoom client as root however (/usr/bin/zoom) it works fine. I have not yet tried to root-cause this.

Boom! I just tried running it as root and everything worked properly! Ran it again as normal user and it reverted to the old problem. Good find! Maybe now we can find the root issue. I’ll send this information to the Zoom support tech helping me.

It is probably a permissions problem then

Maybe need to be member of zoom group??? Wild guess.:wink:

No, there’s no Zoom group. Plus, if there were, the program probably wouldn’t even launch. The program launches, but the GUI is blank. Makes me think there’s a permission problem with a dependency somewhere.

You in the video group?

I wasn’t, but I added my user to the video group and restarted. No change.