zlib installation on OpenSuse 12.3 fails

Hi, I want to install Joomla 3 on OpenSuse 12.3 and the last outstanding requirement is installation of zlib.

I went to this link: software.opensuse.org: but got the following error message:

Software installation
Installation was only partially successful.
The following packages could not be installed
• zlib

This happens on more than one PC

Any assistance will be appreciated

Try as root:

zypper in zlib

That’s wrong. On 12.3 it would be:

zypper in libz1

But this should already be installed by default! (if I try to remove it, zypper wants to uninstall most of my system: 1 Paket wird aktualisiert, 7 werden zurückgestuft, 1 neu, 3838 zu entfernen, 7 Anbieterwechsel…)

Why do you think you need to install it?

That’s wrong. On 12.3 it would be:

zypper in libz1

Thanks wolfi323, my fault.

Are you sure you’re not wanting to install the zlib-devel?

zypper in zlib-devel

Thank you for all the advice!

We are lucky enough to have an Open Source Lab, I will test all suggestions and report back here. I’m not sure why Joomla 3.1 say it is not installed.

Doing the same installation on Mint however works without any problems, that is why I think zlib is not installed on Suse 12.3. Will test and let you know, my first problem was that I tried to install zlib not libz1.



Well, Joomla is written in php. So you may be missing the package “php5-zlib”…

Thank you! That was the obvious solution which I did not see!!! zlib is installed on Suse but it was still required by PHP!

Thank you very much …

zypper in php5-zlib

worked 100% !!!