Zenwalk and OpenSuse - dual boot, lost menu

I have Zenwalk installed and decided to also install OpenSuse as a dual boot. All worked fine; I’ve got 1 swap partition for both distros and 1 each of /home and root partitions.

However, when starting up now, I don’t get the option of booting in Zenwalk. OpenSuse opens automatically without bringing up a menu.
I have played around with the /boot/grub/menu.lst file without any luck.
I managed to get a menu which included the Zenwalk title but it wouldn’t boot.
I added: root (hd0, 4) & configfile /boot/grub/menu.lst to the file.

Any suggestions? Cheers!

Please open a su terminal and post the result of the following, if you know which partition is your Zen root - identify it

cat /boot/grub/menu.lst
fdisk -l


You might even be able to read your Zen menu.lst if you know your way around

I have now played around quite a lot with the menu.lst file and I’ve got to a point where a menu is displayed and where the title of my other distro is included.
However, when choosing it, nothing happens.
I have, from some on-line recommendations (there are lots of advice out there but none seems to work with my set-up), added

root (hd0,4) #the other distro’s / partition is sda5
chainloader +1

but that is obviously not enough information.

There was also suggested to add

kernel /boot/vmlinuz-
intrd /boot/initrd.splash

but that gives: “Can’t find the file…”

Suggestions, anyone?

try this

###Don’t change this comment - YaST2 identifier: Original name: zenwalk###
title Zenwalk
root (hd0,4)
configfile /boot/grub/menu.lst

When I was using Zenwalk it was using lilo instead of grub. This isn’t still the case, is it?

Zenwalk still uses lilo but I chose not to install it, hoping that the grub would “kick in” instead. (Was that correct?)

I tried ‘configfile…’ but that didn’t make any difference!

If you boot a live cd you can read the zen root partition and post here the menu.lst from there.
And if we had

fdisk -l

we can see more.

Dumb question first:
Do I need to mount that particular partition in order to be able to access its files?
I tried ‘sudo mount /dev/sda5’ but it gave me:
can’t find /dev/sda5 in /etc/fstab or /etc/mtab

Also, the output from fdisk -1:

"Disk /dev/sda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9dc96e9e

Device Boot Start End Blocks Id System
/dev/sda1 1 1912 15358108+ 5 Extended
/dev/sda2 4610 4864 2048287+ 82 Linux swap / Solaris
/dev/sda3 * 1913 2549 5116702+ 83 Linux
/dev/sda4 2550 4609 16546950 83 Linux
/dev/sda5 1 637 5116639+ 83 Linux
/dev/sda6 638 1912 10241406 83 Linux

Partition table entries are not in disk order"

You must have deleted a partition at the start of the table and created the extended we see there, sda5 and 6 are inside sda1.

Yes you need to mount partitions to read them. Either use something like Parted Magic or with a openSUSE live cd, boot and login as root: To do that, remove all boot arguments at boot of cd and just type the number: 3

at the login type: root
hit enter a couple of times
now type: startx

I think we need to establish though if this marriage of SUSE and Zenwalk has ever worked. I mean, have you at any time been able to boot either OS from your SUSE menu?

No I have never had the two working. Zenwalk worked fine on its own but as soon as I installed openSuse I lost the option of selecting distro from a menu.
I have had this problem before when trying to install suse on a drive with Ubuntu but that time I just re-installed Ubuntu’s grub and I had the options again.

At the moment (I have sort of started from scratch) I have my disk devided into 3 primary partitions and 1 extended - which in turn contains two partitions. These are named from “left to right” sda1 → sda6; the extended being sda4 and the two inside sda5 and sda6.

My plan now is to try to install opensuse in sda5 and sda6 (/ and /home respectively) but I’m sure I’ll run into trouble again…:\

You didn’t specify a mount point - if you mount something with ‘sudo mount /dev/[device]’ it mounts it where it’s been specified to automatically mount it - and no such specification exists, hence it complaining about the lack of entry in fstab.

Load your live CD, and you want

su -
mkdir /mnt/suse
mkdir /mnt/zenwalk
mount /dev/sda5 /mnt/suse
mount /dev/sda3 /mnt/zenwalk

Then you can do a ‘cat /mnt/suse/boot/grub/menu.lst’ and ‘cat /mnt/zenwalk/boot/grub/menu.lst’ to look at the boot menus. If Zenwalk did boot, and you omitted lilo, then presumably it must have grub, so it shouldn’t be too hard…

The trick in this situation, I think, is to let each distro have its own bootloader, so they aren’t fighting over the MBR, then you can chainload one from the other.