Zain Connect Stick Modem

Dear All,
I’m using OpenSuse 10.3. I have a stick modem of Zain (Sudan), I use it for the internet. I need help on how to configure OpensUSE 10.3 so I can use it for the internet.

You might get better support with a newer openSUSE version. This one is not supported any longer. There are numerous posts concerning this topic if you search. They may not concern this model, but the principles are the same. Plug your device in, then type

dmesg |tail

What is reported?

He’s most likely using one of Huawei modems. Popular, cheap, most ISPs i know offer them.

Thanks for the reply, Yes I’m using Huawei modem. What should I do to make it run in 10.3 OpenSuse ?

Well, can you tell us which model/chipset? Thats why I posted the commands…

Anyway, since we’re left to guess a bit here. I myself had an Huwei modem and had it working under suse 10.2. I had a custom udev rule designed to ‘eject /dev/sr1’ and reload ‘usebserial’ with vendor and product ID’s. I used kinternet to dial out with. It was a long time ago, so I would need to google up the details again (for a distro that old).

Anyway, see if these old threads help:

Huawei E220, Linux Driver

How To Setting Huawei E220 And Gnome-ppp How

Dear Sir,
Thanks for the reply I got the following message. I just want indicate I’m not experience user.
I got the following messgae

omer@linux-pza1:~> dmesg |tail
sd 7:0:0:0: [sdb] Write Protect is off
sd 7:0:0:0: [sdb] Mode Sense: 0f 0e 00 00
sd 7:0:0:0: [sdb] Assuming drive cache: write through
sd 7:0:0:0: [sdb] 3964928 512-byte hardware sectors (2030 MB)
sd 7:0:0:0: [sdb] Write Protect is off
sd 7:0:0:0: [sdb] Mode Sense: 0f 0e 00 00
sd 7:0:0:0: [sdb] Assuming drive cache: write through
 sdb: sdb1
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
omer@linux-pza1:~> lsusb
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 002: ID 046d:c018 Logitech, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 005: ID 12d1:1446
Bus 003 Device 001: ID 0000:0000

Thanks for the help

This line is relevant:

Bus 003 Device 005: ID 12d1:1446

I haven’t used a huawei device for a while now, but I remember some were handled correctly by the kernel driver, and all one needed to do was plug in, then configure via knetworkmanager.

Other models needed manual asistance with a utility like ‘usb-modeswitch’.

You may need to install usb-modeswitch from here:

Index of /repositories/hardware/openSUSE_11.3

It will help you activate the modem device (and disable the storage device).

There are plenty of online guides and threads which detail this chipset, so don’t be afraid to search further if you need help with configuring usb-modeswitch. Some users dial out with wvdial or kinternet, but knetworkmanager should be ok with it as well.

and that is the latest version of usb_modeswitch in the opensuse repositories at 1.1.3 so that is great; ubuntu seems to be behind with 1.0.1 or somesuch: Josh oversees usb_modeswitch and diligently updates the data sheets very regularly as users report new modems

hopefully after installation, the lsusb will show a new Product ID: it could be one of several …