yum is whacked out

How do I fix this? I am running the latest Suse 11.0, but apparently yum is broken?

I am facing a problem. I had to install Suse 10.3 on my old Asus P2B-DS motherboard, so that it would detect the old IDE drives (i have 4 hard-disks on this platform) Running Suse 11 install showed that it never detected the IDE drives.

So after getting Suse 10.3 installed, and running online update, I come up with literally hundreds of packages to update. However the Yast2 online update bogs down so much so that it becomes unusable to turn off each update patch to determine why the disk space under root more than doubled in size. I have never had to double the / (root) partition, but apparently Yast online-update is claiming that the updates will take more than 1.5 gigs in size.

Hence I installed yum, so that I can run “kyum” and see which packages need updating and see how much disk space is needed. I need to find out why Yast2 wants all that disk space (which I don’t have)

However, after installing yum (everything available under the 11.0 release) and installing kyum, I get the following error

Process 3919 (yum) has been started.
Please be patient, this may be a lengthy operation…

(Command being executed: yum -y info available).

Available Packages
*** Traceback (most recent call last):
*** File “/usr/bin/yum”, line 29, in <module>
*** yummain.user_main(sys.argv[1:], exit_code=True)
*** File “/usr/share/yum-cli/yummain.py”, line 236, in user_main
*** errcode = main(args)
*** File “/usr/share/yum-cli/yummain.py”, line 111, in main
*** result, resultmsgs = base.doCommands()
*** File “/usr/share/yum-cli/cli.py”, line 309, in doCommands
*** return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
*** File “/usr/share/yum-cli/yumcommands.py”, line 214, in doCommand
*** rap = base.listPkgs(ypl.available, (‘Available Packages’), basecmd)
*** File “/usr/share/yum-cli/output.py”, line 337, in listPkgs
*** self.infoOutput(pkg)
*** File “/usr/share/yum-cli/output.py”, line 308, in infoOutput
*** print self.fmtKeyValFill(
("Description: "), enc(pkg.description))
*** File “/usr/share/yum-cli/output.py”, line 256, in fmtKeyValFill
*** val = str(val)
*** UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xc7’ in position 627: ordinal not in range(128)
Process exited normally with code 1.

Why is this happening? I thought unicode characters were accounted for, under the install python script?

Can someone enlighten me as to how to get yum working? Yast2 is way way way too slow and bogs down, when running online update.

I really need to add the patches to Suse 10.3, that’s the whole intention here.

Thanks for all your comments, insights, tidbits of helpful information, articles, etc.

  • Randall

Hmm, never tried to use yum on OpenSUSE, but have you tried zypper?

zypper is working fine, I used it to fix Yast2 when I accidentally broke it while trying to get yum and yumex and kyum to work. I actually enjoyed working with zypper, as it is a nicely written CLI command, yet very powerful.