Youtube videos don't play on Chromium + HTML5


I came back to openSUSE this year to see what’s new on 13.1, and I like it very much! :wink: Only problem is that I can’t see Youtube videos with Chromium
I can see every video I want with HTML5 on other distros, but on openSUSE none play, and the message “This video is currently unavailable” is displayed (see picture bellow).

Any idea why? Maybe some firewall/apparmor rule?
Note that I don’t have Flash Player installed, and the problem existed even when it was installed.
I also installed the 1-Click codecs for KDE.



Nevermind, I just realized it’s not the issue here.

Maybe some codecs are missing, I just switch multimedia packages to packman repo and it’s working fine.
That is, youtube videos which have no flash ads work fine, ones that do have flash ads need a workaround.
Google wants you to have flash player, and will remind you to install one because otherwise you won’t see the ads.

In chrome, you’ve got integrated flash player, in firefox, there’s a simple workaround.
I just replace watch?v= in url with /embed/ which then redirects to google video service and somehow forces HTML5.
By doing this, I have avoided the plugin completely, haven’t used it since adobe 64bit linux development was dropped, years ago.

No problem;)

BTW, you haven’t been through this too, have you?

No Ama,
I was just thinking that it might have been the lack of chromium-ffmpeg package (from Packman) but then again HTML5 should work without it.

I have the same problem with chromium but the video plays fine in Konqueror - so it is clearly an openSUSE chromium problem. At present, the openSUSE version of chromium is somewhat behind the latest release; so that may be the cause of the problem.

Well, it depends on the codec of course.
Especially for HTML5 with codecs like MP4 or H.264 you do need the chromium-ffmpeg package, fitting to the chromium package version.

See also this bugreport:

It works fine for me, just tried it. Can you post an url of the video that fails to run?

Thanks for the link, had a quick look at it so… It’s intended.
It works fine with packman chromium-ffmpeg but fails with chromium-ffmpegsumo from update repo.


It had the “chromium-ffmpegsumo” package, so I wasn’t sure if uninstalling it and then installing ‘chromium-ffmpeg’ would solve.

Best regards.

Just checked and I was seeing exactly the same thing in Chromium 32.xx
The difference is that I have flash installed so it would then automatically switch to the flash player.

Chromium 33.xx is now in packman. I just updated to this and switched to chromium-ffmpeg (removed the sumo version) and now html 5 player works fine in Chromium

So not sure if it is the update to Chromium 33 or switching the ffmpeg codec pack that fixed it.

sorry, Chromium 33.xx isn’t in packman - it’s in OSS Updates. Chromium-ffmpeg is in packman however.

chromium-ffmpegsumo is the openSUSE package that doesn’t support non-free codecs.
From the package’s description:

The is the multimedia codec library for Chromium. It is based on the internal ffmpeg source code and contains only the open source codecs from ffmpeg. Proprietary codecs (e.g. H.264) are not part of this library, but are provided in an external package

For full codec support you need chromium-ffmpeg from Packman.

I think I have the answer; I don’t have chromium-ffmpeg installed - presumably Konqueror relies on a different codec.

Of course. chromium-ffmpeg is only used by chromium, obviously.

Konqueror (at least the KHTML backend) most likely uses Phonon (KDE’s multimedia framework), so it would depend on your Phonon backend (either gstreamer-0_10 or vlc) and whether you installed the codecs for that.
But I’m not sure about the WebKit backend. This seems to use gstreamer-0_10 directly, according to the package’s dependencies.

For example, this is one of the video clips that don’t run without installing chromium-ffmpeg from Packman repository: - Wynter Gordon - Dirty Talk (Official Video)


that video is encoded in h264 so of course you will need chromium-ffmpeg to view in the chromium browser.