Youtube playback issue

There are some youtube videos I can’t play, loading takes forever. Tried on chromium and firefox with the same result. Any ideas?

Unfortunately, you haven’t given us enough information to reply with anything other than speculation. Have you got any links to the ‘problematic’ videos you can share?

from experience chrome has less issues than chromium

I noticed that with chromium esp. newly created or very long videos are not played. It seems they need to be converted by Youtube to a format chromium understands, and their queue needs some time to get all converted. Am I right?

Are we talking videos you upload yourself?
Yes, youtube does convert videos, that’s right.

sounds like a google issue to me
google has servers in a lot of countries and most of us get different IP’s and speed/content from youtube in theory all youtube servers should be synced but syncing terabytes of data takes time and different google servers have different speed capacities and the server you use might be overloaded
it could be a vp9 decoding issue (google defaults webm with vp9 (vp8 for older videos) under linux) you can force google to give you mp4 (h264+aac) video by disabling webm or with the h264ify addon (you need the restricted codecs from packman for this to work)
for Chromium based browsers
for Firefox
the thing is in the past Firefox used gstreamer for mp4 decoding and gstreamer used hardware acceleration (vdpau or vaapi) where available, not Firefox uses the system ffmpeg (just like Chromium) and I’m not sure if ffmpeg uses hardware acceleration if it does h264 video will be decoded by the graphic card

according to this wiki

The software decoder starts normally, but if it detects a stream which is decodable in hardware then it will attempt to delegate all significant processing to that hardware.

if your graphic card has h264 support (most 10 year old do) Firefox/Chromium should use hardware acceleration for mp4 videos, that might be your issue if you are viewing 1080p vp9 encoded video’s there might be a cpu bottle neck issue

Not only. For example very long gaming stream videos (>4h) need several weeks for conversion. Example:
is not playable for me right now. It may be in two weeks.

this sounds like a google issue as I said google has local servers and they might not be in-sync
the above video is available for me and I’m not in “the west”
you could try and edit /etc/hosts so you can use a different youtube server I tested and it seams to work with your link
after the line localhost
your /etc/hosts file should read something like

# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#    localhost

again this is a google service issue there is nothing anyone outside of google can do about it, it should get fixed but … as google uses static IP’s the above should not be a problem but I don’t reccomend using static IP’s in your host file as still youtube’s address might change