YouTube Full Screen Stopped working after ati driver install

In an effort to improve awful video performance (e.g. in maximized You Tube or simply scrolling the browser) of my new Suse 11.3 install on my new HP workstation with ATI Radeon HD 5770, I added the repository http://www2.ati.com/suse/11.3
and installed “ATI “fglrx” driver kernel module for ATI Radeon HD 2000 and later.”

But now if I try to go full screen in YouTube, the browser screen gets maximized for an instant but then reverts to its original size with the original video window greyed out.

This occurs in both Firefox and Chrome.

After the Firefox failure, I following line appears in dmesg:
npviewer.bin[15775]: segfault at 4 ip 00000000eec9e8d8 sp 00000000ffaf4110 error 4 in libGL.so.1.2[eec32000+b3000]

If I run Chrome from the command line, after failure I see the following in the terminal:
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() wait for reply: Connection reset by peer
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2394):invoke_NPP_Write: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2239):invoke_NPP_DestroyStream: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:2123):invoke_NPP_URLNotify: assertion failed: (rpc_method_invoke_possible(plugin->connection))
*** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!
*** NSPlugin Wrapper *** ERROR: NPObject 0x2f85200 is no longer valid!

etc.

I have all the latest Suse updates installed.
Does anyone have a solution?
Thanks.

Please confirm that you can run this in a terminal:

glxgears

And post result of:

/usr/sbin/hwinfo --gfxcard | grep Driver

HPE-270f:~ # glxgears
Segmentation fault

HPE-270f:~ # /usr/sbin/hwinfo --gfxcard | grep Driver
Driver Info #0:
Driver Info #1:

Also: dmesg:

[180747.537683] glxgears[17835]: segfault at 4 ip 00007ffc053b18be sp 00007fff09d1b120 error 4 in libGL.so.1.2[7ffc05357000+ad000]

Thanks.

I had problems like this only it was with a Radeon X300. I eventually gave up on installing the proprietary drivers. However, based on your output of hwinfo, you are apparently not running a driver. The top post of this thread might help. It certainly helped when I had issues like this:
How to downgrade from 11.2 to 11.1

More Info:
After my driver installation adventure (on Sunday) I noticed that the number of selections on my boot menu had doubled from two to four.

Now I see:
openSUSE 11.3-2.6.34-12 (default)
Failsafe – openSUSE 11.3-2.6.34-12 (default)
Desktop – openSUSE 11.3-2.6.34-12
Failsafe – openSUSE 11.3-2.6.34-12 (desktop)

The first and third choices boot to a command prompt with no KDE.
The second and forth choices (the Failsafes) bring up fully functioning KDE.
The default selection is #3, which I suppose I was using before I started tinkering.

Strange.

That’s bizarre that the failsafes work but the others don’t. Try manually selecting a run-level of 5 with the regular kernels (just type “5” (without the quotes) into the command line at boot).

There are several flavors of the kernel. Normally desktop is the default kernel there is also one called default. It is confusing because default is not normally the default kernel for desktop operations and is optimized for servers. Desktop is optimized for desktops. You have managed to install both. That is the reason for the extra selections. There is no real problem other then operator confusion of having multiple kernels. It may cause problems in that different flavors have different source packages which are needed by the proprietary driver to dock itself to the kernel. It is probably best as a beginner to get rid of one of the kernels to reduce confusion.

That failsafe works is NOT unusual, it one of the reasons it’s there in the first place.
I suggest you look at Lee’s graphics thread:
openSUSE Graphic Card Practical Theory Guide for Users

Thanks all.

In YaST2 I see that I have the following installed:
xorg-x11-driver-video-radeonhd
ati-fglrxG02-kmp-default
ati-fglrxG02-kmp-desktop
x11-video-fglrxG02

Could they be conflicting? Should some of these be removed?
How can it appear that I no driver running when I have all of these installed?
(Assuming “no driver running” is the correct interpretation of the following):

HPE-270f:~ # /usr/sbin/hwinfo --gfxcard | grep Driver
Driver Info #0:
Driver Info #1:

Leaving out the “grep Driver” I see:
HPE-270f:~ # /usr/sbin/hwinfo --gfxcard
34: PCI 700.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: aK5u.jG2WizdxKP9
Parent ID: 3hqH.nd5a2INC039
SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:07:00.0
SysFS BusID: 0000:07:00.0
Hardware Class: graphics card
Model: “ATI 0x68B8”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x68b8 “0x68B8”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x6880
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xfbec0000-0xfbedffff (rw,non-prefetchable)
I/O Ports: 0xe000-0xefff (rw)
Memory Range: 0xfbea0000-0xfbebffff (ro,non-prefetchable,disabled)
IRQ: 15 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d000068B8sv0000103Csd00006880bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: fglrx
Driver Info #1:
XFree86 v4 Server Module: fglrx
3D Support: yes
Extensions: dri
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

Primary display adapter: #34

You have:
ati-fglrxG02-kmp-default
ati-fglrxG02-kmp-desktop

because you have both those kernels installed. Why you have both I don’t know. You only need one really. It can be fun trying to remove one of them though. I would stick with kernel-desktop
So you will also need to remove
ati-fglrxG02-kmp-default

I’m an nvidia person myself though

The reason I have both is because that’s what I have ended up with after posting the same question on numerous boards trying to figure out (unsuccessfully) from among the wildly differing opinions, how to get 11.3 to work with the ATI Radeon HD 5770 video card.

I’m using a mass-market, late-model computer and (started with) a fresh installation of SuSE 11.3 yet I have have not been able to get the definitive word on how to get the well-known video card to work. It seems like there ought to be some sort of deterministic sequence of steps to get from point A (fresh 11.3 install) to point B on this, but maybe not.

I’ve been told everything from “it’s not possible” to “delete your xorg.conf” to install this/install that, etc. Now I’ve been told on this very thread that I have no driver running at all, even though I can see that I installed one through Yast2. But this thread seems to be petering out before the gap between driver installation and actually causing it to be running could be bridged.

I’ll try posting the question again in a few weeks.

Thanks.

Did you read here: openSUSE Graphic Card Practical Theory Guide for Users

From this point:
For all openSUSE versions (including 11.3) there is “Xorg -configure”. ie run with root permissions in run level 3”

Of course you could get the driver manually, here: Graphics Drivers & Software

And install. You need to remove the other and then the ati repo first.

Instructions are available to download. I did walk someone thru once before. Using the downloaded installer (not one converted to .rpm)
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_cat107-inst.pdf

I went to _64, but I wasn’t sure if you were _64
Here is the link for _64
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-10-7-x86.x86_64.run