Youtub-dlg won't store files

I’m using **youtube-dl-gui, **the graphical interface for youtube-dl, but I can’t get it to store any files. I actually had this working very recently, but something has changed and I don’t know what. The problem is definitely with the interface since I can call youtube-dl directly and it behaves just as expected.

I first entered the URL in the upper box and then clicked Add. The file type doesn’t seem to matter; I’ve tried default and several others. The folder choice doesn’t matter either. The UFL then shows up in the Download list and is indicated as 0% and Queued. I then click the Cloud and get a message “Download Completed” almost instantly. The status shows up as Finished – but nothing gets stored. I verified this with a search for the title as well as looking in the plausible places.

How can I diagnose this?

Never using the GUI, but a good way to see what’s going wrong is to start it from a terminal window, then look at the output.

I took Knurpht’s helpful suggestion and immediately saw a likely cause: a version mismatch. The shell window revealed this:

/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")

But not knowing anything about Python’s exotica, how can I use this information?

Meanwhile, I’ll try creating another thread on the subject of “Python release number mismatches”.

Python2 is dead. You’d have to wait until the devs have ported the gui app to python3. Which IMHO they should have a long time ago.

Agreed…they need to be leaned on.

Try using tartube instead
https://pypi.org/project/tartube/

I usually just use Video DownloadHelper (firefox extension), but for the purposes of testing, I did quickly download and install this GUI (as I already had youtube-dl installed). It seems to work ok, but I’ll leave for you to investigate further.

I cannot download anything using youtube-dl that comes with Leap 15.1 (it fails to detect video format). Upstream youtube-dl works. Where does your youtube-dl come from and in which directory it is installed (what is full path to youtube-dl command)?

I then click the Cloud and get a message “Download Completed” almost instantly. The status shows up as Finished – but nothing gets stored.

One reason could be that youtube-dl-gui does not find youtube-dl command.

This is red herring. It works just fine with this warning.

Python2 is official part of Leap 15.1. You do not help users by proclaiming commonplace facts based on random keywords you happened to notice. You help by understanding the problem, finding the cause and suggesting workaround. Your statement does neither.

Guess what? It works just fine using python2 on Leap 15.1. It does not work with youtube-dl version shipped with Leap 15.1 (at least for URL I tested) but that has absolutely nothing to do with Python 2 vs. Python 3.

Hi
From a maintenance perspective sure, but the Leap 15.1 version is python3 only…

youtube-dl-gui is python2…

Hi
I do note there is a python-youtube-dl module (python2/3)…

Anyway, there is an old issue (2018) about getting youtube-dl-gui to python3: https://github.com/MrS0m30n3/youtube-dl-gui/issues/344

I installed **youtube-dl **and youtube-dl-dlg by getting them in the obvious way – using the default repositories. So what’s the right way to install those programs so that they work?

So what, then, should I do to ensure that when I call **youtube-dl-dlg **I get the correct python2 version? Do I need to change something in Yast’s repository list (including the priorities)?

I first encountered the problem when I tried to use youtube-dl-gui and it failed to do the job but did not complain. So what can we tell the next person who encounters this problem what to do? For someone who just wants to use the program, the issues regarding versions (python2 versus python3, standard Leap 15.1 repositories versus other repositories) can be daunting.

You say youtube-dl works for you. Please provide couple of URLs that work with youtube-dl and do not work with youtube-dl-gui. As I said before, none of URLs I tested worked with youtube-dl included in Leap 15.1, but youtube-dl-gui for Leap 15.1 worked with upstream youtube-dl installed as local Python 2 application with “pip2 install --user”.

youtube-dl and youtube-dl-gui are now working for me. The key was adding additional repositories and updating with youtube-dl -U. Thanks to all the people here who helped me. Of course, having been in the computer game for a long time, I realize that system changes sometimes cause things that were working to stop working. (I’m posting from a different computer so I don’t remember just which repositories I added.)

Less seasoned users do what is recommended and they have by default what you are hunting for:

karl@erlangen:~> youtube-dl -U
youtube-dl is up-to-date (2020.06.06)
karl@erlangen:~> 

:wink: