Yet Another Wine Thread

I have installed 12.3 as a clean install and then installed Wine. I have tried various fixes from searching forums but none have worked. Wine itself runs and I can run programs with it. I get no sound however. How do I diagnose and fix my lack of sound? Thanks.

Try this out.Let me google that for you

Thank you for your thoughtful suggestion of using Google. Somehow that never occurred to me but then my mind isn’t as supple as your juvenile one.

I have run through the steps suggested at WineHQ. I have tried various remedies such as editing the registry inside Wine to delete/change/add the HKEY_CURRENT_USER\Software\Wine\Drivers entry, installing the i586 version instead of x86_64, installing various codecs, deleting my .wine directory and re-installing, installing from the terminal to see if there were any error messages, disabling pulseaudio, etc. I even made an attempt to compile from source which I may return to if no solution can be found for the official binaries.

My current situation is that I have deleted my .wine directory and re-installed the x86_64 version of wine. I am at a loss as to what to try next.

That site is a bit snarky, I did not mean any disrespect. I did not know if you knew about windhq and that seemed the easiest thing. :X
If it helps I finally went with VirtualBox and installed MS Windows as guest, works good.

Just to progress this/clarify a bit more. When you launch ‘winecfg’ from a terminal, and navigate to Audio > ‘Test Sound’, do you hear any sound? Make sure you check your alsa sound levels first. For example, I’m using KDE, so KDE mixer levels need to be checked (eg PCM level). If you’re using PulseAudio, this may also come into play.

I can hear some kind of clicking noise. My options for output device are: (System Default), Out:default, HDA Intel PCH - STA92xx Analog… along with some HDA Intel HDMI outputs. I have tried them all, even the HDMI. They all produce the same sound.

alsamixer shows my master volume at 100 and my card as PulseAudio. Interestingly KMix will not run. I do have sound for everything other than wine though.

I re-installed OpenSuse and have managed to get the sound working. I really am not sure of what the difference in this time and last is but I did wait to install the native ATI drivers until after I had wine working with sound. Other than that I’m not sure what was wrong on my first install.