Yet another sound problem...

Hi, I installed suse 11.1 yesterday and already spent a lot of time trying to fix an audio problem I have… I thought i didn’t have sound at all and started looking for solutions, did a lot of things, updating firmware, installing new version of alsa driver, etc…
Then i realized i had sound only with headphones and looked for a similar problem, nothing solved it, tried this page also: SDB:Intel-HDA sound problems - openSUSE
and did some experiments.
For example i modified /etc/modprobe.d/sound from

options snd-hda-intel enable=1 index=0
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


options snd-hda-intel model=6stack enable=1 index=0
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

This way I had sound on the speakers but when i plug the headphones the sound continues on the speakers…

I also tried adding the line

options snd-hda-intel model=z71v position_fix=1

But then again sound only with headphones.

After that I tried to reconfigure again the sound card but to no use…

Well, here is the other information that can be relevant for solving this issue:

su -c ‘/usr/sbin/’

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-qouu #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

5Dex.Pn_QgE8qwwD:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

Ah, my laptop is a packard bell BV…

Thanks a lot!
Best Regards!

Well done in your efforts so far. The script reports that your PC has an ALC272. I looked in the HD-Audio-Models.txt file and found no entry for an ALC272.

I then did a search on the ALSA web site for an ALC272, and obtained this “hit” : Search results for ALC272 - AlsaProject

That site suggests the ALC272 is very close to an ALC663. In the HD-Audio-Models.txt file, there are the following options for an ALC663:

  3stack-dig	3-stack (2-channel) with SPDIF
  3stack-6ch	 3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig	 6-stack with SPDIF
  lenovo-101e	 Lenovo laptop
  eeepc-p701	ASUS Eeepc P701
  eeepc-ep20	ASUS Eeepc EP20
  ecs		ECS/Foxconn mobo
  m51va		ASUS M51VA
  g71v		ASUS G71V
  h13		ASUS H13
  g50v		ASUS G50V
  asus-mode1	ASUS
  asus-mode2	ASUS
  asus-mode3	ASUS
  asus-mode4	ASUS
  asus-mode5	ASUS
  asus-mode6	ASUS
  auto		auto-config reading BIOS (default)

So what you could do is try those, one at a time, to see if one of them help wrt your speaker and headphone sound.

Rather than restart after each model change, you could restart your alsa sound driver with: su -c ‘rcalsasound restart’ and enter root password when prompted and restart your mixer, and then test.

Whether or not you get this to work, I think you should raise a bug report on openSUSE your failure/success, as there is no mention of a special model requirement for an ALC272. Submitting Bug Reports - openSUSE

Good luck.

Thanks for the reply. Trying other models helped, the first one to work was ‘m51va’, but then i decided also to try the microphone and it didn’t work… tried some other models and the best was ‘asus-mode4’, even though the sound captured is too low, no matter the settings for the microphone…

I will open the bug report later then…

Thanks again!

Good luck with the bug report. Note the openSUSE alsa dev may ask for more information to help with their investigation. Some information you may expect to be asked:

Sending a Bug Report
If any model or module options don't work for your device, it's time
to send a bug report to the developers.  Give the following in your
bug report:

- Hardware vendor, product and model names
- Kernel version (and ALSA-driver version if you built externally)
- `` output; run with `--no-upload` option.  See the
  section below about alsa-info

If it's a regression, at best, send alsa-info outputs of both working
and non-working kernels.  This is really helpful because we can
compare the codec registers directly.

Send a bug report either the followings:

alsa-devel ML::

I suggested rather raising the bug report on openSUSE, but I don’t know if it makes much of a difference. By raising it on openSUSE, it will still be sent upstream, but one has a better chance (I think) of seeing a local fix in openSUSE first, prior to it appearing upstream. Both approaches will benefit Linux as a whole (contrary to Ubuntu where fixes in Ubuntu often do NOT end upstream, as Ubuntu dev’s often don’t pass them upstream).

The script `` is a very useful tool to gather the audio
device information.  You can fetch the latest version from:


Run this script as root, and it will gather the important information
such as the module lists, module parameters, proc file contents
including the codec proc files, mixer outputs and the control
elements.  As default, it will store the information onto a web server
on  But, if you send a bug report, it'd be better to
run with `--no-upload` option, and attach the generated file.

There are some other useful options.  See `--help` option output for