Yet another problem - RAID0

Hello community,

I just managed to install OpenSuse flawlessly and I can even boot into it and use it without any issues.

My problem is the following (I will try to explain it the best I can)

I have 3HD
2HD in RAID0 → BIOS RAID (fakeraid Intel) with Windows7
1SSD → OpenSuse

I installed OpenSuse in the SSD and I said that I didnt want OpenSuse to NOT manage the RAID during installation (was this a mistake?)

What happens is the:

If I choose the Bios the boot priority to SSD, I get Grub menu only with OpenSuse
If I choose the Bios the boot priority to RAID0 I get Windows bootloard only with Windows7 ← I tried add the entry with easyBCD but nothing happens

Another “annoying” thing, is that if I boot from OpenSuse and I do a “restart” (without poweroff) I get the information that the RAID is NON-BOOTABLE and if I switch off the power and start again, everything goes smoothly!

I tried several tips with mdadm and dmraid but I can’t mount the RAID in OpenSuse and I think this is what causes the issue I don’t have here the correct output of the command but one says that it detects only one disc in the RAID

Is possible to have DUAL-BOOT with Windows in RAID0 and Opensuse in the SSD ???

thank you in advance


Hello and welcome here.

Can you please tell which version of openSUSE you are using?


sorry for the missing information
OpenSuse 12.3 so I believe the last version

Hi again

I just wanted to say that I installed Ubuntu and I managed to boot from Ubuntu(Grub) with the option Windows present.

I don’t really like Ubuntu and I wanted to use a RedHat based distro, but both Fedora and OpenSuse didn’t manage to install Grub and make me choose what OS I want to boot from!

I believe that if it works in Ubuntu it should work in other Linux distros no?

I tried a lot of tutorials and suggestions but if you can tell me what I need to do I would appreciate!

Thank you

There is a problem with installing with an existing RAID setup.

It maybe a kernel problem. Since RH and openSUSE both seem to have the problem.