Yet another Dual Boot problem thread...

So I know where the issue lies, I just don’t know how to fix it.

I have been attempting to clean install window$ 7 (ultimate) off of an upgrade cd, with no success due to activation issues. During these multiple install every time I notice there is a 100MB partition, that windows calls a recovery partition, could also be a mbr. I finally got a vista cd, and did the upgrade that way and activated it, everything was okay, unfortunately, this time, there was no 100MB partition. Didn’t notice this at first, and I know this is poor computing, sorry friends…

went to install 11.3, and it went fine, until I rebooted, and it goes directly into winblow$. I can assume its because there is no mbr at the beginning of the HDD. I really really don’t want to go through the process of wiping the hard drive and starting over, as I’m sure the vista/7upgrade would probably not give me the 100mb partition again. I have done this several times on this computer and it worked fine until I introduced the vista cd into the equation.

Is there a fix without wipping everything, and starting yet again?

Thanks in advance to all… you guys are always a huge help…


Yast2 -> system -> bootloader -> BootLoader Installation
and check “Boot from Master Boot Record”

In “section Management”, add an entry for your WIndows partition if required (it might have been already added by Grub)

The 100MB extra partition is a Windows 7 thing (actually not really needed). If you installed Vista yourself and don’t see such a partition, this is prefectly normal.
MBR (Master Boot Record) describes the very first sector of your HD. It includes the partition table (start sector and size of the 4 primary partitions). The first sector a a partition is called the boot sector (BS).

Please Try Again,

I failed you kind sir. I failed to describe my issue. I do have a solid grasp on the concept of an MBR. My issue lies here.

I Cannot get into Linux. It goes straight to windows 7, there is no blootsplash or menu. 11.3 is literally invisible. I turn on the computer, and Winblow$ fires right up. There is no option to get into opensuse…

Help! I Need Somebody!

:slight_smile: Cheers :slight_smile:

At some point you have to boot Linux first. So, you could use openSUSE live CD (or any other Linux using legacy Grub … but not Ubuntu !!! because it uses Grub2). Once you are in Linux, you can use Yast2 (in case of openSUSE) to install Grub into MBR or you can type ‘grub’ in a terminal and then :

find /boot/grub/stage1
root (hd0,?)
setup (hd0)

where (hd0,?) is the Linux partition where /boot is located (probably your Linux / partition). You find out which partition with the first command.

Next time you boot, you will see Grub boot menu. Then you can add an entry to boot Windows, either with Yast or by editing /boot/grub/menu.lst.

Alternatively you can save Linux bootsector into a file and boot it from Windows bootloader (You’ll find out how if you google a little bit). But the Grub way is easier.

Re-Install Grub Quickly with Parted Magic

Thanks caf !


Hope it works out for you
It’s basically what @please_try_again posted but in a guide